radio streaming playback sound problem - mint 13

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
headroom27
Level 1
Level 1
Posts: 3
Joined: Fri Nov 28, 2014 12:20 pm

radio streaming playback sound problem - mint 13

Post by headroom27 »

Hi, when i play radio stream then sound after 40-50 min. hang up.


mplayer http://85.25.209.150:8100
MPlayer2 UNKNOWN (C) 2000-2011 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing http://85.25.209.150:8100.
Resolving 85.25.209.150 for AF_INET6...

Couldn't resolve name for AF_INET6: 85.25.209.150
Connecting to server 85.25.209.150[85.25.209.150]: 8100...

Name : STAR FM From Hell
Genre : Metal
Website: http://www.starfm.de
Public : yes
Bitrate: 128kbit/s
Cache size set to 320 KBytes
Cache fill: 0.00% (0 bytes)
ICY Info: StreamTitle='Halestorm - Love Bites (So Do I)';StreamUrl='';
Cache fill: 10.00% (32768 bytes)

Detected file format: Audio only
==========================================================================
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, floatle, 128.0 kbit/4.54% (ratio: 16000->352800)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 44100Hz 2ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A: 32.7 (32.7) of 0.0 (00.0) 1.2% 0%
Cache not filling, consider increasing -cache and/or -cache-min!
[AO_ALSA] Write error: Broken pipe
[AO_ALSA] Trying to reset soundcard.
A: 33.2 (33.1) of 0.0 (00.0) 3.2% 0%
Cache not filling, consider increasing -cache and/or -cache-min!
[AO_ALSA] Write error: Broken pipe
[AO_ALSA] Trying to reset soundcard.
A: 33.3 (33.3) of 0.0 (00.0) 32.6% 0%


Exiting... (End of file)

can someone help me ?
sorry my english.
thanks

rokytnji
Level 4
Level 4
Posts: 201
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX
Contact:

Re: radio streaming playback sound problem - mint 13

Post by rokytnji »

Code: Select all

·             select a station and play             ·
 ·                                                   ·
 · [space] to pause, [q] to stop, [Ctrl]+[c] to quit ·
 ·····················································

 ·····················································
 ·    1   Addict Alternative     2   Audio Ink       ·
 ·    3   Addict Rock            4   The Buzz        ·
 ·    5   Power_Rock             6   Schizophonic    ·
 ·    7   80s radio              8   Rock-Radio      ·
 ·    9   90s Radio             10   Radio Xenu      ·
 ·   11   WFMU                  12   Rage Radio      ·
 ·   13   KikiNovak Radio       14   AGX            ·
 ·   15   Progressive           16   BadRok Radio    ·
 ·   17   Classic Gator Rock    18   All Dixie Rock  ·
 ·   19   AMPZ Adult            20   106 Radio       ·
 ·····················································

 select a  number  from 1 to 20 then hit [Enter]

13
MPlayer2 2.0-701-gd4c5b7f-2ubuntu2 (C) 2000-2012 MPlayer Team
Cannot open file '/home/harry/.mplayer/input.conf': No such file or directory
Failed to open /home/harry/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.

Playing http://www.radionovak.com:8000/radionovak.ogg.
Resolving www.radionovak.com for AF_INET6...

Couldn't resolve name for AF_INET6: www.radionovak.com
Resolving www.radionovak.com for AF_INET...
Connecting to server www.radionovak.com[62.210.209.120]: 8000...

Name   : Radio Novak
Genre  : Various
Website: http://www.radionovak.com
Public : yes
Bitrate: 128kbit/s
Cache size set to 320 KiB
Cache fill:  0.00% (0 bytes)   

Detected file format: Ogg (libavformat)
[lavf] stream 0: audio (vorbis), -aid 0, Come Closer
Selected audio codec: Vorbis [libavcodec]
AUDIO: 44100 Hz, 1 ch, floatle, 128.0 kbit/9.07% (ratio: 16000->176400)
AO: [pulse] 44100Hz 1ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A: 204.1 (03:24.0) of 6232573214720.0 (1731270337:25:20.0)  0.9% 7% 
Cache not filling, consider increasing -cache and/or -cache-min!
Cache not filling, consider increasing -cache and/or -cache-min!
A: 301.6 (05:01.6) of 6232573214720.0 (1731270337:25:20.0)  1.1% 10% 
Hmmm, Even though my errors kinda resemble yours. I am listening to radio Kikonovak which is transmitting in ogg vorbis just fine.

Code: Select all

$ apt-cache policy mplayer
mplayer:
  Installed: (none)
  Candidate: 2:1.1+dfsg1-0ubuntu3
  Version table:
     2:1.1+dfsg1-0ubuntu3 0
$ apt-cache policy mplayer2
mplayer2:
  Installed: 2.0-701-gd4c5b7f-2ubuntu2
  Candidate: 2.0-701-gd4c5b7f-2ubuntu2
  Version table:
 *** 2.0-701-gd4c5b7f-2ubuntu2 0
But I am on Mint 17 instead of 13. Url I am listening to is site:

http://www.radionovak.com/

url:

http://www.radionovak.com:8000/radionovak.ogg
Hi, when i play radio stream then sound after 40-50 min. hang up.
I am running a cli radio player myself from a script so I wonder? Because I have not been running the radio for as long as you had yours on till
it cut off. Just wondering if you open the .pls or whatever file you are doing with smplayer if it will cut out.

To show what I mean.

Code: Select all

Latitude-XT2:~/Music/Stream Radio$ ls
100Hitz.pls             playlist.ram
106_rock.pls            ProgRock.pls
1FM.pls                 RadioDP.pls
2nd2none.pls            Radio_kikinovak
AGX.pls                 Radio_novak
All_Dixie_Rok.pls       Radio_Novak.pls
AmpZ_Adults.pls         Rage_989.pls
Audio_Ink.pls           ROCKRADIO.COM - 80's Alternative.pls
bglradio.pls            ROCKRADIO.COM - 90's Alternative.pls
Boardies.pls            ROCKRADIO.COM - Modern Rock.pls
Classic_Deep_cuts.pls   ROCKRADIO.COM - Progressive Rock.pls
classic_gator_rock.pls  Sanctuary.pls
Creek_valley.pls        Shizophonic.pls
Dangerous.pls           sinister.pls
Dark_Mother.pls         sit_mexico_radio.pls
Dead_to_self.pls        Supernatural.pls
DoomNation.pls          Sweet_Harmony.pls
Edge.pls                the_buzz.pls
GenX.pls                The_Edge101.pls
GotRadio.pls            TheRock.pls
Great_Big_Radio.pls     Total-Metal.pls
Hamilton.pls            tunein-station.pls
Lava.pls                V103.pls
Legion.pls              wakenradio.pls
MNR.pls                 wbrsfm.pls
morpheme-links          Wide_Radius.pls
namesaker.pls           Xenu.pls
Nuff.pls                xlr8.pls
To give you a idea what is inside a .pls file. Here is one of mine.

Code: Select all

[playlist]
numberofentries=1
File1=http://99.198.112.62:80
Title1=TotalMetalRadio (128kbps)
Length1=-1
Version=2
Maybe because I am listening in ogg vorbis instead of mp3 may be a issue? I don't know really. This behavior you are reporting seems a known mplayer bug
that has been around for years now and never fixed.

Good luck. 8)
Linux user 475019.

rokytnji
Level 4
Level 4
Posts: 201
Joined: Mon Nov 03, 2008 9:56 pm
Location: Pecos, TX
Contact:

Re: radio streaming playback sound problem - mint 13

Post by rokytnji »

Just a question. Did you pause the stream at any time before it quit. Because it will reach the end of the file being played and just stop. Meaning the stream needs restarting in mplayer.
Linux user 475019.

Post Reply

Return to “Sound, Multimedia, & Codecs”