No Connection to Bluetooth Speakers

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
ullices
Level 1
Level 1
Posts: 4
Joined: Fri Jan 23, 2015 8:41 am

No Connection to Bluetooth Speakers

Post by ullices » Thu Feb 05, 2015 12:18 pm

Hi everyone.

I used to have this problem, where establishing a connection to my bluetooth speakers was difficult, but possible.
I don't know what has happened, but now it completely stopped working. I get the "device added succesfully, but failed to connect" error in the blueman applet and the line

Code: Select all

pactl load-module module-bluetooth-discover
doesn't help any more, even though the output is not an error but a rather misterious "23".

Information about my system is in the linked post.
Thanks for your help!

Jerry
Level 3
Level 3
Posts: 113
Joined: Fri Dec 28, 2012 11:52 pm
Location: Canada

Re: No Connection to Bluetooth Speakers

Post by Jerry » Mon Feb 09, 2015 1:46 pm

intersesting. Most everywhere I go, I see the same problems encountered in LM bluetooth. I have this very same problem and have been working on it for days. I have also tried the

Code: Select all

pactl load-module module-bluetooth-discover
to no avail. That number that you give '23' suggests that f the module was not loaded you'll get a number as exit code and that being the case your next connection attempt should succeed. Apparantly, that is. But that is not really the case. I have tried to delete/remove my bluetooth speakers (Bose Soundlink Mini, in my case), then re-add them, then proceeed without pairing, all to no avail. My speakers are still having no throughput. When you look at the bottom of the 'Bluetooth Devices' dialogue box, do you see numbers representing the total data recieved and sent? Am asking because this theorectically represents the idea that because your speakers were added, there should be data stream. But when you turn off your BT speakers, the data stream stops as well. So if this is happening to you as well, it means that data is being sent/recieved, just that the speakers are obviously not correctly connected. And this is what I also have been searching for the last few days.

I should further add that this snafu lies not just only in the connection but further up as I've been realizing. Have dug throughout the net and came up with various posts from different linux forums. It seems that bluetooth support is more or less not just Ubuntu deriviatives but the problem lies further up the chain as you'll come to see when you read this thread below.
https://www.linuxliteos.com/forums/inde ... 65#msg1865

there is also the information from Launchpad. https://bugs.launchpad.net/ubuntu/+sour ... ug/1181106
It seems that BT support, or lack thereoff, is rampant throughout the Linux community. But I'm not giving up. If I find a method that works, I'll post here and let you know. But so far it doesn't look good as I've been discovering in my own experiences.
May you have good thermals.

Tom P
Level 2
Level 2
Posts: 93
Joined: Wed Jan 11, 2012 12:27 pm

Re: No Connection to Bluetooth Speakers

Post by Tom P » Sat Feb 21, 2015 6:36 pm

I can only sympathize. I managed to get Bluetooth to an external speaker working on Qiana, but in an attempt to get it working with an application that uses ALSA, it has now stopped working. I have been struggling for days without success to get it back. What I can see in the SYSLOG is:

Code: Select all

Feb 21 23:22:40 Presario-CQ56-Notebook-PC bluetoothd[703]: Protocol not supported (93)
Feb 21 23:22:40 Presario-CQ56-Notebook-PC pulseaudio[1983]: [pulseaudio] module-bluetooth-device.c: Failed to acquire transport /org/bluez/703/hci0/dev_04_FB_75_15_23_CF/fd0

The net effect is that it is impossible to get the A2DP protocol to work
The frustrating part is that there is no single authoritative description of how all the components Bluemon, blueZ, ALSA and PulseAudio are supposed to work together under Linux Mint, meaning there is no way way to debug the system in any coherent fashion. Instead there are dozens of bandaid fixes posted in any number of forums that may or may not be relevant for your own system.
I currently have the following setup in etc/bluetooth/audio.conf based on suggestions here http://www.aboutcher.co.uk/2014/04/linu ... -speakers/:

Code: Select all

[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
Enable = Source,Sink,Headset,Gateway,Control,Media
Disable = Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
#tep 21.feb.2015 https://www.linuxliteos.com/forums/index.php?topic=558.0
#HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0
What doesn't help is that I really have no idea what the various parameters mean. Are they documented somewhere?

For the record, the rest of my setup -

Code: Select all

inxi -Fxz
System:    Host: Presario-CQ56-Notebook-PC Kernel: 3.13.0-24-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: Gnome Distro: Linux Mint 17 Qiana
Machine:   System: Hewlett-Packard product: Presario CQ56 Notebook PC version: 0595100000242810010020100
           Mobo: Hewlett-Packard model: 1604 version: 88.06 Bios: Hewlett-Packard version: F.06 date: 11/08/2010
CPU:       Single core AMD V140 (-UP-) cache: 512 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 4588.26 clocked at 800.00 MHz 
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] bus-ID: 01:05.0 
           X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz 
           GLX Renderer: Gallium 0.4 on AMD RS880 GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card: Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-24-generic
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller 
           driver: r8169 ver: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: wl bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 320.1GB (30.6% used) 1: id: /dev/sda model: ST9320325AS size: 320.1GB 
Partition: ID: / size: 21G used: 6.6G (34%) fs: ext4 ID: /home size: 174G used: 85G (52%) fs: ext4 
           ID: swap-1 size: 4.02GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 71.6C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 152 Uptime: 2 min Memory: 435.5/3696.9MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4 

JeremyB
Level 18
Level 18
Posts: 8253
Joined: Fri Feb 21, 2014 8:17 am

Re: No Connection to Bluetooth Speakers

Post by JeremyB » Sun Feb 22, 2015 9:33 am

If any of you are using broadcom bluetooth devices you might need to update to 3.13.0-45 kernel and find the firmware for your device in a windows driver, just post the output of

Code: Select all

lsusb
And some Atheros bluetooth modules have issues with xhci and don't always load firmware at boot and there is a workaround for that

stephanwintner
Level 1
Level 1
Posts: 13
Joined: Sat Aug 24, 2013 8:23 am

Re: No Connection to Bluetooth Speakers

Post by stephanwintner » Sun Feb 22, 2015 6:25 pm

I got it to work !

OK, As several other have found, Bluetooth + A2DP +Pulse Audio + Mint 17 = not working.

I will refrain from repeating everything everyone else has written. in short, I have had to
a) edit my /etc/bluetooth/ audio.conf
b) use pactl load-module module-bluetooth-discover

and that worked, but not via A2DP, only via the telephony HFP/HCP protocol. But I found a way to get it to use A2DP.

c) remove the device
d) add the device using the command line not the Gnome GUI
$ hcitool scan
$ sudo bluez-simple-agent hci0 xx:xx:xx:xx:xx:xx (where xx:xx:xx etc is the address returned by the scan)
e) now restart pulseaudio & use pavucontrol to select A2DP (under configuration).
$ pulseaudio -k; pulseaudio --start
$ pactl load-module module-bluetooth-discover
$ pavucontrol &

And that finally actually caused it to use A2DP.

Step D was found at https://bbs.archlinux.org/viewtopic.php?id=157326

Hope that helps someone - Tom P, give it a try!
(full disclosure - I haven't rebooted, yet, so I will get the joy of discovering what is reqd on a new boot.)

I must echo Tom's frustration's though. It really shouldn't be this hard.

Stephan

Tom P
Level 2
Level 2
Posts: 93
Joined: Wed Jan 11, 2012 12:27 pm

Re: No Connection to Bluetooth Speakers

Post by Tom P » Wed Feb 25, 2015 6:03 am

Hi Stefan,
to make a comparison I plugged the Bluetooth adaptor into a different laptop which is running 32bit LM13, and - it works perfectly out of the box without any mods. The audio.conf only has two options set, and these are defaults anyway:

Code: Select all

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1
All the other options are commented out. I'm giving up trying to get LM17 working again, I'm installing 17.1

Kenbo11
Level 1
Level 1
Posts: 1
Joined: Fri Feb 27, 2015 9:03 pm

Re: No Connection to Bluetooth Speakers

Post by Kenbo11 » Fri Feb 27, 2015 9:21 pm

I installed mint just a week or two ago. The first thing I did was attempt to use my bluetooth headset. and of course it didn't work. But I noticed that I hadn't run update yet and among the 70 that were there, therer were some bluetooth related ones. After the updates the headset worked! I still have 1 problem tho. I have it set for a2dp, So if I get too far away, it of course disconnects. When I get close enough it connects again but in hsp not a2dp. And I always have to manually switch it back. How do I make it stay on a2dp permanently? Any ideas will be appreciated!

ullices
Level 1
Level 1
Posts: 4
Joined: Fri Jan 23, 2015 8:41 am

Re: No Connection to Bluetooth Speakers

Post by ullices » Wed Mar 04, 2015 8:07 pm

yeah! i tried stephanwintner's instructions and got it to work, too.

i did steps a) - d) as he suggested, for the very last step i had to install pavucontrol via apt-get.

first i was disappointed because my speakers were not listed in the pavucontol-interface. but then i opened the blueman-applet (the small bluetooth icon in the control panel), looked for my device in "Devices" -there it was- and tried to set it up via "Setup" -> SUCCESS!

stephan wintner, i am very grateful.

ullika

stephanwintner
Level 1
Level 1
Posts: 13
Joined: Sat Aug 24, 2013 8:23 am

Re: No Connection to Bluetooth Speakers

Post by stephanwintner » Fri Mar 06, 2015 2:14 am

You're welcome Ullika.

FWIW I once I rebooted it was unhappy again - and I haven't had time to fix it. No AD2P - but I figure I can always remove and re-connect it. Anyway, hope I helped.

Lumenary
Level 1
Level 1
Posts: 32
Joined: Fri Dec 04, 2009 11:55 pm
Location: US-OH-Newton Falls (TZ=EST/EDT)

Re: No Connection to Bluetooth Speakers

Post by Lumenary » Sun Mar 08, 2015 12:20 am

Hello Everyone,




I ran into this issue myself after loading my notebook with Mint Xfce 17.1 (Rebecca).



After much digging, including through sources listed in this thread, I stumbled upon an interesting tidbit... It seems that Blueman -- as originally written -- intentionally unloaded module-bluetooth-discover because (and according to the original Blueman author) PulseAudio "did not properly manage bluetooth headsets" during PA's early years.



Thus, it can be conjectured that any OS that is:
  1. Based on Trusty, and
  2. Relies on Blueman components to mange Bluetooth connectivity
will bork PulseAudio's ability to utilize Bluetooth headsets and speakers.



The relevant info can be found under David Henningsson's post #14 in Launchpad Bug #1274613:
[/list]
and under Issue #64 at the Blueman GitHub project repository:
[/list]


I can confirm that on my installation of Linux Mint Xfce 17.1 (Rebecca), the repaired Blueman package built by CSchramm and posted to a Launchpad PPA:
[/list]
did fix the problem with PulseAudio's Bluetooth Discovery subsystem.



However, problems with A2DP selectivity remained, until I adjusted my /etc/bluetooth/audio.conf as indicated here:

Code: Select all

# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket
Enable=Source,Sink,Headset,Gateway,Control,Media
Disable=Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
#HFP=false

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=false

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0


Hope this helps! :-)




Best Regards,

Lumenary
TZ=US-EST/EDT

Tom P
Level 2
Level 2
Posts: 93
Joined: Wed Jan 11, 2012 12:27 pm

Re: No Connection to Bluetooth Speakers

Post by Tom P » Tue Mar 10, 2015 4:20 pm

Sorry about delay in responding, I've had a lot of other realworld stuff to deal with.
I now have Rebecca 17.1 installed plus bluemon.
I made the changes as you suggested to audio.conf and updated ppa:

Code: Select all

sudo add-apt-repository ppa:cschramm/blueman
You are about to add the following PPA to your system:
 More info: https://launchpad.net/~cschramm/+archive/ubuntu/blueman
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.dPQb6Rbeqo --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys CE12015E
gpg: requesting key CE12015E from hkp server keyserver.ubuntu.com
gpg: key CE12015E: public key "Launchpad PPA for cschramm" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
The update manager is now reporting update available 1.23-git201406261335-deb-1

Code: Select all

sudo aptitude versions blueman
Package blueman:                        
i   1.23-git201403102151-1ubuntu1                 trusty                    500 
p   1.23-git201406261335-deb-1                    trusty                    500 

Package blueman:i386:
p   1.23-git201403102151-1ubuntu1                 trusty                    500 
p   1.23-git201406261335-deb-1                    trusty                    500 
So I installed this but I can't tell any difference in the behaviour, meaning that although it connects to the headphones, it doesn't show up as an output device. Is this update your modified version? How can I verify this?

Lumenary
Level 1
Level 1
Posts: 32
Joined: Fri Dec 04, 2009 11:55 pm
Location: US-OH-Newton Falls (TZ=EST/EDT)

Re: No Connection to Bluetooth Speakers

Post by Lumenary » Fri Mar 13, 2015 11:10 pm

Hello Tom,




Run this command:
  • sudo dpkg-query -s blueman
and check the results against those from my machine:

Code: Select all

Package: blueman
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 2527
Maintainer: Christopher Schramm <debian@shakaweb.org>
Architecture: amd64
Version: 1.23-git201406261335-deb-1
Depends: libbluetooth3 (>= 4.91), libc6 (>= 2.4), libglib2.0-0 (>= 2.31.8), libgtk2.0-0 (>= 2.16), libpython2.7 (>= 2.7), libstartup-notification0 (>= 0.4), python (>= 2.7), python (<< 2.8), python:any (>= 2.7.1-0ubuntu2), dbus, bluez (>= 4.61), obex-data-server (>= 0.4.3), python-gtk2 (>= 2.12), python-dbus, python-gi, python-notify, notification-daemon, librsvg2-common, gnome-icon-theme, python-appindicator, libpulse-mainloop-glib0
Recommends: python-gconf, policykit-1
Conffiles:
 /etc/xdg/autostart/blueman.desktop e58720ee51be5b3fcc1d47e7e82fc156
 /etc/dbus-1/system.d/org.blueman.Mechanism.conf 51b54bebb527e4291b0ec4b8ad6c9250
Description: Graphical bluetooth manager
 Blueman is a GTK+ bluetooth management utility for GNOME using bluez D-Bus
 backend.
Homepage: https://launchpad.net/blueman
The version you want ends in "...-deb-1" as indicated in the output posted above.



Once you've verified you have the correct version installed, delete all of your bluetooth devices out of Blueman, and remove your PulseAudio user-level configuration files as per the info listed here (for Ubuntu 14.04):
[/list]


Once everything has been removed, reboot your machine, and re-add your bluetooth headset device using the CSchramm-repaired Blueman.



You will then need to launch:
  • pavucontrol
and navigate to the [Output] tab to select the bluetooth headset. Finaly, click on the [Configuration] tab and make sure the device is set to the "High Fidelity Playback (A2DP)" option.



Let us know what happens...




Best Regards,

Lumenary
TZ=US-EST/EDT

Tom P
Level 2
Level 2
Posts: 93
Joined: Wed Jan 11, 2012 12:27 pm

Re: No Connection to Bluetooth Speakers

Post by Tom P » Thu May 21, 2015 12:43 pm

Hello Lumenary,

I finally got back to trying this stuff out again. The version of Blueman is exactly the same Christopher Schramm version that you have. However I seem to be going backwards. I can get the sound settings test LH and RH speaker to work, but no music comes of the bluetooth speakers. I tried VLC media player, Banshee and mixxx. Same result. This stuff is just too flakey for me. If Linux Mint ever brings out an edition that actually supports bluetooth audio, I try it again but meantime if I want bluetooth audio I'll just boot the Windows partition. Sorry about that.

a34fm
Level 1
Level 1
Posts: 3
Joined: Mon Jan 30, 2012 7:55 am

Re: No Connection to Bluetooth Speakers

Post by a34fm » Wed Jan 31, 2018 2:26 pm

:D Ok!!!
For me also worked with these two last commands, fully unexpectedly :evil: .
The bluetooth speaker is a Sony SRS-XB10. :P :P :P :P :P

stephanwintner wrote:I got it to work !

$ pactl load-module module-bluetooth-discover
$ pavucontrol &

And that finally actually caused it to use A2DP.

Stephan
IF you try, try and try after trying you may be lucky and not stuck(y).
A34

Post Reply

Return to “Sound, Multimedia, & Codecs”