Page 1 of 1

Multimedia Keys Not Working

Posted: Wed Jan 13, 2016 5:35 pm
by crusaderad
Ok, so this is the 2nd logitech keyboard I've tried. Keys like volume up / down and the mute button work. Play/Pause, Stop, Back, Forward don't work. I tried with multiple media players as well, my favorite being Banshee.

One weird thing about this... if I open the sound menu in Cinnamon (I use Mint 17.3) and hit a media key like pause, it works! Why not when the menu is closed?

Re: Multimedia Keys Not Working

Posted: Mon Jan 18, 2016 9:46 am
by crusaderad
Bump

Re: Multimedia Keys Not Working

Posted: Tue Jan 19, 2016 1:56 pm
by toddmaxwell
Try Ctrl + Fn and then your key

Re: Multimedia Keys Not Working

Posted: Tue Jan 19, 2016 2:28 pm
by crusaderad
Ctrl - Fn - Key fails.

Re: Multimedia Keys Not Working

Posted: Sat Dec 31, 2016 12:08 am
by ben2talk
Thanks for the info - same problem (though I hadn't discovered it working when I had the sound applet open).

This worked for me in Mint 17, but it's failing after moving on to Mint 18 (Cinnnamon).

So what gives?

Opened 'Configuration Editor'...
Browsed to / gnome/ sound
Now we have 'default_mixer_device' (key name /desktop/gnome/sound/default_mixer_device) owned by 'gnome'. This is apparently the 'default mixer device used by the multimedia key bindings'.

Interesting. Now I guess I'm going to cause more problems, because mostly I just play via pulse - but not for multichannel/passthrough (plex and sometimes audacious play via ALSA).

Let's see...

Hmmm after a few minutes I decided to test the guest account.
Then I just Ctrl+Alt+1 into a console and did an mdmrestart

alias mdmrestart='sudo service mdm restart' in .bashrc first, or type 'sudo service mdm restart'

That's all it needed. I guess 'reboot' would work, but mdm restart takes only 3 seconds now I have an SSD - a full restart still takes over 30 seconds with all the waiting for the motherboard and bios...

Re: Multimedia Keys Not Working

Posted: Tue Jan 17, 2017 6:48 pm
by rdonnelly

Re: Multimedia Keys Not Working

Posted: Fri Jan 27, 2017 9:06 pm
by jebeaudet
I have the same problem, linux mint 18 with cinnamon and the media keys just stopped working. Exact same thing, volume up/down and mute work properly but play/pause forward/back keys didn't. Keys worked in the sound applet though.

Re: Multimedia Keys Not Working

Posted: Fri Jan 27, 2017 9:15 pm
by jebeaudet
Hum, after realizing it worked after a reboot and not after a while, I think I've narrowed it to google chrome being open is the cause of the problem. When I close chrome, the play/pause next/back buttons start working again.

After digging some more, I found out it's a new extension that was hijacking the media keys. In my case, it was the plex extension however it can be the google play music for example. There seems to be a solution if you want to keep the extension but I decided to delete the extension in my case and the keys started working back again instantly yay! Here is the workaround : http://www.omgchrome.com/chrome-google- ... edia-keys/

Re: Multimedia Keys Not Working

Posted: Sun Mar 05, 2017 7:32 pm
by bobmcbobertson
I was having this problem in Linux Mint 18.1 with a fresh install. It was especially a problem controlling Banshee media player with my media keys. As others have stated, the volume and mute keys worked but not the keys for forward and back media key commands. Trying to manually assign key commands by creating new shortcuts and so forth didn't work either.

But I figured out what the problem was and solved the problem I was having, and this may work for some others as well.

First: Delete any custom shortcuts you have created for your media keys within your keyboard settings. (You're going to want to reassign everything after subsequent steps to be sure everything "takes")

Second: CHECK THE SETTINGS OF THE "SOUND" APPLET! This is important because, for me, THE SOUND APPLET WAS THE PROBLEM! I found that if I was running Banshee and left-clicked on the sound applet so it popped up, and then hovered my mouse over the popup, that I could use my media keys as I had assigned them. This is, of course, inconvenient because you have to keep your mouse in one place on the screen, hovering over the sound applet's popup--massively impractical.

SO: Go to the panel where your sound applet is located and right click it. Select "configure" and look over your settings. For me, "Control Players" was toggled on. I toggled it off after deleting my custom keyboard shortcuts, then I toggled it back on and re-entered custom keyboard shortcuts for banshee (banshee --next and banshee --previous and assigned the keys by pressing them etc again). After you've made the changes by toggling off "Control Players" and deleting the custom shortcuts, it may be a good idea to restart your computer--I did, just to be sure the change "took". Then when I re-assigned those keys back as custom shortcuts and toggled "Control Players" back on after the computer restarted, I restarted again after toggling "Control Players" back on and assigning the custom shortcuts again--this is just to be sure that cinnamon and all the applets etc are refreshed with the new settings (this may not be necessary, but I do it this way anyway, because I'm kinda old school and wanted to eliminate not having refreshed everything as a possible cause for why I wasn't getting the result I wanted after changing things)

I opened banshee up again and tried it and it has been working fine. I can control it using the media keys without having to have my mouse pointer hovering over the opened popup of the sound applet.

One thing though, you may need to toggle the "Control Players" setting in the sound applet on and off a time or two. Especially if you (as I was doing the first time I did this on one of my computers) are trying to do this without restarting and with the media player running etc as you are making changes, because you're trying to isolate what the problem is and want to be able to try and retry the keys between changes. :P

Again, though, I've only tried this for Banshee since it was the only program I was having this issue with and is the main media player I use. I'm not sure if this will work for other programs, but it's worth trying--I don't see why it wouldn't work since the process of assigning a custom shortcut etc should be the same for any other program as it is for banshee.

As to things others have said about Google Chrome sort of hijacking the keys etc, I have not had that issue happen to me, but I am wondering if that isn't related to this issue with the sound applet as well. It may be that the Chrome hijacking problem goes away once the sound applet is bound to the custom shortcuts for your media keys? If you are having that problem, you could try this trick of toggling "Control Players" off (if it's set to on) then deleting your custom shortcuts, and toggling back on and re-assigning the shortcuts again etc. and see if getting the key bindings to stick to the applet prevents Chrome from hijacking your players, too. I'm curious about if this will help for that problem, too. I've never had that issue with Chrome so I wouldn't even know how to test it, since I'm not sure why it's happening for some people and not for others.

Re: Multimedia Keys Not Working

Posted: Thu Mar 09, 2017 8:48 pm
by bobmcbobertson
Another trick I just learned that is easier to work with (and faster) than doing things as per my previous post:

Create a custom key binding for Banshee (for example I just created a custom key binding for banshee --toggle-playing and bound it to my media key that is a play/pause button on my keyboard) and when you assign the custom shortcut to the key, go the "Sound and Media" category under "Categories" (so, change from being under Custom Shortcuts like you are in when you create the custom shortcut to being under the Sound and Media category) and find the shortcut for that key (so for example I clicked "Play") and assign that key to that command in Keyboard Bindings. You will get a popup telling you "This key combination, ________________ (whatever the key and combo is for your key goes in that blank, in my case it was Audio play) is currently in use by ____________ (whatever you named your custom shortcut as will go in that blank) If you continue it will be reassigned to ________ (whatever key you are reassigning your custom shortcut to will go in that blank, in my case it was Play) Do you want to continue with this operation?"

Select Yes.

Now, go back to your custom shortcut for Banshee and assign that key back to the custom shortcut. You'll get the popup again that tells you the key is assigned to something else and that if you continue it'll be bound to your custom binding etc. Select yes again.

The key binding will actually work now. I kept having the problem of the custom binding not working, when I'd press the key I would get the popup in the center of the screen with the circle with the slash through it and all, and it wouldn't work. After binding the key to what is essentially the default, under Sound and Media, and then assigning it back to my custom key, it works flawlessly.

So if my other suggestion doesn't work, or if it is too time consuming to go through multiple restarts of the computer and all, then this will work and is something you can do in just seconds. It also seems to be independent of whether the sound applet is set to control media players or not. I have tried this with the sound applet toggle for controlling media players set to on and off, and it works no matter what that is set to--which also makes this way of dealing with the failure of the key to bind a much easier and faster way of solving the problem.

Re: Multimedia Keys Not Working

Posted: Thu Jul 06, 2017 8:53 pm
by brroad
Thank you! Google Play Music extension was hijacking the media keys. Disabled the extension, now it works!
jebeaudet wrote:Hum, after realizing it worked after a reboot and not after a while, I think I've narrowed it to google chrome being open is the cause of the problem. When I close chrome, the play/pause next/back buttons start working again.

After digging some more, I found out it's a new extension that was hijacking the media keys. In my case, it was the plex extension however it can be the google play music for example. There seems to be a solution if you want to keep the extension but I decided to delete the extension in my case and the keys started working back again instantly yay! Here is the workaround : http://www.omgchrome.com/chrome-google- ... edia-keys/

Re: Multimedia Keys Not Working

Posted: Wed Aug 01, 2018 12:19 pm
by Caltrop
where are all these settings talked about

my sound applet has no control players

there is no sound and media

I have checked keyboard shortcuts

still does not work after reboot

I am running Linux Mint Mate 18.2 with most updates installed
I am NOT doing anything kernel 4.15!

Re: Multimedia Keys Not Working

Posted: Tue Aug 13, 2019 7:07 am
by asandl
Hi -- posting this in August 2019 for anyone having this problem. As noted below by others, Chrome is often the culprit! I closed Chrome and the pause/next/previous track keys worked. Re-open Chrome and again stopped working.

One post below referred to this link: https://www.omgchrome.com/chrome-google ... edia-keys/. The information there was relevant for me -- one of my extensions was 'hijacking' or rather 'overriding' the media player controls on my wireless keyboard. The link refers to Google Play Music as being the culprit. But it can be any sound-related extension -- so scroll down through ALL the keyboard shortcuts and look for anything that refers to sound and shows the 'Global' option for this shortcut. That's the problem (or it was for me)! I had a Podcast Player app that showed Global option -- I just clicked on the dropdown and selected 'Chrome' as shown in the above link and all was well.

Hooray -- hope this helps someone else!

-Allen

Re: Multimedia Keys Not Working

Posted: Thu Aug 22, 2019 5:20 am
by Kout
Thanks Allen, it really helped me. Though in my case restarting Chrome was enough.
asandl wrote:
Tue Aug 13, 2019 7:07 am
Hi -- posting this in August 2019 for anyone having this problem. As noted below by others, Chrome is often the culprit! I closed Chrome and the pause/next/previous track keys worked. Re-open Chrome and again stopped working.

One post below referred to this link: https://www.omgchrome.com/chrome-google ... edia-keys/. The information there was relevant for me -- one of my extensions was 'hijacking' or rather 'overriding' the media player controls on my wireless keyboard. The link refers to Google Play Music as being the culprit. But it can be any sound-related extension -- so scroll down through ALL the keyboard shortcuts and look for anything that refers to sound and shows the 'Global' option for this shortcut. That's the problem (or it was for me)! I had a Podcast Player app that showed Global option -- I just clicked on the dropdown and selected 'Chrome' as shown in the above link and all was well.

Hooray -- hope this helps someone else!

-Allen