Playback of local videos is 'choppy'

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
User avatar
thx-1138
Level 6
Level 6
Posts: 1050
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Playback of local videos is 'choppy'

Post by thx-1138 » Fri Dec 22, 2017 6:36 am

...The "Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory" is most probably innocuous (vdpau is meant for nvidia cards), but just in case, you can set vlc, tools, input /codecs, hardware acceleration, try the vaapi settings there...

...I'm not personally familiar with Cinnamon & thereby how it handles compositing, Pjotr has some very good suggestions in his site though that will make it behave in a much more lightweight manner:
https://sites.google.com/site/easylinux ... n-Cinnamon

Just in case, check that you have the latest linux-firmware installed (it should be 1.157.4 currently)...
If nothing of the above does the trick, i really recommend trying out with a more recent kernel...
======================================================
lucky62 wrote:Some errors are there...

$ dmesg | grep -i error
[ 3.852605] mce: [Hardware Error]: Machine check events logged
[ 3.852608] mce: [Hardware Error]: CPU 2: Machine Check: 0 Bank 128: 0000000088192803
[ 3.852608] mce: [Hardware Error]: TSC 1115f191f8
[ 3.852609] mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1513887278 SOCKET 0 APIC 1 microcode 70
[ 3.858565] mce: [Hardware Error]: Machine check events logged
[ 3.858566] mce: [Hardware Error]: CPU 2: Machine Check: 0 Bank 128: 00000000881a2802
[ 3.858567] mce: [Hardware Error]: TSC 1116f9c06a
[ 3.858567] mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1513887278 SOCKET 0 APIC 1 microcode 70
[ 4.298720] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 128: 0000000088192803
[ 4.299600] mce: [Hardware Error]: TSC 1118062efc
[ 4.300836] mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1513887278 SOCKET 0 APIC 0 microcode 70
[ 4.301758] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 128: 00000000881a2802
[ 4.302694] mce: [Hardware Error]: TSC 11182606d1
[ 4.304460] mce: [Hardware Error]: PROCESSOR 0:806e9 TIME 1513887278 SOCKET 0 APIC 0 microcode 70
..........................................................
That however i'm afraid would need more investigation...check for suggestions here, and here...
Last edited by thx-1138 on Fri Dec 22, 2017 6:48 am, edited 2 times in total.

phelest
Level 1
Level 1
Posts: 17
Joined: Sun Jul 22, 2012 7:44 pm
Location: Nuremberg / Germany

Re: Playback of local videos is 'choppy'

Post by phelest » Fri Jan 19, 2018 9:02 pm

Is there a difference when disabling WLAN and using LAN ?
LinuxMint 18 definitely has a quite unfriendly problem with video streaming when using dedicated WLAN-HW - which LinuxMint 17 does not have at all!
This can be stated at least when older WLAN-HW is used, i.e. Lenovo Thinkpad T60 (Mate 32-bit) or P5W DH Deluxe of ASUS Digital Home Series (Mate 64-bit), while there is absolutely no problem when using LAN! ==> Activate the Netspeed Applet in the Panel and watch the Device Details to check when using WLAN!

carum carvi
Level 3
Level 3
Posts: 153
Joined: Sun Apr 16, 2017 11:44 pm

Re: Playback of local videos is 'choppy'

Post by carum carvi » Thu Feb 22, 2018 12:01 am

Maybe try searching the Vlc VideoLan Forum page for suggestions. I was searching for all kinds of difficult options on the linuxmint forum and in the end I just had to change the video output in my Vlc settings. And gone was the screen tearing and choppiness. I have got smooth video now with LinuxMint Cinnamon 18.3 and Nvidia Geoforce grahpics card which I definetely do not want to use because the opensource software of LinuxMint works fine.

The advice I got from the Vlc forum page is to change the video output in the settings of Vlc Media Player.
I just had to disable the Hardware Accelerated Video Output (Overlay) and I did this too in Firefox (Preferences-General-Performance) That is one setting found in the Video settings of Vlc and one setting in Firefox. Just two litte changes and all my problems were
solved: smooth video now !
Takes 2 minutes to try it out. Be aware that for changes to take place in Vlc Mediaplayer you must save changes first and close program second. Then start Vlc up again to test if the change has had ANY effect. Otherwise Vlc doesnt change its settings. That fooled me in the beginning.

Another advice I read on VideoLan Forum was to change the video output to ANY other than the current one. Maybe just experiment, or try VideoLan Forum.
https://forum.videolan.org/

jeffsp
Level 1
Level 1
Posts: 9
Joined: Mon Jun 27, 2016 8:48 pm

Re: Playback of local videos is 'choppy'

Post by jeffsp » Sun Mar 25, 2018 11:10 am

I have had the same problem ever since I upgraded to Linux Mint Version 18.3 + Cinnamon (64bit).

My "choppiness" sounds like the same thing in the OP: About every 10 or so seconds the video freezes on a single frame for about 100-300ms and then continues.

If I play a 6 second MP4 in XPlayer continuously in a loop, the freezes occur in different places relative to frame 0 on successive loops.

The choppiness occurs in both Chrome, Firefox, and XPlayer.

I tried disabling hardware acceleration in both Chrome and Firefox, but it did not help.

I also tried changing my video drivers between NVidia-384, xserver-xorg-video-nouveau, and NVidia-340, but they all exhibit the same behavior.

Code: Select all

$ inxi -F
System:    Host: tamago Kernel: 4.4.0-116-generic x86_64 (64 bit) Desktop: Cinnamon 3.6.7
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx Bios: American Megatrends v: 2301 date: 01/06/2014
CPU:       Octa core AMD FX-8320 Eight-Core (-MCP-) cache: 16384 KB 
           clock speeds: max: 3500 MHz 1: 1700 MHz 2: 1400 MHz 3: 1400 MHz 4: 1700 MHz 5: 2300 MHz 6: 1700 MHz
           7: 1700 MHz 8: 2300 MHz
Graphics:  Card-1: NVIDIA GM107 [GeForce GTX 750 Ti]
           Card-2: NVIDIA GM107 [GeForce GTX 750 Ti]
           Display Server: X.Org 1.18.4 drivers: nvidia,nouveau (unloaded: fbdev,vesa)
           Resolution: 3840x2160@60.00hz
           GLX Renderer: GeForce GTX 750 Ti/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.111
Audio:     Card-1 2x NVIDIA Device 0fbc driver: snd_hda_intelsnd_hda_intel Sound: ALSA v: k4.4.0-116-generic
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp9s0 state: down mac: 10:c3:7b:92:8f:b7
           Card-2: Ralink RT5372 Wireless Adapter
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 4480.9GB (54.3% used) ID-1: /dev/sda model: WDC_WD20EZRX size: 2000.4GB
           ID-2: /dev/sdb model: WDC_WD20EZRX size: 2000.4GB ID-3: /dev/sdc model: SanDisk_SDSSDXPS size: 240.1GB
           ID-4: /dev/sdd model: PNY_CS1311_240GB size: 240.1GB
Partition: ID-1: / size: 205G used: 20G (11%) fs: ext4 dev: /dev/sdd3
           ID-2: /home size: 1.8T used: 1.5T (85%) fs: ext4 dev: /dev/sda1
           ID-3: swap-1 size: 16.63GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 28.6C mobo: N/A gpu: 42C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 294 Uptime: 3 days Memory: 7156.8/32075.1MB Client: Shell (zsh) inxi: 2.2.35

mediclaser
Level 2
Level 2
Posts: 90
Joined: Tue Mar 20, 2018 2:28 pm

Re: Playback of local videos is 'choppy'

Post by mediclaser » Wed Apr 25, 2018 8:34 pm

newbie serena wrote:
Thu Feb 22, 2018 12:01 am
...
The advice I got from the Vlc forum page is to change the video output in the settings of Vlc Media Player.
I just had to disable the Hardware Accelerated Video Output (Overlay)...
This is the fix that works on my LM 18.3 laptop. Thanks for sharing.

Post Reply

Return to “Sound, Multimedia, & Codecs”