[SOLVED] Internal speaker volume problem LM 18 and 18.1 (working in LM 13, 17.3)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
rndmusr
Level 1
Level 1
Posts: 3
Joined: Sun Mar 19, 2017 2:25 pm

[SOLVED] Internal speaker volume problem LM 18 and 18.1 (working in LM 13, 17.3)

Postby rndmusr » Sun Mar 19, 2017 2:50 pm

Hello

I've been using LM 13 Mate with my HW, but now it's at end of support so I freshly installed LM 18.1 Mate. My problem is, that sound control/volume works fine with headphones plugged in. But when I want to use internal speakers, sound is almost muted and I'm able to change volume of speakers only via terminal - alsamixer - problem is, that after system reboot, or plugging and unplugging headphones internal speaker volume is again almost muted.

Card: HDA Intel
Chip: Realtek ALC269VB

Screenshot from LM 18.1 with Headphones plugged in (without any changes after reboot):
https://s24.postimg.org/yvmi4l6x1/plugged.png

Headphones unplugged:
https://s24.postimg.org/n7sga1hs5/unplugged.png

How it should look like:

Screenshot from LM 17.3 live session with Headphones plugged in:
https://s1.postimg.org/ptrtx89bj/plugged.png

Headphones unplugged:
https://s1.postimg.org/qkkk30bov/unplugged.png

I've tried things like pavucontrol, HDAJackretask but without success. In LM 13 Mate everything worked well with no workarounds. Live session LM 17.3 Mate worked also well, live session LM 18, 18.1 Mate, Debian 8 Mate, Debian 8 lxde didn't. Can someone help me please? :?:
Last edited by rndmusr on Wed Mar 22, 2017 5:31 pm, edited 8 times in total.

deepakdeshp
Level 8
Level 8
Posts: 2370
Joined: Sun Aug 09, 2015 10:00 am

Re: Internal speaker problem LM 18 and 18.1 (working in LM 13, 17.3)

Postby deepakdeshp » Mon Mar 20, 2017 2:16 am

Please try installing Kernel version 4.8.x. If this doesnt work, you can always revert to the present version.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .

rndmusr
Level 1
Level 1
Posts: 3
Joined: Sun Mar 19, 2017 2:25 pm

Re: Internal speaker problem LM 18 and 18.1 (working in LM 13, 17.3)

Postby rndmusr » Wed Mar 22, 2017 5:27 pm

Kernel update did not help.. tried 3 different 4.4 Kernels, 4.8 also.

I found exact same problem reported in this launchpad bug report from 2011 https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/697498 - in that time it was fixed by Kernel update.

Finally figured it out via HDAJackRetask.
Now when I plug in Headphones, Internal speaker is muted and Headphones are playing, when I unplug, speaker is playing but I think that proper state sould be, that Internal speaker is muted after Headphone unplugging (and you have to change volume manually via keyboard shortcut, or sound tray icon). I've got same state on other machine with another sound card and LM 17.3. This is acceptable state for now.

Things which can also help with linux sound troubleshooting are:

Code: Select all

alsamixer


Code: Select all

cd ~/
wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh


- diff output with for example output from usb/sd live session from system/kernel in which everything works.


Last bumped by rndmusr on Wed Mar 22, 2017 5:27 pm.


Return to “Sound, Multimedia, & Codecs”

Who is online

Users browsing this forum: No registered users and 7 guests