sound not working on new laptop, no alsa

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
oretas
Level 1
Level 1
Posts: 2
Joined: Fri Feb 12, 2016 5:37 am

sound not working on new laptop, no alsa

Postby oretas » Sun Jun 04, 2017 5:08 pm

I trawled forums and tried a bit of everything with no success.
The troubleshooting steps in that list helped me identify what's wrong but not how to fix it:
https://askubuntu.com/questions/57810/h ... ards-found


I'n stuck on step 4: no soundcard found when running aplay -l. Nothing fixes it.
I pass step 5 & 6. Here's my output for 6:

00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
Subsystem: CLEVO/KAPOK Computer Device 2410
Flags: bus master, fast devsel, latency 32, IRQ 129
Memory at df220000 (64-bit, non-prefetchable) [size=16K]
Memory at df200000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel, snd_soc_skl


If I try to open alsamixer, I get no such file or directory. I tried installing pavucontrol, adding myself as user to the audio group...

By the way, it's a brand new laptop and wireless internet wasn't working with Linux Mint Mate that I'm running until I upgraded to kernel v. 4.10.

deepakdeshp
Level 8
Level 8
Posts: 2371
Joined: Sun Aug 09, 2015 10:00 am

Re: sound not working on new laptop, no alsa

Postby deepakdeshp » Mon Jun 05, 2017 9:24 am

You can try installing different kernel versions. And blog to that version in recovery mode as you boot the system.
The kernel version which recognize s your sound card has to be found by trial and error. I would first start with version 4.9.31 then go downwards as 4.9.30 etc.
Good luck
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .


Return to “Sound, Multimedia, & Codecs”