Page 1 of 1

Getting music from my USB sound card...

Posted: Sat May 05, 2007 10:07 am
by starbase1
Hi All,
I just got started with Linux Mint - I am still very new to all this, and as I still cannot get my modem working, the idea of trying a Linux that already had the codecs installed had obvious appeal to me.

Sadly my initial attempts to play MP3 music have not been sucessful.

I think the root of the problem is that I have 2 sound cards, a low quality inboard one, and a high quality USB one. I found the system controls to select the USB sound card, and when I clicked on test, sound came out. (It also plays the shutdown tune OK).

But when I fire up Amarok, no sound comes out - though from the dancing level meters, and changing time, it is managing to decode the audio files OK. I could not find any option to choose a sound card inside Amarok, so is there anything else I can do?

I am running direct from the CD image, so I cannot reboot and keep the new settings...

All clues very welcome,

Posted: Sat May 05, 2007 1:19 pm
by nick
Have you tried, Settings/Configure Amarok/Output Plugin and try using another plugin i.e. Alsa, OSS, or any of the others?


Posted: Sat May 05, 2007 2:00 pm
by telic
I could not find any option to choose a sound card inside Amarok, so is there anything else I can do?
In amarok, select Settings > Configure Amarok, and look in the Engine and Media Devices sections. Try the autodetect options, or manually test a sound device/driver from the drop-down list. Double check the main Bianca > Preferences > Sound settings.

You might also need to tinker with the system sound mixer controls, to set/enable various audio input levels (I had to do that to get sound from xawtv, even though other TV software mostly worked as is). One good utility for this is gamix, which you can download (it's only 37k bytes in size) and install from the Terminal...

Code: Select all

sudo apt-get install gamix
Then invoke the gamix panel...

Code: Select all

This provides more control buttons and sliding levers than you can shake a stick at. Expand the gamix panel across your entire display and you still need the horizontal scroll bar to access all its knobs. (Your audio driver may need to be set to ALSA.)

You're running on the liveCD, so don't be shy about making a bad guess about configuration options. Mistakes will disappear when you reboot.

Good luck, and happy listening.


Posted: Mon May 07, 2007 1:23 pm
by starbase1
Thanks very much for such detailed responses, here's hoping!