Very Bad Sound Quality

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Very Bad Sound Quality

Postby vw98075 » Mon Jun 26, 2017 5:39 pm

After I restart my Linux Mint 18.1 installation on a dual boot PC, the sound is very bad for youtube as well as the sound test in the sound setting panel. How to fix it?
Last edited by vw98075 on Fri Oct 13, 2017 3:35 pm, edited 1 time in total.

User avatar
jimallyn
Level 16
Level 16
Posts: 6676
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Very Bad Sound Quality

Postby jimallyn » Mon Jun 26, 2017 8:08 pm

Does this mean after you have booted into your other OS (I assume Windows)? I once had problems with a dual boot system if I selected "restart" or "reboot" (or whatever they called it) from Windows. If I shut it down completely before booting into Linux, all was fine. Apparently Windows left something in an inappropriate condition. It might be good to know a bit more about your system. Open a terminal, enter inxi -Fxz and press Enter, then copy/paste the output of that command here.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Mon Jun 26, 2017 10:41 pm

Thanks very much for your inputs. I have rebooted it quite few times and the problem still exists. Here is the output of the command.

$ inxi -Fxz
System: Host: oem-Vostro-270s Kernel: 4.4.0-81-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.1 Serena
Machine: System: Dell product: Vostro 270s
Mobo: Dell model: 0XFWHV v: A00 Bios: Dell v: A11 date: 10/14/2013
CPU: Quad core Intel Core i5-3470S (-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 23155
clock speeds: max: 3600 MHz 1: 1623 MHz 2: 1680 MHz 3: 1689 MHz
4: 1684 MHz
Graphics: Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1920x1200@59.95hz
GLX Renderer: Mesa DRI Intel Ivybridge Desktop
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.4.0-81-generic
Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
driver: ath9k bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 04:00.0
IF: enp4s0 state: down mac: <filter>
Drives: HDD Total Size: 1004.1GB (4.6% used)
ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
ID-2: USB /dev/sdb model: USB_Disk size: 3.9GB
Partition: ID-1: / size: 189G used: 39G (22%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 4.16GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 177 Uptime: 12 min Memory: 1993.1/3823.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.461) inxi: 2.2.35


vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Wed Jun 28, 2017 1:31 pm

Can someone help me out on the sound problem? The sournd data is lost in a sound stream as I can tell.

User avatar
Flemur
Level 13
Level 13
Posts: 4543
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Very Bad Sound Quality

Postby Flemur » Wed Jun 28, 2017 2:02 pm

vw98075 wrote:I have rebooted it quite few times and the problem still exists.

Did you shut it down completely, as jimallyn suggested?
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Wed Jun 28, 2017 9:40 pm

Flemur wrote:
vw98075 wrote:I have rebooted it quite few times and the problem still exists.

Did you shut it down completely, as jimallyn suggested?


Yes, many times in the past day. Are there any possible solutions other than rebooting?

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Fri Jun 30, 2017 2:03 pm

Shall I perform this procedure, https://help.ubuntu.com/community/Sound ... gProcedure or reinstall pulseaudio?

Hoser Rob
Level 9
Level 9
Posts: 2824
Joined: Sat Dec 15, 2012 8:57 am

Re: Very Bad Sound Quality

Postby Hoser Rob » Fri Jun 30, 2017 3:30 pm

I'd try what the 1st answer here suggests ...

https://askubuntu.com/questions/508692/ ... any-module

... though where it says "nano /etc/modprobe.d/alsa-base.conf" that assumes a bit too much knowledge maybe.

First, nano may not be your simple text editor. I always install leafpad and use that, so I can never remember which editor comes with each Mint DE version even though I've had 'em all installed. Can't even remember what it is for Mint Xfce without looking and I have that on 2 machines ...

So in my case, with leafpad, the command would be ...

gksudo leafpad /etc/modprobe.d/alsa-base.conf

... and substitute the name of your editor. You need to run gksudo because you need sudo provileges to change anything in your root (/) folder, which is always in protected mode. You can read files from there otherwise ut not write to them. gksudo is needed for GUI programs.

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Sat Jul 01, 2017 12:36 pm

Thanks for the info although I am not 100 percent sure they are related.

I don't' have any output for the command "lspci -v | grep audio".

The followings are an output for the command "lsmod | grep snd"

Code: Select all

snd_hda_codec_hdmi     53248  1
snd_hda_codec_realtek    86016  1
snd_hda_codec_generic    77824  1 snd_hda_codec_realtek
snd_hda_intel          40960  3
snd_usb_audio         176128  1
snd_hda_codec         135168  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           73728  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_usbmidi_lib        36864  1 snd_usb_audio
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  2 snd_usbmidi_lib,snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
snd_pcm               106496  5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  21 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              16384  1 snd


And the followings is an output for the command "locate snd-hda-intel"

Code: Select all

/lib/modules/4.4.0-53-generic/kernel/sound/pci/hda/snd-hda-intel.ko
/lib/modules/4.4.0-77-generic/kernel/sound/pci/hda/snd-hda-intel.ko
/lib/modules/4.4.0-81-generic/kernel/sound/pci/hda/snd-hda-intel.ko

I add the line

Code: Select all

options snd-hda-intel model=generic


to the file /etc/modprobe.d/alsa-base.conf without a luck.

BTW, I have reinstalled PulseAudio without any improvement.

User avatar
phd21
Level 13
Level 13
Posts: 4892
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Very Bad Sound Quality

Postby phd21 » Sat Jul 01, 2017 1:19 pm

Hi "vw98075",

I just read your post and the good replies to it. Here are my thoughts on this as well.

You could try updating/upgrading your Linux Kernel, which is safe to do because if for some reason the new Linux Kernel did not work well, just reboot into advanced boot options menu and pick a previous one.

You can update/ upgrade the Linux Kernel through your Mint Update Manager, or install "Ukuu", then reboot afterwards. I installed and am running Linux Kernel v4.11.7 without any negative issues.

You can also try installing pulse audio equalizer and pulse audio volume control from the "Synaptic Package Manager (SPM)".

I always install and use "Qasmixer" as well.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
Flemur
Level 13
Level 13
Posts: 4543
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Very Bad Sound Quality

Postby Flemur » Sat Jul 01, 2017 1:56 pm

vw98075 wrote:BTW, I have reinstalled PulseAudio without any improvement.

Generally when you reinstall packages to correct a problem you should also delete your user files associated with that package; so delete the ~/*pulse* files, IIRC (I don't have pulseaudio),

Code: Select all

rm -r ~/.pulse*

Then relogin or reboot.

There might be more (?) :

Code: Select all

find ~ -iname "*pulse*"
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Sat Jul 01, 2017 7:27 pm

Flemur wrote:
vw98075 wrote:BTW, I have reinstalled PulseAudio without any improvement.

Generally when you reinstall packages to correct a problem you should also delete your user files associated with that package; so delete the ~/*pulse* files, IIRC (I don't have pulseaudio),

Code: Select all

rm -r ~/.pulse*

Then relogin or reboot.

There might be more (?) :

Code: Select all

find ~ -iname "*pulse*"

There isn't the directory ~/.pulse* in my box.

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Sat Jul 01, 2017 7:37 pm

phd21 wrote:Hi "vw98075",

I just read your post and the good replies to it. Here are my thoughts on this as well.

You could try updating/upgrading your Linux Kernel, which is safe to do because if for some reason the new Linux Kernel did not work well, just reboot into advanced boot options menu and pick a previous one.

You can update/ upgrade the Linux Kernel through your Mint Update Manager, or install "Ukuu", then reboot afterwards. I installed and am running Linux Kernel v4.11.7 without any negative issues.

You can also try installing pulse audio equalizer and pulse audio volume control from the "Synaptic Package Manager (SPM)".

I always install and use "Qasmixer" as well.

Hope this helps ...

My system is updated. And no luck. I get into SPM and don't know what I can do about pulseaudio other than marking it as reinstallation.

User avatar
Flemur
Level 13
Level 13
Posts: 4543
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Very Bad Sound Quality

Postby Flemur » Sat Jul 01, 2017 7:53 pm

vw98075 wrote:There isn't the directory ~/.pulse* in my box.

It might be a regular file.
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
phd21
Level 13
Level 13
Posts: 4892
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Very Bad Sound Quality

Postby phd21 » Sat Jul 01, 2017 8:02 pm

Hi "vw98075",

According to your "inxi -Fxzd", your kernel is not updated... Update it.

There is nothing wrong with selecting reinstall on pulse audio either...

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Sun Jul 02, 2017 2:18 pm

phd21 wrote:Hi "vw98075",

According to your "inxi -Fxzd", your kernel is not updated... Update it.

There is nothing wrong with selecting reinstall on pulse audio either...

Hope this helps ...


I did a update yesterday. Right now, I see "Your system is up to date" on the Update Manager. The inxi message was an output I run a few days ago.

User avatar
phd21
Level 13
Level 13
Posts: 4892
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Very Bad Sound Quality

Postby phd21 » Sun Jul 02, 2017 2:23 pm

Hi "vw98075",

Please re-run and post the new results of "inxi -Fxzd".
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Mon Jul 03, 2017 8:33 pm

phd21 wrote:Hi "vw98075",

Please re-run and post the new results of "inxi -Fxzd".


Code: Select all

System:    Host: oem-Vostro-270s Kernel: 4.4.0-83-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: Dell product: Vostro 270s
           Mobo: Dell model: 0XFWHV v: A00 Bios: Dell v: A11 date: 10/14/2013
CPU:       Quad core Intel Core i5-3470S (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 23155
           clock speeds: max: 3600 MHz 1: 3326 MHz 2: 3053 MHz 3: 3298 MHz
           4: 3081 MHz
Graphics:  Card: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1200@59.95hz
           GLX Renderer: Mesa DRI Intel Ivybridge Desktop
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-83-generic
Network:   Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
           driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 1004.1GB (4.0% used)
           ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
           ID-2: USB /dev/sdb model: USB_Disk size: 3.9GB
           Optical: /dev/sr0 model: HL-DT-ST DVD+-RW GHA2N
           rev: A103 dev-links: cdrom,cdrw,dvd,dvdrw
           Features: speed: 48x multisession: yes
           audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 189G used: 34G (19%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 4.16GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 209 Uptime: 1 min Memory: 875.1/3823.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


And I just install the 18,2 version as shown in the above output messages. The problem still exists.

vw98075
Level 1
Level 1
Posts: 35
Joined: Sat Dec 27, 2014 8:20 pm

Re: Very Bad Sound Quality

Postby vw98075 » Thu Jul 06, 2017 9:23 pm

It can not be resolved, I guess.

user815
Level 1
Level 1
Posts: 5
Joined: Thu Aug 10, 2017 6:51 am

Re: Very Bad Sound Quality

Postby user815 » Fri Aug 25, 2017 9:02 am

vw98075 wrote:It can not be resolved, I guess.


Do not be disappointed. I suggest you to install Linux Mint Debian Edition 2 Betsy. Because since it is Debian based, It will install required proprietary driver for you. I had bad sound issue with my laptop quite a sometime, It got fixed When I installed Debian and install proprietary Debian drivers for sound. So After that I decided to install LMDE 2 and installed LMDE 2. When I try to install proprietary audio drivers in LMDE 2, It was already installed. I was happy. :) Sound also works fine.


Return to “Sound, Multimedia, & Codecs”

Who is online

Users browsing this forum: No registered users and 3 guests