Sound output switches every reboot or after suspend

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
theoldfellow
Level 1
Level 1
Posts: 38
Joined: Wed Nov 30, 2011 3:47 am

Sound output switches every reboot or after suspend

Postby theoldfellow » Fri Aug 18, 2017 9:01 am

I am running Mint 16.2 on an 8-core AMD based system, Gigabyte MB, with a nVidia GTX1080Ti graphics card. My 2 monitors are connected to the GTX with HDMI cables.
Every time I boot, or after a suspend the sound OUTPUT setting switches at RANDOM between the 2 HDMI DisplayPorts or the S.PDIF or Headphones on the MB.
I keep resetting it to the main monitor using the Cinnamon Sound control, but it WILL NOT stay set.

How can I set it permanently?
Cheers,
TOF.

theoldfellow
Level 1
Level 1
Posts: 38
Joined: Wed Nov 30, 2011 3:47 am

Re: Sound output switches every reboot or after suspend

Postby theoldfellow » Fri Aug 18, 2017 9:05 am

inxi -Fxz
System: Host: rad1 Kernel: 4.10.0-27-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya
Machine: System: NOVATECH product: PERSONAL v: V1.0
Mobo: Gigabyte model: 970A-DS3P v: x.x
Bios: American Megatrends v: F2k date: 02/24/2015
CPU: Octa core AMD FX-8350 Eight-Core (-MCP-) cache: 16384 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 64295
clock speeds: max: 4000 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz
4: 1400 MHz 5: 1400 MHz 6: 1400 MHz 7: 1400 MHz 8: 1400 MHz
Graphics: Card: NVIDIA Device 1b06 bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
GLX Renderer: GeForce GTX 1080 Ti/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 384.59 Direct Rendering: Yes
Audio: Card-1 NVIDIA Device 10ef driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Card-3 Alcor Micro driver: USB Audio usb-ID: 001-004
Sound: Advanced Linux Sound Architecture v: k4.10.0-27-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 2370.5GB (9.1% used)
ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB
ID-2: /dev/sdb model: MAXTOR_STM325031 size: 250.1GB
ID-3: /dev/sdc model: Hitachi_HDS72302 size: 2000.4GB
Partition: ID-1: / size: 94G used: 14G (15%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 236M used: 118M (53%) fs: ext2 dev: /dev/sda1
ID-3: /home size: 197G used: 173G (92%) fs: ext4 dev: /dev/dm-4
ID-4: swap-1 size: 17.15GB used: 0.00GB (0%) fs: swap dev: /dev/dm-7
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 31.0C mobo: N/A gpu: 0.0:39C
Fan Speeds (in rpm): cpu: N/A fan-3: 0 fan-4: 0
Info: Processes: 267 Uptime: 22:31 Memory: 5822.7/16010.0MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35


pulseaudio --dump-conf
### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
local-server-type = user
cpu-limit = no
enable-shm = yes
flat-volumes = no
lock-memory = no
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-8.0/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target =
log-level = notice
resample-method = auto
enable-remixing = yes
enable-lfe-remixing = yes
lfe-crossover-freq = 120
default-sample-format = s16le
default-sample-rate = 44100
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 4
default-fragment-size-msec = 25
enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
deferred-volume-extra-delay-usec = 0
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 200000
Cheers,
TOF.


Return to “Sound, Multimedia, & Codecs”