[SOLVED] No soundcard found Linux Mint 18.

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
MrFraser
Level 1
Level 1
Posts: 12
Joined: Fri Oct 13, 2017 2:35 am

[SOLVED] No soundcard found Linux Mint 18.

Postby MrFraser » Fri Oct 13, 2017 2:53 am

Hello, i'm new to this forum. I just installed OSS and uninstalled it due to no sound. I revert back to ALSA and suddently this message appear when i type

Code: Select all

alsamixer


Code: Select all

cannot open mixer: No such file or directory


This is my

Code: Select all

lspci -v | grep -i audio


Code: Select all

00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
   Subsystem: Lenovo 7 Series/C210 Series Chipset Family High Definition Audio Controller


It appear that i've got no soundcards found

Code: Select all

aplay --list-devices


Code: Select all

aplay: device_list:268: no soundcards found...


This is my

Code: Select all

inxi -Fxz


Code: Select all

System:    Host: faeez-Laptop Kernel: 4.10.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 2.24.30) Distro: Linux Mint 18.2 Sonya
Machine:   System: LENOVO product: 20244 v: Lenovo G400s
           Mobo: LENOVO model: INVALID v: 00000000Not Defined Bios: LENOVO v: 7BCN38WW(V2.04) date: 12/10/2013
CPU:       Dual core Intel Core i3-3110M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
           clock speeds: max: 2400 MHz 1: 2400 MHz 2: 2396 MHz 3: 2400 MHz 4: 2400 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller bus-ID: 00:1b.0
Network:   Card-1: Qualcomm Atheros QCA8172 Fast Ethernet driver: alx port: 2000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 2004.4GB (24.9% used) ID-1: /dev/sda model: ST1000LX015 size: 1000.2GB
           ID-2: /dev/sdb model: ST1000LM014 size: 1000.2GB ID-3: USB /dev/sdc model: DT_101_G2 size: 4.0GB
Partition: ID-1: / size: 92G used: 12G (14%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 811G used: 313G (41%) fs: ext4 dev: /dev/sda7
           ID-3: swap-1 size: 16.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 59.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 249 Uptime: 19 min Memory: 1812.3/5834.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35


and

Code: Select all

cat /etc/os-release


Code: Select all

NAME="Linux Mint"
VERSION="18.2 (Sonya)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 18.2"
VERSION_ID="18.2"
HOME_URL="http://www.linuxmint.com/"
SUPPORT_URL="http://forums.linuxmint.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/linuxmint/"
VERSION_CODENAME=sonya
UBUNTU_CODENAME=xenial
Last edited by MrFraser on Tue Oct 17, 2017 8:04 am, edited 1 time in total.

rene
Level 6
Level 6
Posts: 1338
Joined: Sun Mar 27, 2016 6:58 pm

Re: No soundcard found Linux Mint 18.

Postby rene » Fri Oct 13, 2017 9:01 am

MrFraser wrote:I just installed OSS and uninstalled it due to no sound.

Installed from the repositories with an apt-get install and uninstalled with apt-get remove? If so you have lingering ALSA blacklisting in /etc/modprobe.d/oss4-base_noALSA.conf. Fix by repeating the, e.g., apt-get remove oss4-base oss4-dkms command you used but this time as apt-get purge oss4-base oss4-dkms instead.

Removal of configuration files resp. not is the exact difference between apt-get purge resp. apt-get remove and as such this makes general sense. Given the in this case resulting situation I feel it makes significantly less specific sense; would be inclined to consider this an oss4-base package bug. Anyone feel free to find their mileage to vary. I would have more issue with anyone finding an OSS install on a modern system to make sense in the first place...

Even if you did not install OSS from the repositories the above is likely still the problem. Find the correct uninstall method in its documentation and/or delete OSS-related content in /etc/modprobe.conf or under /etc/modprobe.d/ manually.

MrFraser
Level 1
Level 1
Posts: 12
Joined: Fri Oct 13, 2017 2:35 am

Re: No soundcard found Linux Mint 18.

Postby MrFraser » Fri Oct 13, 2017 3:13 pm

apt-get remove oss4-base oss4-dkms

Here you go

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'oss4-base' is not installed, so not removed
Package 'oss4-dkms' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.


and
apt-get purge oss4-base oss4-dkms

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'oss4-base' is not installed, so not removed
Package 'oss4-dkms' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.


but somehow, i'll found other site to put this code

Code: Select all

sudo apt-get install --reinstall alsa-utils alsa-oss alsa-base libasound2 libasound2-plugins linux-sound-base gstreamer0.10-alsa


and i can open up

Code: Select all

alsamixer
from terminal but got no sound. Forgot to mentioned that before this i've got no input and output devices, after i'll using this code, it appears. :?

MrFraser
Level 1
Level 1
Posts: 12
Joined: Fri Oct 13, 2017 2:35 am

Re: No soundcard found Linux Mint 18.

Postby MrFraser » Fri Oct 13, 2017 3:29 pm

i just run this

Code: Select all

gedit /etc/modprobe.d/alsa-base.conf



there you go

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


i curious if the order is correct

Code: Select all

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2

MrFraser
Level 1
Level 1
Posts: 12
Joined: Fri Oct 13, 2017 2:35 am

Re: No soundcard found Linux Mint 18.

Postby MrFraser » Fri Oct 13, 2017 3:33 pm

You know what's the fun part, after applying

Code: Select all

sudo apt-get install --reinstall alsa-utils alsa-oss alsa-base libasound2 libasound2-plugins linux-sound-base gstreamer0.10-alsa
IT WORK OUT!!!, but the sound effect is not working...

MrFraser
Level 1
Level 1
Posts: 12
Joined: Fri Oct 13, 2017 2:35 am

Re: No soundcard found Linux Mint 18.

Postby MrFraser » Mon Oct 16, 2017 9:28 pm

Solved by run this

Code: Select all

sudo apt-get install libcanberra-pulse

rene
Level 6
Level 6
Posts: 1338
Joined: Sun Mar 27, 2016 6:58 pm

Re: No soundcard found Linux Mint 18.

Postby rene » Tue Oct 17, 2017 5:35 am

Why the bump? Is there a problem left?

MrFraser
Level 1
Level 1
Posts: 12
Joined: Fri Oct 13, 2017 2:35 am

Re: No soundcard found Linux Mint 18.

Postby MrFraser » Tue Oct 17, 2017 7:54 am

sorry, wrong click, i just want to edit and put [SOLVED]
can't see any option here.

rene
Level 6
Level 6
Posts: 1338
Joined: Sun Mar 27, 2016 6:58 pm

Re: No soundcard found Linux Mint 18.

Postby rene » Tue Oct 17, 2017 8:01 am

Indeed. This forum employs the high tech technique of making you go back to your original post and edit the subject line to say [SOLVED] or some such at start or end.

MrFraser
Level 1
Level 1
Posts: 12
Joined: Fri Oct 13, 2017 2:35 am

Re: [SOLVED] No soundcard found Linux Mint 18.

Postby MrFraser » Tue Oct 17, 2017 8:05 am

i get it now, thank you :D


Return to “Sound, Multimedia, & Codecs”