Volume goes from 0 to 100 in 1% on aux [solved]-ish

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
TrySpace
Level 1
Level 1
Posts: 6
Joined: Thu Nov 02, 2017 11:11 am

Volume goes from 0 to 100 in 1% on aux [solved]-ish

Postby TrySpace » Thu Nov 02, 2017 11:17 am

When I play audio on my `aux` headphone output, when the master-volume is 0% no sound is heard, no problem there. However, when I go to 1% or anything between that and 100%, the volume is at 100%, and doesn't change in audible volume/db, until it goes over 100%, like 115% it's audibly louder.

So basically the audio goes from 0 to 100. While the internal sound volume (it's a laptop) works fine. And it switches between them automatically fine when I plug in a headphone.

Also, this is not a an issue with the hardware itself, because this has work normally before and still works fine with windows 10. (I think it even might have something to do with `i3`, because I think it worked fine with Cinnamon)

I've tried googling this issue, but I can't find any prior cases or the right search terms to use.

When I open `pavucontrol` I can control the volume there per application, that is the only way to control the volume, but not with the master volume.


This might help:

❱ inxi -Fxz
System: Host: me2 Kernel: 4.10.0-35-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: i3 4.14.1 Distro: Linux Mint 18.2 Sonya
Machine: Mobo: Micro-Star model: MS-17B1 v: REV:1.0
Bios: American Megatrends v: E17B1IMS.310 date: 04/07/2017
CPU: Quad core Intel Core i7-7700HQ (-HT-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
clock speeds: max: 2700 MHz 1: 2800 MHz 2: 2800 MHz 3: 2800 MHz 4: 2800 MHz
5: 2800 MHz 6: 2800 MHz 7: 2800 MHz 8: 2800 MHz
Graphics: Card-1: Intel Device 591b bus-ID: 00:02.0
Card-2: NVIDIA Device 1c20 bus-ID: 01:00.0
Display Server: X.Org 1.18.4 driver: nvidia
Resolution: 1920x1080@60.00hz, 3840x2160@60.00hz, 1920x1080@59.93hz
GLX Renderer: GeForce GTX 1060/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 375.66 Direct Rendering: Yes
Audio: Card Intel Device a171 driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.10.0-35-generic
Network: Card-1: Qualcomm Atheros Device e0b1 driver: alx port: d000 bus-ID: 3d:00.0
IF: enp61s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
driver: ath10k_pci bus-ID: 3e:00.0
IF: wlp62s0 state: down mac: <filter>
Card-3: Atheros usb-ID: 001-007
IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives: HDD Total Size: 2000.4GB (5.6% used)
ID-1: /dev/nvme0n1 model: N/A size: 512.1GB
ID-2: /dev/sda model: ST2000LM015 size: 2000.4GB
ID-3: /dev/mmcblk0 model: N/A size: 124.5GB
Partition: ID-1: / size: 119G used: 17G (15%) fs: ext4 dev: /dev/nvme0n1p5
ID-2: /home size: 67G used: 60G (94%) fs: ext4 dev: /dev/nvme0n1p7
ID-3: swap-1 size: 32.00GB used: 0.19GB (1%) fs: swap dev: /dev/dm-0
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 62.5C mobo: 27.8C gpu: 0.0:48C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 392 Uptime: 1 day Memory: 12399.8/15929.3MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (zsh 5.1.1) inxi: 2.2.35


Output of `pacmd info`: https://gist.github.com/anonymous/e1911 ... e2d09d5c3f
Last edited by TrySpace on Fri Nov 24, 2017 8:57 am, edited 1 time in total.

User avatar
catweazel
Level 10
Level 10
Posts: 3468
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Volume goes from 0 to 100 in 1% on aux

Postby catweazel » Fri Nov 03, 2017 7:55 pm

As a first step, run alsamixerin a terminal. Press F6 to select your sound card and check the settings it shows you.
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

TrySpace
Level 1
Level 1
Posts: 6
Joined: Thu Nov 02, 2017 11:11 am

Re: Volume goes from 0 to 100 in 1% on aux

Postby TrySpace » Tue Nov 07, 2017 9:40 am

catweazel wrote:As a first step, run alsamixerin a terminal. Press F6 to select your sound card and check the settings it shows you.


It shows 1 card: `0 HDA Intel PCH`

Furthermore, the master volume in alsamixer moves around like expected, however, the output volume of the aux is still not affected.

ALSAMIXER.png

TrySpace
Level 1
Level 1
Posts: 6
Joined: Thu Nov 02, 2017 11:11 am

Re: Volume goes from 0 to 100 in 1% on aux

Postby TrySpace » Tue Nov 07, 2017 9:52 am

This is interesting though:

When below 8%, I still have sound, and the Front speaker goes down (still no audible difference in the AUX though...)
Alsamixer says 0%:
ALSA_2.png

But Pavucontrol is more accurate:
PAVU.png


So when pavu says 5%, , alsa says Front: 58%;
At 8%, alsa Front is 100%
At 2%, alsa says 22%
4% = 51%
However, even between that range the AUX still has no difference in volumen, still on/off. So the `Front` is not linked to my AUX.

TrySpace
Level 1
Level 1
Posts: 6
Joined: Thu Nov 02, 2017 11:11 am

Re: Volume goes from 0 to 100 in 1% on aux

Postby TrySpace » Tue Nov 07, 2017 10:14 am

I'm even more confused now, suddenly the laptop speakers were pumping out the music I was testing with. I think I've never noticed it until now, because I just kept the volume at 8% in order not to accidentally blow up my speakers when I unplug my headphone.

But now it seems as though it's the `PCM` which is in control of the volume, if I move that around, the volume on my AUX does change, but this does require me to set the master to at least 1%, which means there is still music coming out of my speakers.

One last interesting/odd behaviour:
When I put pavu at 1%:
PAVU_1.png

The PCM changes to 99%
ALSA_PCM_1.png

TrySpace
Level 1
Level 1
Posts: 6
Joined: Thu Nov 02, 2017 11:11 am

Re: Volume goes from 0 to 100 in 1% on aux

Postby TrySpace » Fri Nov 24, 2017 8:51 am

So in summary

- The internal speakers don't mute when I plug in the headphones (this is a different issue than this post)
- The internal speakers work fine with the master volume.

- The AUX output is not shown in `Output Devices` which might be the main problem here.
- The AUX volume only changes when the main volume is above 100%
- The AUX volume can only be changed by changing the volume of the source app, or under the `Playback` tab in pavucontrol.

- Under configuration tab in pavucontrol the profile `Analogue Stereo Duplex` or `Analogue Stereo Output` gives me sound through the AUX, the others don't

TrySpace
Level 1
Level 1
Posts: 6
Joined: Thu Nov 02, 2017 11:11 am

Re: Volume goes from 0 to 100 in 1% on aux

Postby TrySpace » Fri Nov 24, 2017 8:56 am

I solved the output problem

Selecting `Digital Stereo (IEC958) Output` will mute my speakers, and the master volume will work on the AUX.

For some reason the `Output Devices` port will say `S/PDIF`, while it is not an optical plug, just a stereo jack.

Anyways, now I'll just need to find a way to detect the plugging in of the AUX which is a different topic entirely.

I hesitate to close the issue, since the 0 to 100% is still strange and not expected behaviour.


Return to “Sound, Multimedia, & Codecs”