Front panel detection for headphone jack

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Sethlance
Level 1
Level 1
Posts: 1
Joined: Fri Nov 03, 2017 7:13 am

Front panel detection for headphone jack

Post by Sethlance » Fri Nov 03, 2017 7:50 am

So I have a pretty old chipset and I use realtek hd drivers. On windows there was an app "realtek hd audio manager", that would install itself alongside with drivers. That app had a function to disable front audio panel detection, which allowed to use rear ports in a better "free" way and was the only way for me to use headphones with both channels. I really have no idea how it all works, but now that I switched to Linux, nothing seems to work and I only have sound in one channel, which is the fault of the hardware, I believe.
Is there any software that could do that?

User avatar
wutsinterweb
Level 5
Level 5
Posts: 645
Joined: Tue Feb 28, 2017 2:14 am
Location: Connecticut, USA

Re: Front panel detection for headphone jack

Post by wutsinterweb » Tue Dec 05, 2017 11:11 pm

I just found QasMixer, give it a try, it helped my similar problem.
I'm just a student, your guidance is appreciated.

User avatar
ArtGirl
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

Re: Front panel detection for headphone jack

Post by ArtGirl » Wed Dec 06, 2017 6:18 am

I'm not sure if pavucontrol and gnome-alsamixer (both installed via Synaptic Package Manager) might have the features you need ... looking at gnome-alsamixer, it has 'mute' settings, and a sound card settings tab that might shut off some things. :)
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150


For any advice I've been able to add, eg re graphics tablets, please search forum.

Image

refeed
Level 1
Level 1
Posts: 1
Joined: Thu Jul 12, 2018 9:55 am

Re: Front panel detection for headphone jack

Post by refeed » Thu Jul 12, 2018 10:00 am

I'm not sure if pavucontrol and gnome-alsamixer (both installed via Synaptic Package Manager) might have the features you need ... looking at gnome-alsamixer, it has 'mute' settings, and a sound card settings tab that might shut off some things. :)
Thank you very much.

Using `pavucontrol` solved my issue. In pavucontrol, in "Output Devices" tab there's a "Port" selection, changing it to "Headphones" makes my front port works again..

Post Reply

Return to “Sound, Multimedia, & Codecs”