Can't get built-in microphone on my headphones to work on my PC.

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
ht2000
Level 1
Level 1
Posts: 7
Joined: Sat Nov 04, 2017 1:36 am

Can't get built-in microphone on my headphones to work on my PC.

Postby ht2000 » Sat Nov 04, 2017 1:41 am

I had this problem for a couple months now and i'm running Mint 18.2. I think the problem is due to the lack of drivers for Realtek Audio. Can I please get help with this? Due to this problem, I couldn't talk to my friends on TeamSpeak and Skype. I would really appreciate it if this problem could be fixed.

User avatar
phd21
Level 13
Level 13
Posts: 4911
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby phd21 » Sat Nov 04, 2017 10:40 am

Hi "ht2000",

Welcome to the wonderful world of Linux Mint and its excellent forum !

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

FYI: Install pulseaudio volume control. And, there are some really nice graphical (GUI) programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager (SPM) that you can install and use. Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" and make it fullscreen, on the right side you will have mixer devices where you can control your system sound. If you do not see the mixer devices, hit "F6". The mixer item "sysdefault" will show all installed sound card devices, and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. Check to make sure the microphone button is enabled in lower right and all input and capture options (sliders) are enabled and at least half way up. There are also various other check boxes below that you can use, and depending upon your sound card(s) that sometimes includes headphone checkboxes and or sliders as well, like "Headphone Jack Sense".

The applications included are:
- qasconfig - browser for the alsa configuration tree
- qashctl - mixer for alsa's high level control interface
- qasmixer - desktop mixer with features similar to alsamixer

Qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a sytem tray icon with basic mixer functionality.


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

ht2000
Level 1
Level 1
Posts: 7
Joined: Sat Nov 04, 2017 1:36 am

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby ht2000 » Sat Nov 04, 2017 1:58 pm

Here you go,

System: Host: mint Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya
Machine: Mobo: HP model: 2B47 v: 1.04 Bios: AMI v: A0.16 date: 03/17/2016
CPU: Quad core Intel Core i5-6400 (-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 21696
clock speeds: max: 3300 MHz 1: 899 MHz 2: 899 MHz 3: 899 MHz
4: 899 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM]
bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.00hz
GLX Renderer: Gallium 0.4 on AMD BONAIRE (DRM 2.46.0 / 4.8.0-53-generic, LLVM 3.8.0)
GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Intel Sunrise Point-H HD Audio
driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network: Card-1: Intel Wireless 3165 driver: iwlwifi bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
IF: enp3s0 state: down mac: <filter>
Drives: HDD Total Size: 2159.9GB (0.5% used)
ID-1: /dev/sda model: SAMSUNG_MZ7LN128 size: 128.0GB temp: 0C
ID-2: /dev/sdb model: WDC_WD20EZRZ size: 2000.4GB temp: 26C
ID-3: USB /dev/sdc model: Cruzer_Blade size: 31.5GB temp: 0C
Optical: /dev/sr0 model: hp HLDS DVDRW GUD1N
rev: LD02 dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 24x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: swap-1 size: 8.52GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 25.0C mobo: N/A gpu: 29.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 205 Uptime: 31 min Memory: 863.5/7919.3MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0781:5567 SanDisk Corp. Cruzer Blade
Bus 001 Device 003: ID 8087:0a2a Intel Corp.
Bus 001 Device 002: ID 1af3:0001
Bus 001 Device 005: ID 1b1c:1b2d Corsair
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

It detects my headphones fine but I can't use the bulit-in microphone on it.

ht2000
Level 1
Level 1
Posts: 7
Joined: Sat Nov 04, 2017 1:36 am

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby ht2000 » Sat Nov 04, 2017 2:03 pm

Recently a month or two ago because of this issue, I reinstalled Windows 10. Right now i'm just using Mint live.

User avatar
phd21
Level 13
Level 13
Posts: 4911
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby phd21 » Sat Nov 04, 2017 3:21 pm

Hi "ht2000",

I do not see anything wrong with the results of the "inxi -Fxzd" console terminal command, so that is a good thing. Your CPU (processor) is not running in "performance mode", if you want to change that, search for "performance mode" in this forum.

What does "using Mint live" mean? Do you have Linux Mint fully installed, or are you running the Live, test drive, installation version of Linux Mint which will not keep your settings or changes upon restarting?

Did you install "qasmixer"? If so, can you please provide us with a full screen picture of that on the "sysdefault" mixer option?

Does your headphone (headset) have separate cords for microphone and headphones, or one cord for both? Does you computer have audio jacks in the front and in the back of your computer? My Dell Optiplex 780 does have front audio jacks and audio jacks in back, but my microphone will only work from the front microphone jack.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

ht2000
Level 1
Level 1
Posts: 7
Joined: Sat Nov 04, 2017 1:36 am

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby ht2000 » Sat Nov 04, 2017 7:53 pm

No, what I was trying to say was that because of that issue i've been having I reinstalled Windows 10 a month or two ago or in other words I went back to Windows but I attempted to try and fix the issue today by running Linux Mint 18.2 of a USB live but it didn't seem to work. Yeah I install those software's you mentioned but it didn't help. I notice on Windows 10 when using the built-in microphone on my headphones, it would detect Realtek High Definition Audio while browsing the audio setting on TeamSpeak and Skype but that doesn't seem to appear on Linux Mint nor does it detect any input audio devices whatsoever in the sound menu. I think the problem is that I need to install a proprietary driver for Realtek High Definition Audio. I always plug my headphones on the same port as always on the front of my PC case and it will always detect the built-in microphone from my headphones on Windows but not on Linux Mint.

I think installing this driver would fix this problem but I have no idea how to install it.

http://www.realtek.com.tw/downloads/dow ... Down=false

ht2000
Level 1
Level 1
Posts: 7
Joined: Sat Nov 04, 2017 1:36 am

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby ht2000 » Sat Nov 04, 2017 8:01 pm

I have audio jacks at the back of my PC but their used for my speakers. Besides I couldn't plug my headphones at the back anyway. The cord isn't long enough so it would feel uncomfortable.

User avatar
phd21
Level 13
Level 13
Posts: 4911
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby phd21 » Sat Nov 04, 2017 8:10 pm

Hi "ht2000",

You did not say whether you are running a fully installed Linux Mint or a "live" demo version.

You did not provide screenshots of qasmixer on the sysdefault mixer.

You did not mention whether your headphones have 2 cords (one for mic and one for headphones), or just one connector cord?

Your system looks like it recognizes two audio devices.
Audio:
Card-1 Advanced Micro Devices [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Intel Sunrise Point-H HD Audio
driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic


You could also try updating your Linux Kernel from within the Mint Update Manger to the 4.11 series or 4.12 series (always reboot after Kernel update).


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

ht2000
Level 1
Level 1
Posts: 7
Joined: Sat Nov 04, 2017 1:36 am

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby ht2000 » Sat Nov 04, 2017 8:34 pm

My headphone only has one cord which is 3.5 jack. I'll send the screenshots in a bit.

ht2000
Level 1
Level 1
Posts: 7
Joined: Sat Nov 04, 2017 1:36 am

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby ht2000 » Sat Nov 04, 2017 8:38 pm

Well I also have speakers connected on the back on my PC.

User avatar
phd21
Level 13
Level 13
Posts: 4911
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Can't get built-in microphone on my headphones to work on my PC.

Postby phd21 » Sun Nov 05, 2017 4:05 pm

Hi "ht2000",

While waiting for that other information and screenshots, you can try unplugging the speakers from the back and see if that helps. Some computers will automatically switch to headset or speakers if they are plugged in. I use an audio splitter (Y cable) to get around this issue.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.2, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,3gb Ram,160gb hdd, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde


Return to “Sound, Multimedia, & Codecs”