<SOLVED> 1080p mkv videos not playing well after a while

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Fri Dec 01, 2017 12:45 pm

<SOLVED> 1080p mkv videos not playing well after a while

Post by tieriadgcr » Fri Dec 01, 2017 1:13 pm


I have a problem when playing 1080p videos, if I have been using my laptop for a while and try to play a video it doesn't play smoothly. The same issue happens if a have watched a couple of videos and I have to restart the computer for being able to watch them without problems. I'm new to Linux so I don't really have any ideas to solve that. Please let me know if there's more info that I should provide.

Thank you in advance for your help.

Here's the output of inxi -Fxz:

System: Host: veda Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya

Machine: System: TOSHIBA product: Satellite C845 v: PSCB2P-011LM2
Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 v: Type2 - Board Version
Bios: Insyde v: 6.50 date: 12/27/2012

CPU: Dual core Intel Core i3-2328M (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8780
clock speeds: max: 2200 MHz 1: 2199 MHz 2: 2200 MHz 3: 2199 MHz
4: 2200 MHz

Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.03hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.10.0-40-generic

Network: Card-1: Realtek RTL8723AE PCIe Wireless Network Adapter
driver: rtl8723ae port: 3000 bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Card-2: Qualcomm Atheros AR8152 v2.0 Fast Ethernet
driver: atl1c v: port: 2000 bus-ID: 03:00.0
IF: enp3s0 state: down mac: <filter>

Drives: HDD Total Size: 500.1GB (26.8% used)
ID-1: /dev/sda model: TOSHIBA_MK5075GS size: 500.1GB

Partition: ID-1: / size: 453G used: 120G (28%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 6.34GB used: 0.00GB (0%) fs: swap dev: /dev/sda5

RAID: No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors: System Temperatures: cpu: 68.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A

Info: Processes: 193 Uptime: 1:40 Memory: 1351.3/5865.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by tieriadgcr on Sat Dec 02, 2017 6:42 pm, edited 1 time in total.

User avatar
Level 6
Level 6
Posts: 1001
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: 1080p mkv videos not playing well after a while

Post by greerd » Fri Dec 01, 2017 1:34 pm

Hi tieriadgcr,

I see you are using the intel graphics driver, Pjotr's Easy linux Tips has a section on removing that driver to allow a more up to date driver to load, see #6 on this link.

Hope it helps

Level 1
Level 1
Posts: 2
Joined: Fri Dec 01, 2017 12:45 pm

Re: 1080p mkv videos not playing well after a while

Post by tieriadgcr » Sat Dec 02, 2017 2:24 am

Hi greerd and thank you for your reply.

I did that and everything seems to be running good now. Not just the videos but the system in general. I will try to see if tomorrow everything keeps like that the whole day before marking this post as resolved.

Thank you.

Post Reply

Return to “Sound, Multimedia, & Codecs”