Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 39
Joined: Fri Jul 01, 2016 6:10 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by somelurker » Sat Jan 27, 2018 1:17 am

Here is the output from the pactl command you posted:

Code: Select all

Soon, I will delete .xsession-errors and look for anything that seems relevant.

User avatar
Level 6
Level 6
Posts: 1015
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by trytip » Sat Jan 27, 2018 12:43 pm

install swh-plugins from synaptic these are LADSPA plugins like equalizer and compressor that you can use with audacity or other editors. but they can be live on the system to enhance or correct audio.
so after you install swh-plugins go into .config/pulse folder and create a blank text naming it inside paste this content then SAVE

Code: Select all

#include system-wise config
.include /etc/pulse/

#compressor -- for normalize audio volume

### BEGIN: Equalized audio configuration
### Generated from: pulseaudio-equalizer
load-module module-ladspa-sink sink_name=ladspa_sink master=alsa_input.pci-0000_00_1f.3.analog-stereo label=sc1 control=3,401,-30,4,5,18
load-module module-ladspa-sink sink_name=ladspa_output.mbeq_1197.mbeq master=alsa_input.pci-0000_00_1f.3.analog-stereo plugin=mbeq_1197 label=mbeq control=-1.0,-2.0,0.0,1.5,3.1,5.4,5.4,7.4,7.4,9.4,9.4,7.4,5.8,3.6,1.8
load-module module-ladspa-sink sink_name=ladspa_out master=ladspa_output.mbeq_1197.mbeq label=sc1 control=3,401,-30,4,5,12
load-module module-ladspa-sink sink_name=ladspa_normalized master=ladspa_out plugin=fast_lookahead_limiter_1913 label=fastLookaheadLimiter control=15,0,0.8
set-default-sink ladspa_out
set-sink-volume alsa_input.pci-0000_00_1f.3.analog-stereo 65536
set-sink-mute alsa_input.pci-0000_00_1f.3.analog-stereo 0
### END: Equalized audio configuration


###use the below pactl command for alsa card should be one w/o .monitor###
###  pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2  ###
you will need to logOFF/ON or reboot

when you are back, you should now have LADSPA effects enabled in pulse if i made the script compatible with your audio output. you can use pavucontrol PulseAudio Volume Control to see your connections. you will have in output devices 4 new audio templates which can be viewed in the Playback tab of pavucontrol

every once in a while i like to go to .config/pulse and DELETE everything except the now newly created or the presets folder.
BACKUP your by rightclick and compress because if you use the PulseAudio Equalizer the will be written over, meaning you will not be able to use PulseAudio Equalizer as it will interfere with the script

but none of this will matter if your sound is still shuttering, so let me know if it works then i will explain the different script possibilities

ps: this script will only work for your machine. it can be modified by replacing alsa_input.pci-0000_00_1f.3.analog-stereo in the script with the output of the pactl command for alsa card from pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2 and selecting the string WITHOUT .monitor

Level 1
Level 1
Posts: 1
Joined: Mon Feb 05, 2018 11:40 pm

Re: Stuttering sound on Linux Mint 18 Sarah 64-bit (MATE)

Post by thebrowser » Tue Feb 06, 2018 12:20 am

Hello there,

I'm having a similar issue with my audio and didn't want to open a new topic, I hope this is ok, please let me know if I should.

My problem is that while playing audio (music or video) every few minutes the sound "stutters" and comes out the speakers with a lot of distortion. The sound goes back to normal after pausing the track/video and waiting for a few seconds, but then after a couple of minutes comes back again. I'm running Mint as a virtual machine on top of windows 7 (host) using Virtual Box, which I understand is not great for media but even simple audio files get distorted, even when the computer is doing nothing else.

Some useful information:

Code: Select all

System:    Host: LMUser Kernel: 4.13.0-32-generic x86_64 (64 bit)
           Desktop: MATE 1.18.0  Distro: Linux Mint 18.3 Sylvia
           Virtual Box 5.2.6
           Audio Driver: ICH AC97
I've tried to change the audio driver to Intel HD with no result, play audio/videos from different sources (local storage, youtube, twitch...) with no result, install available updates through Update Manager, and also followed the steps in this guide I found online (although it seems it was focused for Ubuntu). To avoid you the reading I made the following changes:

Code: Select all

1. sudo nano /etc/modprobe.d/alsa-base.conf
2. at the bottom add "options snd-intel8x0 ac97_clock=48000"
Sorry for the long post, please let me know your thoughts and thanks in advance for the help.


Post Reply

Return to “Sound, Multimedia, & Codecs”