Cannot control speaker sound volume on ux550vd

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Sat Dec 30, 2017 4:42 pm

Cannot control speaker sound volume on ux550vd

Post by FrEaKmAn » Sat Dec 30, 2017 4:46 pm


I just installed linux mint 18.3 on zenbook ux550vd. I'm facing a problem with control volume levels as it's always at max. If I change the volume settings under system settings (or with sound applet), it does not change the sound level. When I use the headphones, everything works. I tried to lower the volume with alsamixer and it works great, but volume gets reset at reboot.

I tried reinstalling pulseaudio, also tried deleting ~/.config/pulse without any success. Any ideas?

User avatar
Level 3
Level 3
Posts: 194
Joined: Sun Feb 28, 2016 4:05 pm
Location: USA

Re: Cannot control speaker sound volume on ux550vd

Post by powerwagon75 » Sat Dec 30, 2017 7:34 pm

When I started using Mint 18, I too had the full volume blast at login.

You could try this.. it worked for another member here as well (I'm on Mint 18, they were on Mint 18.2, so hopefully will work in 18.3.) I had searched around on the 'net and found it, and tailored the dB levels to my liking. Created a small file, named, in my /Home directory, and put the contents in the "code" below section inside that file.

The file makes some minor adjustments to alsa's amixer settings, and contains the following:

Code: Select all

#Set Master volume to a sane level
#amixer set 'Master',0  20% unmute
#amixer set 'Master',0  20% unmute
amixer -c 0 sset Line,0 65%,65% unmute
amixer -c 0 -- sset Master playback -32.25dB
#Set Front to zero
amixer -c 0 -- sset Front playback -32.25dB
#Set Surround to zero
amixer -c 0 -- sset Surround playback -32.25dB
#Set Center to zero
amixer -c 0 -- sset Center playback -32.25dB
(You can experiment with the -32.25dB numbers to find a level you like. You likely don't need to fuss with all of them if you don't have those speaker options..I just did it that way to minimize my editing of the file initially to see if it worked, and didn't bother to experiment/clean it up to see if only the master needed to be adjusted for it to work.)

I then went to: Menu > Preferences > Startup Applications, and added it to that location:
It's not the greatest fix I'm sure, but it works. Your results may vary, but its been working every time since I've implemented it.



Custom tower w/Mint 18
HP laptop w/Mint 17.3
Dualboot Acer w/W10/Mint 18.3
Dualboot Macbook w/El Capitan/Mint 18.3
Optiplex 960 "Frankenbox" currently w/Fedora 28/Mint 18.3
Acer C720 Chromebook w/GalliumOS

Post Reply

Return to “Sound, Multimedia, & Codecs”