[Solved] Sound always max at boot

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Peterjack
Level 1
Level 1
Posts: 37
Joined: Tue Aug 01, 2017 10:11 pm

[Solved] Sound always max at boot

Post by Peterjack » Sun Jan 07, 2018 2:46 pm

Hi all- I've tried multiple searches to see if I could find something on this with no luck so far. Any ideas welcome. I was running Mint Sonya 18.2 and as it should, it remembered my last sound setting at boot. After upgrading to Sylvia 18.3 the sound is always at maximum when I boot. The sound is generic Mint except that I added the Pulse Audio Equalizer package (back in 18.2 and things worked fine).

Any ideas much appreciated, it can be startling when it's quiet and the welcome blasts into the room.
Last edited by Peterjack on Sat Feb 03, 2018 11:05 am, edited 3 times in total.

User avatar
powerwagon75
Level 3
Level 3
Posts: 130
Joined: Sun Feb 28, 2016 4:05 pm
Location: USA

Re: Sound always max at boot after upgrade 18.2 to 18.3

Post by powerwagon75 » Sun Jan 07, 2018 11:12 pm

Have a try at this and see if it will work for you:

viewtopic.php?f=48&t=260564#p1407384

Regards,

Eric
Image
Image

Peterjack
Level 1
Level 1
Posts: 37
Joined: Tue Aug 01, 2017 10:11 pm

Re: Sound always max at boot after upgrade 18.2 to 18.3

Post by Peterjack » Mon Jan 08, 2018 9:36 pm

@Eric Thanks for the reply and I gave it a whirl. First I #'d out Front, Center, Rear (laptop has only front stereo) using your code leaving only Master. There was no folder named hmix in my Home, so I created SoundStart and put it there. It was clearly recognized as a terminal command file based on icon. No luck. I then removed # from the Front line and tried again. No luck. Thanks for the idea, and if I made an error you see please let me know. -Pete

User avatar
powerwagon75
Level 3
Level 3
Posts: 130
Joined: Sun Feb 28, 2016 4:05 pm
Location: USA

Re: Sound always max at boot after upgrade 18.2 to 18.3

Post by powerwagon75 » Wed Jan 10, 2018 2:43 pm

Pete,

Did you make the file back to original, as it was before any changes and try? Also double-check your start up programs section to ensure its pointing to the right file. (The hmlx in my example is the user folder in /home... ensure your *.sh file is in the home directory you’re logging in with.

Eric
Image
Image

Peterjack
Level 1
Level 1
Posts: 37
Joined: Tue Aug 01, 2017 10:11 pm

Re: Sound always max at boot after upgrade 18.2 to 18.3

Post by Peterjack » Wed Jan 10, 2018 9:21 pm

@Eric- Since you took time to reply with another suggestion I took time to try it. This time I put Sound.sh intact- just as copied from Select All- in pete/home root folder and I used your instructions to add a startup program and browsed to it- no mistake. Still no luck, but thanks! I have zero ideas and will try all.

Peterjack
Level 1
Level 1
Posts: 37
Joined: Tue Aug 01, 2017 10:11 pm

Re: Sound always max at boot after upgrade 18.2 to 18.3

Post by Peterjack » Sun Jan 21, 2018 9:12 pm

I am still hoping for more ideas, this is not solved. Sound was normal at 18.2 Sonya, always max at boot with 18.3 Sylvia. 12 Gb ram, iCore7 dual boot laptop.

It turns out to be the default file setting from the very end of this file where Pulse Audio Equalizer saves my settings (edit as root):
/home/username/.config/pulse/default.pa

Near the very bottom I changed this line from 65536 to 35536- gives me about 60% volume on boot.
set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 35536

Post Reply

Return to “Sound, Multimedia, & Codecs”