[SOLVED!] Saving, keeping Alsamixer Mic Boost level

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
User avatar
sebastjava
Level 2
Level 2
Posts: 74
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

[SOLVED!] Saving, keeping Alsamixer Mic Boost level

Post by sebastjava » Fri Jan 12, 2018 10:40 pm

I have a little Asus netbook. When i first tried the microphone, there was just noise. I found i just have to turn Alsamixer Mic Boost level to zero to fix that issue. For those who did not know, Alsamixer is a kind of graphical interface that can be opened by typing "alsamixer" in a terminal.

But Alsamixer forgets my setting each time i restart the computer.

So here is my question: is there a way to permanently store Mic Boost level in Alsamixer, so it remains set to zero after restarting?
Last edited by sebastjava on Wed Jan 17, 2018 11:32 am, edited 4 times in total.

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: Saving, storing or keeping Alsamixer Mic Boost level

Post by orschiro » Sat Jan 13, 2018 3:35 am

So here is my question: is there a way to permanently store Mic Boost level in Alsamixer, so it remains set to zero after restarting?
You could run a script on boot that contains the command to set your level to zero.

User avatar
sebastjava
Level 2
Level 2
Posts: 74
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

Re: [CLOSED] Saving, storing or keeping Alsamixer Mic Boost level

Post by sebastjava » Sat Jan 13, 2018 9:20 am

Thanks, i will probably try such a script. I am closing this topic because i have to think and search more first. I tried sudo alsactl store : it does restore the settings from one session to another, but not after a restart. I suspect Pulse Audio is also storing/restoring some values so i might have to control both Alsamixer and Pulse Audio...

orschiro
Level 4
Level 4
Posts: 230
Joined: Mon Dec 04, 2017 2:56 am
Contact:

Re: [CLOSED] Saving, storing or keeping Alsamixer Mic Boost level

Post by orschiro » Sat Jan 13, 2018 10:25 am

You could also take a look at: https://github.com/graysky2/pulseaudio-ctl

User avatar
sebastjava
Level 2
Level 2
Posts: 74
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

[SOLVED!] Saving, keeping Alsamixer Mic Boost level

Post by sebastjava » Sat Jan 13, 2018 10:53 pm

I probably could have inserted this amixer sset 'Mic Boost' 0 in the system start. But i preferred to edit the source of the problem. It works! Now the Internal Microphone sounds fine on my little Asus EeePC X101ch. Here is what i did:

Code: Select all

# Disable auto adjusting of gain on mic:
# Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
# Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf
# Under "[Element Internal Mic Boost]" set "volume"  to "zero".
# Under "[Element Int Mic Boost]" set "volume"  to "zero".
# Under "[Element Mic Boost]" set "volume"  to "zero".
I found that there:
https://askubuntu.com/questions/279407/ ... put-volume

Post Reply

Return to “Sound, Multimedia, & Codecs”