18.3 Sylvia - Sound cracking with external USB sound card

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 3:59 pm

18.3 Sylvia - Sound cracking with external USB sound card

Post by el_sid » Thu Jan 18, 2018 4:19 pm

Hi guys,
I have a problem with my external USB sound card: When its plugged in and I dont play any sound, it's all quiet. But when I start playing a soud (song, video,...), it works okay but I can hear unregular "cracks" from my speakers, like if I'm playing a vinyl record. Also sometimes the sound freezes for a short moment and then continues to play. And I can hear a quiet "wave" sound in the background that is only hearable when the song is really quiet.
But both of these sounds dont belong there. I tried my best to google the problem and I found that it might be a lag problem with the sound (?) and/or a kernel problem.
I also read that this might be due to power saving settings, I found a manual online to update the parameters but it didnt help.
So here's my setup:
Computer --- Terratec 7.1 Sound Card --- SPDIF --- Amplifier
The Terratec 7.1 sound card is supported by Linux Mint (thats what I found), so it shouldnt be a driver problem. Anyway, listening to music is one of my main activites that I use my computer for, so it would be awesome if you guys could help me.
Just weird: Sometimes I find the analog + the digital output and sometimes just the analog output?

Once the problem was solved, when I had selected "internal audio" (usually the Laptop speakers) but the sound was playing on my external speakers. Then the weird sounds were gone.

Some technical information:
Lenovo ThinkPad T430

Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm Distro: Linux Mint 18.3 Sylvia
Kernel: 4.10.0-38-generic
Audio: Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1e20
Card-2 TerraTec Electronic driver: USB Audio usb-ID: 001-009 chip-ID: 0ccd:00b1
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic

CPU and RAM usage are in a normal range.

I really love Linux, this is the only thing that bothers me. Please notice that I have started to use Linux for the first time 2 weeks ago, I'm trying my best but might not understand every technical answer correctly in the first place.
I'm really thankful for every answer/suggestion.
Thanks everyone :)

User avatar
Level 17
Level 17
Posts: 7763
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: 18.3 Sylvia - Sound cracking with external USB sound card

Post by catweazel » Fri Jan 19, 2018 1:58 am

In a terminal:

Code: Select all

sudo nano -w /etc/pulse/default.pa
Look for this line:

load-module module-udev-detect

Add tsched=0 to the end of the line, like this:

load-module module-udev-detect tsched=0

ctrl-o, enter to save, then ctrl-x to exit.


Give that a try. If it doesn't fix the issue, reverse the edit by modifying the instructions above.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 3:59 pm

Re: 18.3 Sylvia - Sound cracking with external USB sound card

Post by el_sid » Fri Jan 19, 2018 5:42 am

Hi, thanks for your help.
Unfortuantely it did not solve the problem. I deleted the tschad=0 again from the file.
Yesterday I did a kernel update to 4.13, but it didnt change anything as well.

Level 1
Level 1
Posts: 3
Joined: Thu Jan 18, 2018 3:59 pm

Re: 18.3 Sylvia - Sound cracking with external USB sound card

Post by el_sid » Fri Jan 19, 2018 5:58 am

So I came across the pactl list sinks command and it shows me this:
me@me ~ $ pactl list sinks
Sink #0
Name: alsa_output.usb-0ccd_Aureon_7.1_USB-00.iec958-stereo
Description: Aureon 7.1 USB Digital Stereo (IEC958)
Driver: module-alsa-card.c
Sample Specification: s16le 2ch 48000Hz
Channel Map: front-left,front-right
Owner Module: 6
Mute: Nein
Volume: front-left: 65536 / 100% / 0,00 dB, front-right: 65536 / 100% / 0,00 dB
balance 0,00
Base Volume: 65536 / 100% / 0,00 dB
Monitor Source: alsa_output.usb-0ccd_Aureon_7.1_USB-00.iec958-stereo.monitor
Latency: 0 usec, configured 0 usec
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "USB Audio"
alsa.id = "USB Audio"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "1"
alsa.card_name = "Aureon 7.1 USB"
alsa.long_card_name = "Aureon 7.1 USB at usb-0000:00:1a.0-1.2, full speed"
alsa.driver_name = "snd_usb_audio"
device.bus_path = "pci-0000:00:1a.0-usb-0:1.2:1.0"
sysfs.path = "/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/sound/card1"
udev.id = "usb-0ccd_Aureon_7.1_USB-00"
device.bus = "usb"
device.vendor.id = "0ccd"
device.vendor.name = "TerraTec Electronic GmbH"
device.product.id = "00b1"
device.product.name = "Aureon 7.1 USB"
device.serial = "0ccd_Aureon_7.1_USB"
device.string = "iec958:1"
device.buffering.buffer_size = "352800"
device.buffering.fragment_size = "176400"
device.access_mode = "mmap+timer"
device.profile.name = "iec958-stereo"
device.profile.description = "Digital Stereo (IEC958)"
device.description = "Aureon 7.1 USB Digital Stereo (IEC958)"
alsa.mixer_name = "USB Mixer"
alsa.components = "USB0ccd:00b1"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-usb"
iec958-stereo-output: Digitaler Ausgang (S/PDIF) (priority: 0)
Aktive Profile: iec958-stereo-output

I got suspicious because of the SUSPENDED. Could this be a hint for the solution?

Post Reply

Return to “Sound, Multimedia, & Codecs”