Mint 18.3 and sound card problems

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
ozbeaky25
Level 1
Level 1
Posts: 1
Joined: Tue Jan 23, 2018 9:32 pm

Mint 18.3 and sound card problems

Post by ozbeaky25 » Tue Jan 23, 2018 9:38 pm

Linux Mint 18.3 “Sylvia” and Sound Card Problems

Recently (Jan 2018) I decided to update from Mint 17.3 and also update the Kernel for my HP Proliant Microserver (some years old).

Not being sufficiently confident to try this alone, I got the assistance of a mate who is confident in Linux and I prepared for him to supervise the process by backing up all my data and profiles (mozilla, etc).

The process of updating to the latest version of the Kernel and Mint 18.3 was relatively easy and went smoothly. However, when we checked a few things after updating, the ASUS sound card was no longer operating. Try as we may we couldn't get the unit to work and no sound was forthcoming.

My mate had to return home and left me with the process of checking various forums for any advice and processes for activating the sound card. This process took a few days with no success. On discussion with my mate he made a quick comment of suggesting we remove the sound card and replace it with a bluetooth dongle and a bluetooth sound-bar. As the speakers were old recycled ones anyway, that sounded like a good idea and possibly a better solution.

With the sound card removed, and a bluetooth dongle and sound-bar purchased and installed, the dongle was automatically recognised and easy to set-up. It recognised the sound-bar and displayed the identity number of the sound-bar but didn't recognise it as an audio device.

Again back to the various forums for advice to overcome this hurdle. I eventually got the dongle-soundbar to work as proposed, in fact it is better than the sound-card and speakers that were previously used. To get the audio system to work I am thankful for the advice from the following:

https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/

https://linuxcommando.blogspot.com.au/2 ... tooth.html

https://wiki.debian.org/BluetoothUser/a2dp

It wasn't any one of these alone that worked but a combination of the information contained at these sites. I am really thankful for the information and direction these sites gave, but I have no idea what individual command or process worked.

Not all the commands (in terminal mode) worked because of out-of-date issues, AND the most important aspect I learnt was to reboot after every process tried.

There are one or two issues remaining such as the system alerts having the alert sound level turned to zero when you close the system sound preferences control panel. I can work around this by using a low-volume wave file and pointing Mozilla etc to the relevant sound file(s).

Bill (Ozbeaky)

==============================================

How To Fix: No Sound In Ubuntu 14.04 And Linux Mint 17
Last updated March 11, 2015 By Abhishek Prakash

https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/

This article was originally written for Ubuntu 13.04 but it is also applicable to no sound problem in Ubuntu 14.04, Ubuntu 14.10 and Linux Mint 17.

Ubuntu 13.04 has been released with lots of eye-candy and performance boost. As it happens with every Ubuntu release, you install or upgrade to a newer Ubuntu version and run in to a number of problems. But then, there is always a way to overcome these big little problems. One of the most common problem faced is no sound after installing Ubuntu 14.04.

While there could be several reasons for no sound in Ubuntu 14.04, I will share the trick which worked for me. Lets see in steps how I fixed and how you can fix it.

Steps to fix no audio in Ubuntu 14.04:

First step, just to verify, check if the sound is not muted. Once you verify this, go to Sound Settings:

In the Sound Settings, you’ll find that you have practically nothing here except a dummy output. Quite frustrating. It means that your sound card is not even recognised. Puff!

No worries. The one shot solution which fixed the sound problem for me on my Intel powered Dell Inspiron N4010 is to force reload Alsa. To do that, use the following command in terminal (Ctrl+Alt+T):

sudo alsa force-reload

The output will be like this.


You may think that it is hanged or still in processing but it takes only couple of seconds. You can simply close it afterwards by using Ctrl+C. Now, you need to reboot your computer. If at the next start up, you hear the login sound at the lock screen, you know it worked like a charm.

------------------------------------------------

First Alternate method to fix no sound in Ubuntu 14.04:

If the above problem did not fix it for you, try reinstalling Alsa and Pulse audio in the following manner:

sudo apt-get remove --purge alsa-base pulseaudio

sudo apt-get install alsa-base pulseaudio

And force reload Alsa again:

sudo alsa force-reload

Restart and enjoy the world of sound, again.

------------------------------------------------

Second Alternate method to fix no sound in Ubuntu 14.04:

Open the terminal and edit speech-dispatcher file by using the following command:

sudo gedit /etc/default/speech-dispatcher

In here, change RUN=yes to RUN=no

Reboot and enjoy sound.

If it fixed your sound problem, you may want to fix brightness issue as well. Fixing the sound problem is definitely one of the must to do things after installing Ubuntu 14.04. Any questions, suggestions or a world of thanks to keep me motivated can be dropped in comment section. Stay tuned for more Linux tutorials and tips.

================================================

Linux Commando

This blog is about the Linux Command Line Interface (CLI), with an occasional foray into GUI territory. Instead of just giving you information like some man page, I hope to illustrate each command in real-life scenarios.

https://linuxcommando.blogspot.com.au/2 ... tooth.html

Tuesday, November 26, 2013
How to connect to Bluetooth headset/soundbar/speaker

Most modern laptops are equipped with the Bluetooth radio. It means that you can use a Bluetooth mouse and keyboard as your input device, and a Bluetooth headset, soundbar, or speaker for your sound output. This article gives an example of how to connect your Linux laptop to a Bluetooth soundbar.

Device model

My laptop is a DELL Vostro 1015 running Ubuntu 12.04.3 LTS ("precise"). The bluez Bluetooth stack is of version 4.98.

My soundbar is the Panasonic HTB450. According to the Owner's Manual, this model features Bluetooth V2.1 + EDR. Note that this model is not a Bluetooth Low Energy device. The method in this blog post has only been tested on non-Low-Energy Bluetooth devices.

Getting ready

Install the bluez-tools package on your Linux computer (assuming it is Debian-based):

$ sudo apt-get install bluez-tools

Power up the Panasonic soundbar. Make sure that Bluetooth is selected as the audio source, and that the device is configured to be discoverable to other Bluetooth devices.

The soundbar and the Linux laptop must be within a "short" distance of each other (10 feet to be safe).

Connection procedure

The following assumes you have only one Bluetooth adapter in your Linux computer. If you have more than 1, use the hciconfig command to find out the name of the Bluetooth adapter to use for connection, and specify that device name as a parameter to the commands below.

Discover the soundbar.

Run the following command on Linux to scan for the soundbar. The key piece of data to jot down is the Bluetooth address of the soundbar (e.g., 00:0B:97:0F:C5:2D).

$ bt-adapter -d
Searching...
[00:0B:97:0F:C5:2A]
Name: SC-HTB450
Alias: SC-HTB450
Address: 00:0B:97:0F:C5:2D
Icon: audio-card
Class: 0x240404
LegacyPairing: 0
Paired: 0
RSSI: -56
Done

You can also scan using the hcitool command:

$ hcitool scan
Scanning ...
00:0B:97:0F:C5:2D SC-HTB450

Pair with the soundbar.

This step is only necessary if the 2 devices have never been "paired" before.

To pair, run the bt-device command with the Bluetooth address from step 1 as the parameter.

$ bt-device -c 00:0B:97:0F:C5:2D
Connecting to: 00:0B:97:0F:C5:2D
Agent registered
Agent released
Done

You can verify the result by listing the paired devices:

$ bt-device -l
Added devices:
SC-HTB450 (00:0B:97:0F:C5:2D)

Connect audio output to soundbar.

$ bt-audio -c 00:0B:97:0F:C5:2D
Connecting to an audio service
Audio service is connected

You can verify the connection by querying information about the Bluetooth device name (SC-HTB450). Note that the output contains a line with Connected equals 1 (meaning success!)

$ bt-device -i SC-HTB450
[00:0B:97:0F:C5:2A]
Name: SC-HTB450
Alias: SC-HTB450 [rw]
Address: 00:0B:97:0F:C5:2D
Icon: audio-card
Class: 0x240404
Paired: 1
Trusted: 0 [rw]
Blocked: 0 [rw]
Connected: 1
UUIDs: [AudioSink, AVRemoteControl]

Make soundbar a trusted device.

After the soundbar is turned off and then on again, the Bluetooth audio connection is NOT automatically reconnected. To make re-connection automatic, run the following command to designate the soundbar as a trusted device.

$ bt-device --set SC-HTB450 Trusted 1
Trusted: 0 -> 1

Note that if you reboot your laptop, you need to manually re-connect using bt-audio -c as shown above (but pairing can be skipped). This is true even when the Bluetooth device is designated as trusted.

Playback sound

The audio connection is now made between your laptop and the soundbar.

You can play your favourite sound track and the sound will come from the soundbar, instead of the built-in laptop speakers.

comment:

Unknown said...

This worked with one exception. For some reason, by default, the bluetooth module for pulseaudio wasn't installed on my computer. Once I installed it it worked. So your procedure didn't necessarily fix my issue, but it does work as a general how-to.


================================================
Debian Wiki
BluetoothUsera2dp

https://wiki.debian.org/BluetoothUser/a2dp

A2DP is the "Advanced Audio Distribution Profile" which describes how Bluetooth devices can stream stereo-quality audio to remote devices. It enables connecting high quality audio bluetooth devices, such as headphones and speakers, to your system.

Requirements

To connect to a given device you need working bluetooth on your machine and the following packages, one of which is non-free software which will require you to enable the non-free repository in your /etc/apt/source.list file.

apt-get install pulseaudio pulseaudio-module-bluetooth pavucontrol bluez-firmware

Once you have installed these packages, it may be necessary to restart the bluetooth and pulseaudio services:

service bluetooth restart

killall pulseaudio

Pairing

It is also highly recommended to install a graphical pairing tool. If you are using GNOME as your desktop environment, bluetooth-applet should already be installed from the gnome-bluetooth package.

If you are using an alternative desktop environment that does not already include graphical bluetooth tools, you can use the blueman-applet from the blueman package:

apt-get install blueman

Both of these applets will appear in the notification area of your desktop environment and will provide options for pairing and connecting to your speakers or headphones.

Pair your device as usual and give it the "trust" attribute. The "trust" attribute allows the device to automatically establish a connection to your machine when turned on and in range.

Configuring

Using pavucontrol from the pavucontrol package, it is really easy to setup A2DP for your device, and map connections to it. Your paired headphones should appear as an option to output audio.

Don't forget to put it in high quality mode (A2DP) in the configuration tab. This is necessary for some devices that have mixed mode.

Compatible devices

Any A2DP device should work out of the box.

If you still haven't bought one, the Creative WP-300 works very well and has a very nice sound.

Troubleshooting

Refused to switch profile to a2dp_sink: Not connected

Bluetooth headset is connected, but ALSA/PulseAudio fails to pick up the connected device or there's no device to pick. This happens because GDM captures A2DP sink on session start, as GDM needs pulseaudio in the gdm session for accessibility. For example, the screen reader requires it. See 805414 for some discussion.

Workaround 1: disable pulseaudio in gdm

In order to prevent GDM from capturing the A2DP sink on session start, edit (or create it, if it doesn't exist):
/var/lib/gdm3/.config/pulse/client.conf

autospawn = no
daemon-binary = /bin/true

After that you have to grant access to this file to Debian-gdm user:

chown Debian-gdm:Debian-gdm /var/lib/gdm3/.config/pulse/client.conf

You will also need to disable pulseaudio startup:

rm /var/lib/gdm3/.config/systemd/user/sockets.target.wants/pulseaudio.socket

In order to auto-connect a2dp for some devices, add this to /etc/pulse/default.pa:

load-module module-switch-on-connect

Reboot.

Now the sound device (bluetooth headset) should be accessible through pavucontrol and standard audio device manager.

Workaround 2: disable pulseaudio's bluetooth in gdm

The actual solution package maintainers are looking into next is to simply disable the bluetooth sink in the gdm pulseaudio daemon so that it doesn't take over the device. Add this to
/var/lib/gdm3/.config/pulse/default.pa:

#!/usr/bin/pulseaudio -nF
#

# load system wide configuration
.include /etc/pulse/default.pa

### unload driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
unload-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
unload-module module-bluetooth-discover
.endif

This was first discovered in the Arch wiki.

Solution

The actual solution is for pulseaudio to release the Bluetooth device when it is not in use. This is discussed in the Pulseaudio 845938 which has a few upstream bugs pending as well that are related.

Post Reply

Return to “Sound, Multimedia, & Codecs”