I deleted my own audio

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

I deleted my own audio

Post by Doctor Funkenstein » Wed Jan 31, 2018 4:22 pm

Hello all,

I tried to install a program called KX Studio and I wound up deleting my built-in audio.

When I right-click my task bar, go to 'System Settings' and to Sound, it no longer offers built-in audio as an option.

It does if I am logged in as a guest, so I am certain this is not a hardware issue. The sound definitely works when logged in as guest.

Here is a copy-paste from my terminal with the info from the 'how to get help' section. Thanks in advance for any advice you can provide.

Code: Select all

math@Larry ~ $ inxi -Fxz
System:    Host: Larry Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell (portable) product: Inspiron N5010 v: A07
           Mobo: Dell model: 0WXY9J v: A07 Bios: Dell v: A07 date: 07/26/2010
CPU:       Dual core Intel Core i3 M 370 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9576
           clock speeds: max: 2394 MHz 1: 931 MHz 2: 931 MHz 3: 931 MHz
           4: 931 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.91hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile
           GLX Version: 2.1 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge bus-ID: 12:00.0
           IF: wlp18s0b1 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 13:00.0
           IF: enp19s0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (16.6% used)
           ID-1: /dev/sda model: WDC_WD3200BPVT size: 320.1GB
Partition: ID-1: / size: 291G used: 47G (17%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 3.08GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 59.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 214 Uptime: 7 min Memory: 1380.5/5760.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
math@Larry ~ $
Last edited by Doctor Funkenstein on Tue Feb 06, 2018 8:28 pm, edited 4 times in total.

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Wed Jan 31, 2018 8:14 pm

Update: I tried using Time Machine - still nothing. Wow.

User avatar
TeaSwigger
Level 3
Level 3
Posts: 109
Joined: Mon Feb 06, 2012 6:42 am
Location: CA

Re: I deleted my own audio

Post by TeaSwigger » Wed Jan 31, 2018 10:08 pm

No idea what KXStudio is or does. A quick look at their website is confusing, seemingly promoting an event whereas their other pages are missing (related inquiry in this thread: viewtopic.php?f=42&p=1424079#p1424079). Are you sure it's legit? If it is, if you're sure you want it and that whatever you installed is/was intended for Mint 18.x, you may need to seek further help there.

Assuming you're sure it's legit and you want to remove it, it's promising that the guest account is ok... Logged in as your regular user, open your file manager and make hidden files visible. Do you see a file named .asound? If so, rename it. Do your sound options return to normal? May need to log out.
Mint 18.3 xfce w/nemo - AMD Quad Core - lovely ASUS Xonar ST sound - Radeon R7 Graphics - 1920x1200 Dell U2415
some favs: Zim - Audacious - kid3 - calibre - gimp - artha - deluge - handbrake - k3b - ClickRepair - mc
Folding@Home Mint Team Contributor

User avatar
trytip
Level 6
Level 6
Posts: 1018
Joined: Tue Jul 05, 2016 1:20 pm

Re: I deleted my own audio

Post by trytip » Wed Jan 31, 2018 11:12 pm

go to .config/pulse/ DELETE everything and reboot
if that doesn't work you may need to re-install pulseaudio

ps: i was using the kxstudio ppa and today i find out they are discontinued. remove any ppa if you can along with authentication key
Image

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Fri Feb 02, 2018 7:24 pm

TeaSwigger: I deleted everything from the program, to the best of my knowledge. I was following instructions online to install it via command line and tried several things. I'm sure that's probably what caused the problem initially.

- I deleted everything in the .config/pulse folder and also tried reinstalling pulseaudio
- there was no file named .asound that I could find.

What is the KXStudio ppa and how do I delete it?

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Fri Feb 02, 2018 7:32 pm

I restarted the computer and now it's working! Only other thing I did was uninstall pulse audio volume control.

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: [SOLVED] I deleted my own audio

Post by Doctor Funkenstein » Tue Feb 06, 2018 8:28 pm

Okay, it's back to not working now and I haven't done anything differently. I tried going back to .config/pulse and deleting everything but there was only one file this time and it didn't work.

All I've done differently that I can think of is install some updates. I had a level 4 one earlier. Could this be the problem and if so, should I stop performing updates? How do I roll it back?

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Tue Feb 06, 2018 8:29 pm

Here is a screenshot of my audio section. Usually there is an option for "Built-in Audio" and an HDMI output if I have my HDMI cable plugged in.
Attachments
Screenshot from 2018-02-06 19-28-42.png

User avatar
TeaSwigger
Level 3
Level 3
Posts: 109
Joined: Mon Feb 06, 2012 6:42 am
Location: CA

Re: I deleted my own audio

Post by TeaSwigger » Tue Feb 06, 2018 11:03 pm

Doctor Funkenstein wrote:Only other thing I did was uninstall pulse audio volume control.
Did you re-install it?
Doctor Funkenstein wrote:TeaSwigger: I deleted everything from the program, to the best of my knowledge. I was following instructions online to install it via command line and tried several things. I'm sure that's probably what caused the problem initially.
What were those instructions?

On a seperate line of thought, I see in your screencap, a link or something saying 'text to speech' and that brings to mind an issue I've had on the pc I've set up for my dad: a service, speech-dispatcher, starts, seemingly at random; it takes over the audio and he'll get no sound for music, videos etc. If you want to check if that's acting up on yours: when you're not getting sound, open Task Manager, search for speech and see if you get results; if you see results, right click and opt to kill 'em; with those gone, check if sound is working.
Mint 18.3 xfce w/nemo - AMD Quad Core - lovely ASUS Xonar ST sound - Radeon R7 Graphics - 1920x1200 Dell U2415
some favs: Zim - Audacious - kid3 - calibre - gimp - artha - deluge - handbrake - k3b - ClickRepair - mc
Folding@Home Mint Team Contributor

User avatar
trytip
Level 6
Level 6
Posts: 1018
Joined: Tue Jul 05, 2016 1:20 pm

Re: I deleted my own audio

Post by trytip » Wed Feb 07, 2018 12:18 pm

maybe i'm seeing things wrong but the volume is at 0 is this because audio is not working or could it be something is muting your volume.
you should always have something in .config/pulse if you don't it means pulse isn't initialized and you'll need to logOFF/ON or reboot
open terminal and tell me what do you get for this:

Code: Select all

pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2
you can't roll this back unless you use timeshift it's something like system restore. but you need a stable backup to roll into first.
Last edited by trytip on Wed Feb 07, 2018 12:42 pm, edited 1 time in total.
Image

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Wed Feb 07, 2018 12:37 pm

I really don't remember - it was a bunch of terminal commands!

I just reinstalled pulse audio volume control, but when I try to open it, it hangs at the loading screen.

User avatar
trytip
Level 6
Level 6
Posts: 1018
Joined: Tue Jul 05, 2016 1:20 pm

Re: I deleted my own audio

Post by trytip » Wed Feb 07, 2018 12:44 pm

post your terminal output from the above comment. also run pavucontrol in terminal to tell you what it complains about
Image

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Wed Feb 07, 2018 3:05 pm

It just says, "Establishing connection to PulseAudio. Please wait..." then never leaves that screen. How to post terminal output?

User avatar
Marziano
Level 5
Level 5
Posts: 520
Joined: Thu Jan 04, 2018 1:00 pm
Location: /here

Re: I deleted my own audio

Post by Marziano » Wed Feb 07, 2018 3:07 pm

Are you by any chance running firejail?
In the Grand Scheme of Things, everything on Earth is nothing but an annoying Bug.

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Wed Feb 07, 2018 3:10 pm

Marziano wrote:
Wed Feb 07, 2018 3:07 pm
Are you by any chance running firejail?
Not that I know of!

User avatar
Marziano
Level 5
Level 5
Posts: 520
Joined: Thu Jan 04, 2018 1:00 pm
Location: /here

Re: I deleted my own audio

Post by Marziano » Wed Feb 07, 2018 3:13 pm

Doctor Funkenstein wrote:
Wed Feb 07, 2018 3:10 pm
Marziano wrote:
Wed Feb 07, 2018 3:07 pm
Are you by any chance running firejail?
Not that I know of!
Alright, nothing then. Since firejail causes some issues with audio, so I thought maybe...
In the Grand Scheme of Things, everything on Earth is nothing but an annoying Bug.

User avatar
trytip
Level 6
Level 6
Posts: 1018
Joined: Tue Jul 05, 2016 1:20 pm

Re: I deleted my own audio

Post by trytip » Wed Feb 07, 2018 5:37 pm

post means copy the output from the terminal and paste it here then highlight the whole output and click the "c" icon above this box you're typing in
find $HOME ! -user $USER -type f
Image

Doctor Funkenstein
Level 1
Level 1
Posts: 17
Joined: Wed Jan 31, 2018 4:16 pm

Re: I deleted my own audio

Post by Doctor Funkenstein » Thu Feb 08, 2018 12:56 pm

When I type that it says

Code: Select all

find:  'home/math/.cache/dconf':  Permission denied+

User avatar
trytip
Level 6
Level 6
Posts: 1018
Joined: Tue Jul 05, 2016 1:20 pm

Re: I deleted my own audio

Post by trytip » Thu Feb 08, 2018 10:50 pm

are you sure you put this in terminal? try it again, that last output doesn't seem complete

Code: Select all

find $HOME ! -user $USER -type f
Image

User avatar
powerwagon75
Level 3
Level 3
Posts: 130
Joined: Sun Feb 28, 2016 4:05 pm
Location: USA

Re: I deleted my own audio

Post by powerwagon75 » Fri Feb 09, 2018 11:16 am

Doc,

Your output of trytips command, if it was entered correctly sounds like a possible permissions issue. It should not have given "permission denied."

Go to your home folder in terminal, and enter ls -la . This will list all items in that folder; permissions, owners, and users. You should see .cache listed as below:

drwx------ 42 owner user 4096 Feb 9 08:06 .cache
Where it says owner and user above, make sure it lists your names, and not root.

If you find root owns anything besides the ".." directory, follow this very good fix that was provided some time ago by forum member Cosmo to fix home permissions:

To correct this:
Copy the following command completely and make sure, that you do not miss any sign, than press ctrl-c

find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;

Open a terminal and enter

sudo -i

and press the Enter-key; you get prompted for your password, enter it.
Now still in the same terminal press ctrl-shift-V
Run this command and wait until it has finished. It does not produce a readable output.

• Press twice ctrl-d
• Immediately log off and back into your account.

The cause for wrong ownership is typically the wrong usage of sudo. Generally: Never use sudo to launch any graphical command, but - if really needed only gksudo or (with KDE) kdesudo. Otherwise you will fall back into this problem - or possibly in even harder problems - again.


Not saying this will fix your audio problems, but your query shouldn't have been denied.
Image
Image

Post Reply

Return to “Sound, Multimedia, & Codecs”