No sound via Bluetooth

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
MarshalM
Level 1
Level 1
Posts: 23
Joined: Wed Dec 24, 2014 6:44 am

No sound via Bluetooth

Post by MarshalM » Thu Feb 01, 2018 5:30 pm

Halo,
I searched for in this forum and in the Internet, but still I have the same problem.
I've headphones on bluetooth and i'd like to listen music using them.
I have no problem to pair and connect them to my Linux Mint 18.1, but i can't listen to music.
It's strange, because i can see them in systems sound configuration, but when I try to switch my sound to headphones i can't choose them.
Any idea why?

User avatar
catweazel
Level 17
Level 17
Posts: 7752
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: No sound via Bluetooth

Post by catweazel » Fri Feb 02, 2018 1:21 am

There was a recent pulseaudio update in 18.3 to make it work with more bluetooth headsets. You have 18.1 so perhaps you might consider making sure your machine is fully up to date, or this link. For some extra detail, read this link.

This link is old but might have some clues.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

MarshalM
Level 1
Level 1
Posts: 23
Joined: Wed Dec 24, 2014 6:44 am

Re: No sound via Bluetooth

Post by MarshalM » Sat Feb 03, 2018 5:03 pm

Thanks for your answer, but i still have a problem.
All my packages (including pulseaudio) is already the newest version.
The first and third link which You propose, I already try, but it doesn't help:(
I also think, that some information in this link is out of date, f.ex. some packages mentioned there is no in repo, or files names are different.
For now my headphone is paired and connected via bluetooth, i can see then in my output devices, but i cann't pick up the connected device.
Please help

msfullroller
Level 1
Level 1
Posts: 8
Joined: Sat Feb 10, 2018 5:54 pm

Re: No sound via Bluetooth

Post by msfullroller » Sat Feb 10, 2018 11:16 pm

I too am using Mint 18.1 and was having this same issue a few days ago and found the solution. Forgive me as I don't remember where I found it and can't give full credit to the individual. :(

What you have to do is uninstall "Blueberry" which is what comes with 18.1 and install "Blueman". Both are in the Synaptic Package Manager. Pair your headphones. Then go to the Sound settings, Playback and click on the box that you see next to it that may probably say "Built-in Analog Stereo" so that other options will come up and you should see your bluetooth headphones along with whatever else you may have there. Click the bubble to choose your headphones.

I've only done this using the default media player even for music. I've got to try it to see if it works with the audio players. The next time you want to use them you may have to remove the headphones and pair them again in Blueman.

Satori
Level 1
Level 1
Posts: 22
Joined: Wed Jul 06, 2016 5:19 am

Re: No sound via Bluetooth

Post by Satori » Sun Feb 11, 2018 2:07 am

Let's just accept that Bluetooth sucks in Linux Mint. I've had non-stop issues with it for years and on different (and new) machines. And whenever I do manage to fix it, somehow it ends up broken through the normal update process. I've stopped even trying to fix it.

MarshalM
Level 1
Level 1
Posts: 23
Joined: Wed Dec 24, 2014 6:44 am

Re: No sound via Bluetooth

Post by MarshalM » Sun Feb 11, 2018 1:54 pm

msfullroller i have no idea how and where You found this, but it works! now i'm writing this post listening music via my BT headphones. It's amazing :D
But let mi tell what i had to do (maybe someone else can help this):
1) Uninstall "Blueberry" package (i did this in Synaptic Package Manager);
2) Install "Blueman" package (i did this in Synaptic Package Manager);
3) Restart my computer (without this i couldn't start BT);
4) Start BT module;
5) Run "Blueman";
6) Connect with my headphones (already was paired);
7) In "Blueman" select my device, than click on "Device" in menu > Audio profile (for PulseAudio) and choose option A2DP (i have 3 alternatives: HSP/HFP, A2DP, OFF);
8) Change output device in my sound configuration (via applet).
Thats all. Then i've tested the connection and works fine with music played from www (YT, soundcloud) or any player on my desktop.

Once again thanks a lot!
:wink:

msfullroller
Level 1
Level 1
Posts: 8
Joined: Sat Feb 10, 2018 5:54 pm

Re: No sound via Bluetooth

Post by msfullroller » Sun Feb 11, 2018 10:28 pm

MarshalM wrote:
Sun Feb 11, 2018 1:54 pm
msfullroller i have no idea how and where You found this, but it works! now i'm writing this post listening music via my BT headphones. It's amazing :D
But let mi tell what i had to do (maybe someone else can help this):
1) Uninstall "Blueberry" package (i did this in Synaptic Package Manager);
2) Install "Blueman" package (i did this in Synaptic Package Manager);
3) Restart my computer (without this i couldn't start BT);
4) Start BT module;
5) Run "Blueman";
6) Connect with my headphones (already was paired);
7) In "Blueman" select my device, than click on "Device" in menu > Audio profile (for PulseAudio) and choose option A2DP (i have 3 alternatives: HSP/HFP, A2DP, OFF);
8) Change output device in my sound configuration (via applet).
Thats all. Then i've tested the connection and works fine with music played from www (YT, soundcloud) or any player on my desktop.

Once again thanks a lot!
:wink:

You are most welcome! I'm still a newbie myself and so glad that I could repay the some of the help that I have gotten in the past. I was on the forum looking for answers with another issue that I was having. :lol:

I just installed Mint 18.1, upgrading to Mint 18.3 on another drive to test it out before I upgrade to it on my main drive. What catweazel said is true about 18.3. I'm listening right now as I type this to audio via my bluetooth headphones and this time I didn't have to do anything additional but pair them and of course choose them in the "Sound Settings". Blueberry is still installed.

So now there are two possible solutions to bluetooth issues. :)

MarshalM
Level 1
Level 1
Posts: 23
Joined: Wed Dec 24, 2014 6:44 am

Re: No sound via Bluetooth

Post by MarshalM » Mon Feb 12, 2018 6:05 pm

Thanks for this additional information. I think, that i will move to LM 19 in near future, so we'll see how it will works there.
Anyway in my opinion people can find here some interesting them information.
Thanks a lot for all answers.
Last edited by MarshalM on Wed Feb 14, 2018 12:52 pm, edited 1 time in total.

JeremyB
Level 19
Level 19
Posts: 9304
Joined: Fri Feb 21, 2014 8:17 am

Re: No sound via Bluetooth

Post by JeremyB » Mon Feb 12, 2018 6:16 pm

I have been using the python script at https://gist.github.com/pylover/d68be36 ... 5e6ed6e7ae to get my bluetooth headset to work on A2DP

Post Reply

Return to “Sound, Multimedia, & Codecs”