Downloaded Videos Have No Audio (SOLVED)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
LLS
Level 1
Level 1
Posts: 30
Joined: Sat Nov 18, 2017 9:38 am
Location: County Mayo, Ireland

Downloaded Videos Have No Audio (SOLVED)

Post by LLS » Sat Feb 17, 2018 5:39 pm

I studying a course right now. Part of the course is online and there are a number of instructional videos included. I.e embedded in the webpages.
There is a link below each video to download it so it can be viewed off-line. This I've done.
However, the downloaded videos have no audio! (there is sound if I view them on-line)
I'm wondering if I'm missing a particular codec or something. All the videos are in mp4.

Thanks!
Last edited by LLS on Mon Feb 19, 2018 11:13 am, edited 1 time in total.

User avatar
coffee412
Level 5
Level 5
Posts: 837
Joined: Mon Nov 12, 2012 7:38 pm
Location: Indiana, USA
Contact:

Re: Downloaded Videos Have No Audio

Post by coffee412 » Sat Feb 17, 2018 6:52 pm

See if this link can fix your issues:

http://linuxmint-installation-guide.rea ... odecs.html

Ill cross my fingers for you :)
Ryzen x1800 Asus Prime x370-Pro 32 gigs Ram RX480 graphics
IceWarp * Samba AD * Mint 18.1 * RAID 1/5 * OpenVPN * Linux since kernel 2.0.36

LLS
Level 1
Level 1
Posts: 30
Joined: Sat Nov 18, 2017 9:38 am
Location: County Mayo, Ireland

Re: Downloaded Videos Have No Audio

Post by LLS » Sat Feb 17, 2018 7:16 pm

Thank you coffee412.
However, I've just checked and I already have mint-meta-codecs installed. So its not that.

User avatar
MrEen
Level 6
Level 6
Posts: 1329
Joined: Mon Jun 12, 2017 8:39 pm

Re: Downloaded Videos Have No Audio

Post by MrEen » Sat Feb 17, 2018 7:20 pm

Is it possible that your player is muted?

LLS
Level 1
Level 1
Posts: 30
Joined: Sat Nov 18, 2017 9:38 am
Location: County Mayo, Ireland

Re: Downloaded Videos Have No Audio

Post by LLS » Sat Feb 17, 2018 7:26 pm

MrEen wrote:
Sat Feb 17, 2018 7:20 pm
Is it possible that your player is muted?
It doesn't seem to be.
I should add tht I've tried Media Player and VLC and result is the same.

Hoser Rob
Level 12
Level 12
Posts: 4080
Joined: Sat Dec 15, 2012 8:57 am

Re: Downloaded Videos Have No Audio

Post by Hoser Rob » Sun Feb 18, 2018 10:47 am

VLC should play the audio. But you don't know what's in the files.

Install mediainfo-gui first. It's in the tested repos and essential for media users.

Then open one of the offending files in mediainfo, set the display to Text mode, and copy/paste the text here.

User avatar
phd21
Level 16
Level 16
Posts: 6731
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Downloaded Videos Have No Audio

Post by phd21 » Sun Feb 18, 2018 12:42 pm

Hi LLS,

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

Can you please provide a sample link to one of these videos or links to these videos?

Assuming you installed the 3rd party multi-media codecs during the installation of Linux Mint, then you should be able to play them.

Sometimes links on web pages do not work as expected when they are clicked, so you can try right-clicking the link and selecting "save as".

There are also various video download applications and browser add-on extensions that you can install that might also work well. Applications like, "YouTube-DL" and "YouTube-DLG", "4k video downloader", etc...


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
Flemur
Level 16
Level 16
Posts: 6043
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Downloaded Videos Have No Audio

Post by Flemur » Sun Feb 18, 2018 12:57 pm

LLS wrote:
Sat Feb 17, 2018 5:39 pm
There is a link below each video to download it so it can be viewed off-line. This I've done.
Can you post that link here? ... or does one need to pay money, etc?
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

LLS
Level 1
Level 1
Posts: 30
Joined: Sat Nov 18, 2017 9:38 am
Location: County Mayo, Ireland

Re: Downloaded Videos Have No Audio

Post by LLS » Sun Feb 18, 2018 3:47 pm

Thanks for the replies!
Kate
phd21 wrote:
Sun Feb 18, 2018 12:42 pm

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

Code: Select all

cbdb@laptop ~ $ inxi -Fxzd
System:    Host: laptop Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0) Desktop: Xfce 4.12.3 (Gtk 2.24.28)
           Distro: Linux Mint 18.1 Serena
Machine:   System: HP (portable) product: HP Notebook v: Type1ProductConfigId
           Mobo: HP model: 8305 v: KBC Version 73.15 Bios: Insyde v: F.21 date: 11/01/2016
CPU:       Quad core AMD E2-7110 APU with AMD Radeon R2 Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14373
           clock speeds: max: 1800 MHz 1: 1200 MHz 2: 1350 MHz 3: 1200 MHz 4: 1500 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R3 Graphics] bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.01hz
           GLX Renderer: Gallium 0.4 on AMD MULLINS (DRM 2.43.0 / 4.4.0-53-generic, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be port: 2000 bus-ID: 03:00.0
           IF: wlo1 state: up mac: <filter>
Drives:    HDD Total Size: 240.1GB (6.7% used) ID-1: /dev/sda model: SanDisk_SDSSDHII size: 240.1GB
           Optical: No optical drives detected.
Partition: ID-1: / size: 219G used: 15G (7%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 1.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.2C mobo: 0.0C gpu: 50.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 195 Uptime: 1:04 Memory: 964.0/3415.3MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Code: Select all

cbdb@laptop ~ $ lsusb
Bus 002 Device 003: ID 0bda:b008 Realtek Semiconductor Corp. 
Bus 002 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04f2:b56c Chicony Electronics Co., Ltd 
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Flemur wrote:
Sun Feb 18, 2018 12:57 pm
LLS wrote:
Sat Feb 17, 2018 5:39 pm
There is a link below each video to download it so it can be viewed off-line. This I've done.
Can you post that link here? ... or does one need to pay money, etc?
I have to be logged into my account to access it. However, this seems to work for me logged out so fingercrossed!
This is one of the "problem videos"
https://view.vzaar.com/10886141/download

LLS
Level 1
Level 1
Posts: 30
Joined: Sat Nov 18, 2017 9:38 am
Location: County Mayo, Ireland

Re: Downloaded Videos Have No Audio

Post by LLS » Sun Feb 18, 2018 3:51 pm

Thanks Hoser Rob!
This is the output of the problem file I linked to above.
Kate
Hoser Rob wrote:
Sun Feb 18, 2018 10:47 am
VLC should play the audio. But you don't know what's in the files.

Install mediainfo-gui first. It's in the tested repos and essential for media users.

Then open one of the offending files in mediainfo, set the display to Text mode, and copy/paste the text here.

Code: Select all

General
Complete name                            : /home/cbdb/Downloads/Introductiontothecourseandthecourseteam.mp4
Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom (isom/iso2/avc1/mp41)
File size                                : 7.62 MiB
Duration                                 : 1mn 10s
Overall bit rate mode                    : Variable
Overall bit rate                         : 902 Kbps
Movie name                               : _Welcome message 1.1
Album/Performer                          : Max Budgett
Description                              : This video is about _Welcome message
Encoded date                             : UTC 2017-07-18 13:29:47
Tagged date                              : UTC 2017-07-18 13:29:47
Writing application                      : Lavf53.32.100

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : Main@L3
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 3 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 1mn 10s
Bit rate                                 : 768 Kbps
Width                                    : 646 pixels
Height                                   : 364 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 30.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.109
Stream size                              : 6.49 MiB (85%)
Writing library                          : x264 core 136
Encoding settings                        : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=6 / psy=0 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=48 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=0 / b_adapt=1 / b_bias=0 / direct=1 / weightb=0 / open_gop=0 / weightp=2 / keyint=150 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc=2pass / mbtree=0 / bitrate=768 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / pb_ratio=1.30 / aq=1:1.00
Encoded date                             : UTC 2017-07-18 13:29:47
Tagged date                              : UTC 2017-07-18 13:29:47

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : 40
Duration                                 : 1mn 10s
Bit rate mode                            : Variable
Bit rate                                 : 127 Kbps
Maximum bit rate                         : 128 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 44.1 KHz
Frame rate                               : 43.066 fps (1024 spf)
Compression mode                         : Lossy
Stream size                              : 1.07 MiB (14%)
Language                                 : English
Default                                  : Yes
Alternate group                          : 1
Encoded date                             : UTC 2017-07-18 13:29:47
Tagged date                              : UTC 2017-07-18 13:29:47


Redact
Level 2
Level 2
Posts: 53
Joined: Fri Jan 09, 2015 10:37 am

Re: Downloaded Videos Have No Audio

Post by Redact » Sun Feb 18, 2018 3:57 pm

I don't have the knowledge to help, but to let you and others know - I do get sound from the video you linked to, so the problem is on your end.

LLS
Level 1
Level 1
Posts: 30
Joined: Sat Nov 18, 2017 9:38 am
Location: County Mayo, Ireland

Re: Downloaded Videos Have No Audio

Post by LLS » Sun Feb 18, 2018 4:19 pm

Redact wrote:
Sun Feb 18, 2018 3:57 pm
I don't have the knowledge to help, but to let you and others know - I do get sound from the video you linked to, so the problem is on your end.
Did you view it online or download it? I get sound viewing online but the problem is after i download it!

User avatar
phd21
Level 16
Level 16
Posts: 6731
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Downloaded Videos Have No Audio

Post by phd21 » Sun Feb 18, 2018 4:29 pm

Hi LLS (Kate),

You are welcome from all of use that replied...

I do not see anything wrong with the results of the "inxi -Fxzd" console terminal command, so that is a good thing.

FYI: I meant links to the web page with the download links, not just the download link.

I just tried the link you provided from my Opera browser, Firefox 58, Slimjet, and it downloaded that video and the video and audio work fine. Which browser are you using, perhaps trying another browser?

Are you using the superb sandboxing application "Firejail"? If yes, did you run the fix sound option?


Hope this helps ...
Last edited by phd21 on Sun Feb 18, 2018 4:49 pm, edited 2 times in total.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Redact
Level 2
Level 2
Posts: 53
Joined: Fri Jan 09, 2015 10:37 am

Re: Downloaded Videos Have No Audio

Post by Redact » Sun Feb 18, 2018 4:37 pm

LLS wrote:
Sun Feb 18, 2018 4:19 pm
Did you view it online or download it? I get sound viewing online but the problem is after i download it!
Downloaded by Pale Moon browser.

User avatar
Flemur
Level 16
Level 16
Posts: 6043
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Downloaded Videos Have No Audio

Post by Flemur » Sun Feb 18, 2018 7:06 pm

LLS wrote:
Sun Feb 18, 2018 4:19 pm
Did you view it online or download it? I get sound viewing online but the problem is after i download it!
I can play it fine in vlc and smplayer and the audio is good and clear.

If all else fails, open the downloaded mp4 file in your browser. It plays in firefox.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

LLS
Level 1
Level 1
Posts: 30
Joined: Sat Nov 18, 2017 9:38 am
Location: County Mayo, Ireland

Re: Downloaded Videos Have No Audio

Post by LLS » Mon Feb 19, 2018 9:01 am

Ok i've fixed it!

After doing a comparison with our other laptop which did not have this problem i set about comparing codecs. audio stting etc. No diffeence.

So I reinstalled VLC. still no resolution.

Then went into VLC settings (yet again)
Audio > Audio Device >Built in HDML
Changed it to > Built in Audio Analogue Stereo

I'm convinced only HDML existed before as I've been through this many times. but i could be wrong.

Problem solved! and this also affects Media Player as well!?! Strange.

Thanks to all who offered help!
Kate

Post Reply

Return to “Sound, Multimedia, & Codecs”