Audio is messed up when playing movies

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
ckaibi
Level 1
Level 1
Posts: 5
Joined: Sun Jan 01, 2017 9:51 pm
Location: Switzerland

Audio is messed up when playing movies

Post by ckaibi » Sat Feb 17, 2018 8:26 pm

Few weeks ago I had an issue with a game where cutscenes were not playing correctly. I tried to find the issue and a solution on a forum. I thought it was linked to PulseAudio or ALSA so I modified some parameters in a file but in the end the problem was not solved and I can't remember which file it was. Now every time I play a movie from my PC the voices can barely be heard and the sound is terrible. Videos from other sources have no issue. I can still play game, read MP3s, videos in my browser also play perfectly. It is only when I play videos that are on my PC and the result is the same with all players. Does anyone know where the problem may come from and how to solve it?

ckaibi
Level 1
Level 1
Posts: 5
Joined: Sun Jan 01, 2017 9:51 pm
Location: Switzerland

Re: Audio is messed up when playing movies

Post by ckaibi » Mon Feb 19, 2018 7:23 pm

I managed to fix my issue by reinstalling pulseaudio and ALSA with the following commands:

In a terminal

Code: Select all

sudo apt-get purge pulseaudio
sudo apt-get clean && sudo apt-get autoremove
Reboot. Open a terminal again and type (ignore any errors with the rm command):

Code: Select all

rm -r ~/.pulse ~/.asound* ~/.pulse-cookie ~/.config/pulse
sudo apt-get install pulseaudio
sudo alsa force-reload

Hoser Rob
Level 11
Level 11
Posts: 3856
Joined: Sat Dec 15, 2012 8:57 am

Re: Audio is messed up when playing movies

Post by Hoser Rob » Tue Feb 20, 2018 9:44 am

Nice to see new users figuring out their own answers. Now mark this thread {SOLVED] so others can see an answer.

Post Reply

Return to “Sound, Multimedia, & Codecs”