Installed Audacity, headphones stopped working

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
a coder
Level 1
Level 1
Posts: 21
Joined: Thu Mar 15, 2012 2:30 pm

Installed Audacity, headphones stopped working

Post by a coder » Mon Feb 26, 2018 5:00 pm

I installed Audacity earlier today to make a quick edit on an a MP3 file. I installed 2.1.2 from the default Linux Mint 18 repo, then opened Audacity and selected my file. It played over my headphones just fine. I closed Audacity, then immediately opened it again to select a different file to edit. As Audacity opened I heard an audible 'click' over my headphones. I could no longer hear anything over my headphones whether in Audacity or via browser/youtube or other media player.

I discovered an AskUbuntu question with the same problem. An answer there said that we just needed to open Audacity and select Internal Mic:0. Tried that, and presto had audio over my headphones again. Another answer on the same AU question recommended upgrading from 2.1.2 to the current (then) version of 2.2.0 to get around the bug in the future. So, I uninstalled 2.1.2, and installed 2.2.2 from the ubuntuhandbook repo.

Opened Audacity 2.2.2, only to discover that I now have no headphone volume again, and this time changing the output to Internal Mic:0 did not work. In fact, I cannot get headphone output on any of the 10 output options. Nothing plays over headphones now, not youtube/browser, not files in VLC. Audacity shows signal being played, I just cannot hear over headphones. If I unplug, sound comes over my laptop's speakers.


All of this occurred in less than 5 minutes. Installing Audacity resulted in losing the ability to listen to anything on my laptop over headphones.

I first tried uninstalling Audacity completely, still no headphones. I then opened alsamixer and confirmed that the Headphone channel is not muted (it shows a green oo symbol), and that the Headphone+LO channel has a volume level of around 80%. I confirmed Headphone+LO is the headphone channel by unplugging then replugging the headphones and watching alsamixer switch from Speaker to Headphone+LO.

Headphones unplugged from laptop:
headphones out.png
Headphones plugged into laptop
headphones in.png
Using pavucontrol, I show signal going to Headphones when they are plugged in, but nothing is sounding over my headphones.
pavucontrol.png
I've tried running `alsactl restore` with no luck (no changes, still can hear over speakers but not over headphones when they are correctly and completely plugged in.

Here is the log data from alsa-info.sh: http://www.alsa-project.org/db/?f=d89c4 ... af3110fec2

At a loss on what to do next.

Post Reply

Return to “Sound, Multimedia, & Codecs”