Sound not working in Mint 18.3

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 4:19 am

asinoro wrote:
Sat Mar 03, 2018 3:14 am
You did that before.

Code: Select all

gksudo xed /etc/modprobe.d/alsa-base.conf
At the bottom of the file change 3stack to auto.

Code: Select all

options snd-hda-intel model=auto
Save close reboot and check your sound.
Still no "earphones" and still no sound.

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 4:21 am

Can you post.

Code: Select all

aplay -l

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 5:04 am

asinoro wrote:
Sat Mar 03, 2018 4:21 am
Can you post.

Code: Select all

aplay -l

Code: Select all

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 5:15 am

Change the model=auto to index=1,0

Code: Select all

options snd-hda-intel index=1,0
Save, close, reboot and check again your sound.

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 5:43 am

asinoro wrote:
Sat Mar 03, 2018 5:15 am
Change the model=auto to index=1,0

Code: Select all

options snd-hda-intel index=1,0
Save, close, reboot and check again your sound.
Still no sound. This is what I now have in my /etc/modprobe.d/alsa-base.conf file:

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
#
options snd-hda-intel index=1,0

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 6:31 am

First remove the line from alsa-base.conf.
options snd-hda-intel index=1,0
save and close the file.

Then make a new file.

Code: Select all

gksudo xed /etc/modprobe.d/snd-hda-intel.conf
And add this inside.

Code: Select all

alias char-major-116 snd
alias snd-card-0 snd-hda-intel
alias snd-card-1 snd-hda-intel

options snd-hda-intel id=SB index=0
options snd-hda-intel id=NVidia index=1
Save, close, reboot and check again your sound.

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 7:25 am

asinoro wrote:
Sat Mar 03, 2018 6:31 am
First remove the line from alsa-base.conf.
options snd-hda-intel index=1,0
save and close the file.

Then make a new file.

Code: Select all

gksudo xed /etc/modprobe.d/snd-hda-intel.conf
And add this inside.

Code: Select all

alias char-major-116 snd
alias snd-card-0 snd-hda-intel
alias snd-card-1 snd-hda-intel

options snd-hda-intel id=SB index=0
options snd-hda-intel id=NVidia index=1
Save, close, reboot and check again your sound.

OK, done all that. Still no sound. :(

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 7:52 am

Post again this.

Code: Select all

pactl list sinks

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 7:56 am

asinoro wrote:
Sat Mar 03, 2018 7:52 am
Post again this.

Code: Select all

pactl list sinks

Code: Select all

# pactl list sinks
Sink #3
	State: SUSPENDED
	Name: alsa_output.pci-0000_00_14.2.iec958-stereo
	Description: Built-in Audio Digital Stereo (IEC958)
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 7
	Mute: no
	Volume: front-left: 54394 /  83% / -4.86 dB,   front-right: 55050 /  84% / -4.54 dB
	        balance 0.01
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.pci-0000_00_14.2.iec958-stereo.monitor
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE HW_MUTE_CTRL DECIBEL_VOLUME LATENCY SET_FORMATS 
	Properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC887-VD Digital"
		alsa.id = "ALC887-VD Digital"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "1"
		alsa.card = "1"
		alsa.card_name = "HDA ATI SB"
		alsa.long_card_name = "HDA ATI SB at 0xfe600000 irq 16"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:14.2"
		sysfs.path = "/devices/pci0000:00/0000:00:14.2/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1002"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
		device.product.id = "4383"
		device.product.name = "SBx00 Azalia (Intel HDA)"
		device.form_factor = "internal"
		device.string = "iec958:1"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "iec958-stereo"
		device.profile.description = "Digital Stereo (IEC958)"
		device.description = "Built-in Audio Digital Stereo (IEC958)"
		alsa.mixer_name = "Realtek ALC887-VD"
		alsa.components = "HDA:10ec0887,10438444,00100302"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Ports:
		iec958-stereo-output: Digital Output (S/PDIF) (priority: 0)
	Active Port: iec958-stereo-output
	Formats:
		pcm

Sink #4
	State: SUSPENDED
	Name: alsa_output.pci-0000_01_00.1.hdmi-stereo
	Description: GK107 HDMI Audio Controller Digital Stereo (HDMI)
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 44100Hz
	Channel Map: front-left,front-right
	Owner Module: 6
	Mute: no
	Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor
	Latency: 0 usec, configured 0 usec
	Flags: HARDWARE DECIBEL_VOLUME LATENCY SET_FORMATS 
	Properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "HDMI 0"
		alsa.id = "HDMI 0"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "3"
		alsa.card = "0"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xfe080000 irq 54"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card0"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "0e1b"
		device.product.name = "GK107 HDMI Audio Controller"
		device.string = "hdmi:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "hdmi-stereo"
		device.profile.description = "Digital Stereo (HDMI)"
		device.description = "GK107 HDMI Audio Controller Digital Stereo (HDMI)"
		alsa.mixer_name = "Nvidia GPU 42 HDMI/DP"
		alsa.components = "HDA:10de0042,10b00fc1,00100100"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Ports:
		hdmi-output-0: HDMI / DisplayPort (priority: 5900, not available)
	Active Port: hdmi-output-0
	Formats:
		pcm

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 8:23 am

Change it.

Code: Select all

gksudo xed /etc/modprobe.d/snd-hda-intel.conf
Remove all the other and add only this.

Code: Select all

options snd-hda-intel model=auto
Save, close, reboot and check again your sound.

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 8:42 am

asinoro wrote:
Sat Mar 03, 2018 8:23 am
Change it.

Code: Select all

gksudo xed /etc/modprobe.d/snd-hda-intel.conf
Remove all the other and add only this.

Code: Select all

options snd-hda-intel model=auto
Save, close, reboot and check again your sound.
OK, still no sound. :(

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 8:58 am

Try this.

Code: Select all

gksudo xed /etc/pulse/default.pa
Find this.
#set-default-sink output
and make it.

Code: Select all

set-default-sink alsa_output.pci-0000_00_14.2.iec958-stereo
Save, close, reboot and check again your sound.

If the above do not work replace it to.

Code: Select all

set-default-sink alsa_output.pci-0000_01_00.1.hdmi-stereo
Save, close, reboot and check again your sound.

P.S Try these with 4.4 lts kernel

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 11:09 am

OK, tried both ways, still no sound.

PulseAudio still has the word "silent" on it. I have a feeling this is a key but I cannot find what the lock is that it unlocks. Unfortunately there appears to be nothing online about PulseAudio. :(

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 11:13 am

If no one comes with a suggestion, the last I can think since it works ok in Mint 17 upgrade it to 18 and see. Off course having backup before.

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Sat Mar 03, 2018 11:27 am

If you try.

Code: Select all

sudo modprobe -r snd_hda_intel
and then

Code: Select all

sudo modprobe  snd_hda_intel
Do you see any change?

User avatar
trytip
Level 7
Level 7
Posts: 1849
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sound not working in Mint 18.3

Post by trytip » Sat Mar 03, 2018 1:57 pm

go to .config/pulse DELETE everything and reboot then post output of:

pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2
Image

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 9:45 pm

asinoro wrote:
Sat Mar 03, 2018 11:27 am
If you try.

Code: Select all

sudo modprobe -r snd_hda_intel
and then

Code: Select all

sudo modprobe  snd_hda_intel
Do you see any change?
Yes:

Code: Select all

Nirvanna ~ # modprobe -r snd_hda_intel
modprobe: FATAL: Module snd_hda_intel is in use.
Nirvanna ~ # modprobe  snd_hda_intel
Nirvanna ~ # 
This means?

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sat Mar 03, 2018 9:47 pm

trytip wrote:
Sat Mar 03, 2018 1:57 pm
go to .config/pulse DELETE everything and reboot then post output of:

pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2
Where is "config/pulse"? Please provide the full path.

User avatar
trytip
Level 7
Level 7
Posts: 1849
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sound not working in Mint 18.3

Post by trytip » Sat Mar 03, 2018 9:52 pm

.config/pulse is the complete path
open filemanager and hit ctrl+h which will show hidden files then go to .config/pulse delete everything in there reboot and show the output of the command
Image

lamar
Level 1
Level 1
Posts: 13
Joined: Sun Jul 02, 2017 10:34 am
Location: Maine

Re: Sound not working in Mint 18.3

Post by lamar » Sat Mar 03, 2018 10:18 pm

I don't know if my experiences will help you or not, but here is what I did to get audio in 18.2/3.
Clean installs of 18.2 or 3 would not give audio out with any combination of settings. When I go back and install 18.1 and unmute the line out in alsa mixer, I have good audio. I can then successfully upgrade to 18.2/3 with audio. No other combination would result in audio. Unmuting line out on clean installs of 18.2/3 would not work.
Good luck. These guys are really hanging in there with you. I know you appreciate them all.
lamar

Post Reply

Return to “Sound, Multimedia, & Codecs”