Sound not working in Mint 18.3

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
6syx6
Level 1
Level 1
Posts: 1
Joined: Sun Feb 18, 2018 9:14 pm

Re: Sound not working in Mint 18.3

Post by 6syx6 » Sat Mar 03, 2018 10:42 pm

Did you ever get this figured out?
I'm having a similar issue but with speakers attached. I've tried with headphones as well. I can see action in Output Devices, but no sound output on either.

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sun Mar 04, 2018 12:56 am

trytip wrote:
Sat Mar 03, 2018 1:57 pm
go to .config/pulse DELETE everything and reboot then post output of:

pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2

Code: Select all

$ pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2
alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor
alsa_output.pci-0000_00_14.2.analog-stereo.monitor
alsa_input.pci-0000_00_14.2.analog-stereo

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sun Mar 04, 2018 12:57 am

6syx6 wrote:
Sat Mar 03, 2018 10:42 pm
Did you ever get this figured out?
I'm having a similar issue but with speakers attached. I've tried with headphones as well. I can see action in Output Devices, but no sound output on either.
Nope. Not yet. I am considering a reinstall of an earlier version and see if that fixes the problem. However, I am not happy with having to do that. :(

User avatar
trytip
Level 8
Level 8
Posts: 2059
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sound not working in Mint 18.3

Post by trytip » Sun Mar 04, 2018 1:21 am

how do you connect to audio in the back? are you using hdmi? or the speakers output or headphone jack?
have you tried:
sudo gedit /etc/modprobe.d/alsa-base.conf
Add this to the bottom:

Code: Select all

options snd-hda-intel model=auto
you are using 1024 resolution ? have you installed drivers in the driver manager?
Graphics: Card: NVIDIA GK107 [GeForce GT 640] bus-ID: 01:00.0
Display Server: X.Org 1.17.1 drivers: nouveau (unloaded: fbdev,vesa)
Resolution: 1024x768@60.0hz
Image

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sun Mar 04, 2018 1:34 am

trytip wrote:
Sun Mar 04, 2018 1:21 am
how do you connect to audio in the back? are you using hdmi? or the speakers output or headphone jack?
A headphone connected directly to the hifi output jack on the motherboard.
have you tried:
sudo gedit /etc/modprobe.d/alsa-base.conf
Add this to the bottom:

Code: Select all

options snd-hda-intel model=auto
Tried that already, twice. Didn't work.
you are using 1024 resolution ? have you installed drivers in the driver manager?
Graphics: Card: NVIDIA GK107 [GeForce GT 640] bus-ID: 01:00.0
Display Server: X.Org 1.17.1 drivers: nouveau (unloaded: fbdev,vesa)
Resolution: 1024x768@60.0hz
I am using the inbuilt video drivers in Mint.

User avatar
bartszu
Level 4
Level 4
Posts: 304
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Sound not working in Mint 18.3

Post by bartszu » Sun Mar 04, 2018 1:56 am

OK I did not read this entire tread but I think, I know how to help you.
You don't need to reinstall anything.
First of all you have rainbows nVidia.
Linus-Torvalds-Fuck-You-Nvidia.jpg
But don't you panic it will take more time then regular install to work, but it will work, belive me.

NVIDIA GK107
This is your chipset it has to work as it does bridging, busses, sound and all jazz.
You must use it with all its features, no workaround that.

NVIDIA GK107 [GeForce GT 640] bus-ID: 01:00.0
Display Server: X.Org 1.17.1 drivers: nouveau (unloaded: fbdev,vesa)

But, but,
It cant work on nouveau, nouveau is reversed enginering driver, as source code or chipset designs was never relised by Vidia, it works, on older chippset even works good !!!, but really this is just patch patching a hole, you need to get driver from Vidia.

Open Driver Manager from Menu Start and proceed with install routine.
As you can see, I am using older driver as it is faster on my machine.
Selection_104.jpg

Now you have 2 sound cards:

Audio:
Card-1 NVIDIA GK107 HDMI Audio Controller bus-ID: 01:00.1
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)

You should use only NVIDIA GK107.
Report on progress, it will work, dont mess around kernel and mprobe, no need, with proper driver it will work on kernel 3,0,0.

User avatar
bartszu
Level 4
Level 4
Posts: 304
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Sound not working in Mint 18.3

Post by bartszu » Sun Mar 04, 2018 2:10 am

Well I am wrong:

This is your chipset:
AMD 970/SB950

hmm

User avatar
bartszu
Level 4
Level 4
Posts: 304
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Sound not working in Mint 18.3

Post by bartszu » Sun Mar 04, 2018 2:12 am

rickshaw wrote:
Tue Feb 27, 2018 7:38 am
My sound has stopped working.
So you had sound and it disappered ?

User avatar
trytip
Level 8
Level 8
Posts: 2059
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sound not working in Mint 18.3

Post by trytip » Sun Mar 04, 2018 2:19 am

i don't see an analog output in this picture ... UNcheck the s/pdif set as fallback. it's the checkmark next to the lock on your s/pdif
but that will not work with the headphones so not sure why you don't have sound, do you have sound in the live mint 18.3 ?
Image
Image

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Sun Mar 04, 2018 3:15 am

bartszu wrote:
Sun Mar 04, 2018 2:12 am
rickshaw wrote:
Tue Feb 27, 2018 7:38 am
My sound has stopped working.
So you had sound and it disappered ?
Back with a different motherboard and a different OS. I realise that is not much help but it stopped working when I upgraded to 18.0. I have since changed my motherboard and my OS to 18.3.

I have now broken cinnamon which is, I feel a separate issue.

User avatar
bartszu
Level 4
Level 4
Posts: 304
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Sound not working in Mint 18.3

Post by bartszu » Sun Mar 04, 2018 7:10 am

rickshaw wrote:
Sun Mar 04, 2018 3:15 am
I have now broken cinnamon which is, I feel a separate issue.
Is your hardware sound ?
This might be hardware issue simply.

User avatar
trytip
Level 8
Level 8
Posts: 2059
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sound not working in Mint 18.3

Post by trytip » Sun Mar 04, 2018 1:22 pm

i believe you should read my last post. untick the spdif unplug all your speaker cords from the outputs of the computer reboot THEN plug the speakers in. open a video.

if you can see the volume bar moving up and down then YOU HAVE SOUND but it's not going to the speakers either because it's somehow muted or the cord is bad. you should REALLY install the nvidia drivers
Image

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: Sound not working in Mint 18.3

Post by Sir Charles » Sun Mar 04, 2018 1:32 pm

trytip wrote:
Sun Mar 04, 2018 1:22 pm
open a video.
if you can see the volume bar moving up and down then YOU HAVE SOUND but it's not going to the speakers either because it's somehow muted or the cord is bad. you should REALLY install the nvidia drivers
I was under the impression that rickshaw already HAS SOUND.
rickshaw wrote:
Thu Mar 01, 2018 8:17 am
Marziano wrote:
Thu Mar 01, 2018 8:15 am
Start playing something with your media player and check under Playback tab if you get a moving soundbar.
I get a moving soundbar but no sound comes out of my earphones.
It also has in small print the word "silence" above it.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Mon Mar 05, 2018 1:56 am

I already have sound, according to the PulseAudio output. However it has the word "silence" above it.

I am about to try it with a separate, new set of speakers. I'll see if that works.

[A few minutes later]

Still no sound. :(

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Mon Mar 05, 2018 2:43 am

rickshaw wrote:
Mon Mar 05, 2018 1:56 am
I already have sound, according to the PulseAudio output. However it has the word "silence" above it.

I am about to try it with a separate, new set of speakers. I'll see if that works.

[A few minutes later]

Still no sound. :(

Code: Select all

sudo apt-get install qasmixer
After you start it > View > show device selection > On the right try cards and adjustments.

User avatar
trytip
Level 8
Level 8
Posts: 2059
Joined: Tue Jul 05, 2016 1:20 pm

Re: Sound not working in Mint 18.3

Post by trytip » Mon Mar 05, 2018 3:15 am

omg is your volume muted? :: did you accidentally push the mute volume on the keyboard or on the volume icon in system tray? can you show a snapshot of this "silence" you speak of and also run alsamixer in terminal press F5 and show a snapshot of that
Image

asinoro
Level 4
Level 4
Posts: 246
Joined: Mon Feb 12, 2018 11:43 am

Re: Sound not working in Mint 18.3

Post by asinoro » Mon Mar 05, 2018 3:42 am

Can you post also this?

Code: Select all

cat /proc/asound/modules

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Mon Mar 05, 2018 4:46 am

OK, can we please get this straight?

I do not have a "mute button" on my keyboard. I am using a desktop with a 15 year old mechanical keyboard (why? 'cause I like it's feel).

I do not have any muting that I am aware of on my computer. AlsaVolumeControl does not show my system is muted.

As Cinnamon is presently broken, I do not have a "systray" or any such stuff on my screen. I am presently running WindowMaker.

As you can imagine, I am finding this very frustrating, so bear with me please. I thank all of you for your help.

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Mon Mar 05, 2018 4:51 am

asinoro wrote:
Mon Mar 05, 2018 2:43 am
rickshaw wrote:
Mon Mar 05, 2018 1:56 am
I already have sound, according to the PulseAudio output. However it has the word "silence" above it.

I am about to try it with a separate, new set of speakers. I'll see if that works.

[A few minutes later]

Still no sound. :(

Code: Select all

sudo apt-get install qasmixer
After you start it > View > show device selection > On the right try cards and adjustments.
OK, this is what I get:
Attachments
mixer.jpg

rickshaw
Level 2
Level 2
Posts: 61
Joined: Fri Sep 01, 2017 11:59 pm

Re: Sound not working in Mint 18.3

Post by rickshaw » Mon Mar 05, 2018 4:53 am

asinoro wrote:
Mon Mar 05, 2018 3:42 am
Can you post also this?

Code: Select all

cat /proc/asound/modules
This is the third time I've done this but OK, here goes:

Code: Select all

$ cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel

Post Reply

Return to “Sound, Multimedia, & Codecs”