Bluetooth headphones not working

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
DMG
Level 1
Level 1
Posts: 13
Joined: Mon Dec 12, 2016 2:59 pm

Bluetooth headphones not working

Post by DMG » Tue Mar 20, 2018 3:52 am

Hello!
I have Ausdom M05 bluetooth headphones and I can not make them to work with Linux Mint 18.3 KDE. I installed Blueman, but it is not helping me to fix this issue.

If I select audio sink in blueman it throws error: Connection Failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Only way how they work is when I allow headphones to automatically connect to pc. But even then they stop working after about minute with error:

Code: Select all

20.03.18 09:05	W7211	kernel	[ 3765.618002] input: E8:07:BF:03:83:72 as /devices/virtual/input/input23
20.03.18 09:07	W7211	bluetoothd[1145]	Suspend: Connection timed out (110)
20.03.18 09:07	W7211	bluetoothd[1145]	Abort: Connection timed out (110)
20.03.18 09:07	W7211	acpid	input device has been disconnected, fd 19
20.03.18 09:07	W7211	bluetoothd[1145]	Unable to get io data for Headset Voice gateway: getpeername: Transport endpoint is not connected (107)
20.03.18 09:10	W7211	bluetoothd[1145]	Unable to get Headset Voice gateway SDP record: Connection timed out
20.03.18 09:11	W7211	bluetoothd[1145]	connect error: Connection refused (111)
20.03.18 09:11	W7211	bluetoothd[1145]	connect error: Connection refused (111)
And this solution works only once after restart. And for short period of time.

Can anyone help me? I don't even know, what else I can do, to fix this issue.

mintmdrescher
Level 1
Level 1
Posts: 9
Joined: Thu Jun 11, 2015 9:33 am

Re: Bluetooth headphones not working

Post by mintmdrescher » Wed Mar 21, 2018 1:25 pm

What does 'pactl list' say?
Do you have 'module-bluetooth-discover' loaded?

User avatar
BG405
Level 6
Level 6
Posts: 1427
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Bluetooth headphones not working

Post by BG405 » Wed Mar 21, 2018 3:37 pm

I run pactl load-module module-bluetooth-discover on startup, with a delay of about 20 seconds, on my 17.3 KDE and Cinnamon systems. Then, in Blueman, I sometimes have to select "Audio Sink" first & wait for it to connect, as the "Audio Profile" option is missing initially, then select Audio Profile > High Fidelity Playback (AD2P).

For some reason it (HFP) usually defaults to "Off".
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - Manjaro KDE, LM17.3 KDE 32
Toshiba NB305 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

DMG
Level 1
Level 1
Posts: 13
Joined: Mon Dec 12, 2016 2:59 pm

Re: Bluetooth headphones not working

Post by DMG » Thu Mar 22, 2018 3:13 am

mintmdrescher wrote:
Wed Mar 21, 2018 1:25 pm
What does 'pactl list' say?
Do you have 'module-bluetooth-discover' loaded?
Yes

Code: Select all

Module #26
        Name: module-bluetooth-discover
        Argument: 
        Usage counter: n/a
        Properties:
                module.author = "João Paulo Rechi Vita"
                module.description = "Detect available Bluetooth daemon and load the corresponding discovery module"
                module.version = "8.0"

DMG
Level 1
Level 1
Posts: 13
Joined: Mon Dec 12, 2016 2:59 pm

Re: Bluetooth headphones not working

Post by DMG » Thu Mar 22, 2018 3:18 am

BG405 wrote:
Wed Mar 21, 2018 3:37 pm
I run pactl load-module module-bluetooth-discover on startup, with a delay of about 20 seconds, on my 17.3 KDE and Cinnamon systems. Then, in Blueman, I sometimes have to select "Audio Sink" first & wait for it to connect, as the "Audio Profile" option is missing initially, then select Audio Profile > High Fidelity Playback (AD2P).

For some reason it (HFP) usually defaults to "Off".
Audio Sink in Blueman not working for me at all. I can connect from my android phone, but not from Linux.

Post Reply

Return to “Sound, Multimedia, & Codecs”