no sound device on mint 18.3

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
morc66
Level 1
Level 1
Posts: 6
Joined: Thu May 03, 2018 3:08 am

no sound device on mint 18.3

Post by morc66 » Thu May 03, 2018 5:40 am

Hey all; noob here. I have been using mint for a while on other systems... worked fine. Now installed in on a Akoya netbook which had W10... and worked ok. I missed to check the soundcard when going to linux and now I am stuck with a system without sound.

In several places I see fixes .. but they seem not to work. Any one willing to help out?

All I see is a dummy device.

Code: Select all

 ~ $ aplay -l
aplay: device_list:268: no soundcards found...
 ~ $ inxi -A
Audio:     Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
solutions that seem to work in other cases didn't work .. (reinstalling alsa)

The netbook is an akoya MD60250 / E2228T

Anyone able to help out?

Marziano
Level 6
Level 6
Posts: 1380
Joined: Thu Jan 04, 2018 1:00 pm

Re: no sound device on mint 18.3

Post by Marziano » Thu May 03, 2018 8:10 am

Run the following in a terminal:

Code: Select all

sudo alsa force-reload
Wait for it to run its course. Reboot. Check if you got sound.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

morc66
Level 1
Level 1
Posts: 6
Joined: Thu May 03, 2018 3:08 am

Re: no sound device on mint 18.3

Post by morc66 » Thu May 03, 2018 12:40 pm

nope... tried that .. I even uninstalled reinstalled alsa. . . didn' t work.

dirkjanl
Level 1
Level 1
Posts: 1
Joined: Sun Sep 17, 2017 11:22 am

Re: no sound device on mint 18.3

Post by dirkjanl » Thu May 03, 2018 2:34 pm

I had problems with audio to. I installed:
Pulseaudio-module-x11,
Pavucontrol and
Ubuntu-restricted-extras.
Now I do not have problems anymore.

Regards

morc66
Level 1
Level 1
Posts: 6
Joined: Thu May 03, 2018 3:08 am

Re: no sound device on mint 18.3

Post by morc66 » Thu May 03, 2018 4:09 pm

yeah.. did that .. and re-did it again.. still no sound device found

MrEen
Level 5
Level 5
Posts: 676
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound device on mint 18.3

Post by MrEen » Thu May 03, 2018 4:22 pm

Hi morc66, and welcome to the forum.

I'll assume you already tried deleting/moving the files in ~/.config/pulse/

The kernel you're on isn't patched for Meltdown/Spectre, so that's one upgrade that may also fix your sound issue. To determine the best kernel to try, please post the output of inxi -Fxz

morc66
Level 1
Level 1
Posts: 6
Joined: Thu May 03, 2018 3:08 am

Re: no sound device on mint 18.3

Post by morc66 » Fri May 04, 2018 12:26 am

.. here you go

Code: Select all

System:    Host: MB-Akoya Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: MEDION product: E2228T MD60250 v: DMIC
           Mobo: MEDION model: NT16H v: 1.0
           Bios: American Megatrends v: 5.11 date: 02/27/2017
CPU:       Quad core Intel Atom x5-Z8300 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11520
           clock speeds: max: 1840 MHz 1: 484 MHz 2: 505 MHz 3: 998 MHz
           4: 994 MHz
Graphics:  Card: Intel Device 22b0 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics (Cherrytrail)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card: Intel Wireless 3165 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 62.5GB
           ID-2: /dev/mmcblk2 model: N/A size: 62.0GB
Partition: ID-1: / size: 53G used: 8.0G (16%) fs: ext4 dev: /dev/mmcblk0p2
           ID-2: swap-1 size: 4.21GB used: 0.00GB (0%) fs: swap dev: /dev/mmcblk0p3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 234 Uptime: 3 min Memory: 1120.0/3874.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

MrEen
Level 5
Level 5
Posts: 676
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound device on mint 18.3

Post by MrEen » Fri May 04, 2018 7:03 am

Install the latest kernel in the 4.13 series (Update Manager > View > Linux kernels)

If after a reboot there is still no sound card detected, follow these instructions to get and run the alsa script. Post the URL it outputs here.

morc66
Level 1
Level 1
Posts: 6
Joined: Thu May 03, 2018 3:08 am

Re: no sound device on mint 18.3

Post by morc66 » Fri May 04, 2018 6:22 pm

crashed while going to 4.13 ... 2 times. so went to 4.11

look like something is starting to work.. no sound yet.. but device has emerged.

Code: Select all

upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Fri May  4 22:16:13 UTC 2018


!!Linux Distribution
!!------------------

Linux Mint 18.3 Sylvia \n \l DISTRIB_ID=LinuxMint DISTRIB_DESCRIPTION="Linux Mint 18.3 Sylvia" NAME="Linux Mint" ID=linuxmint ID_LIKE=ubuntu PRETTY_NAME="Linux Mint 18.3" HOME_URL="http://www.linuxmint.com/" SUPPORT_URL="http://forums.linuxmint.com/" BUG_REPORT_URL="http://bugs.launchpad.net/linuxmint/" UBUNTU_CODENAME=xenial


!!DMI Information
!!---------------

Manufacturer:      MEDION
Product Name:      E2228T MD60250
Product Version:   DMIC
Firmware Version:  5.11
Board Vendor:      MEDION
Board Name:        NT16H


!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/10508824:00/status 	 15
/sys/bus/acpi/devices/80860F14:00/status 	 15
/sys/bus/acpi/devices/80860F14:01/status 	 15
/sys/bus/acpi/devices/80860F14:03/status 	 15
/sys/bus/acpi/devices/8086228A:00/status 	 15
/sys/bus/acpi/devices/8086228A:01/status 	 15
/sys/bus/acpi/devices/8086228E:00/status 	 15
/sys/bus/acpi/devices/8086228E:01/status 	 15
/sys/bus/acpi/devices/8086228E:02/status 	 15
/sys/bus/acpi/devices/808622A8:00/status 	 15
/sys/bus/acpi/devices/808622C1:00/status 	 15
/sys/bus/acpi/devices/808622C1:01/status 	 15
/sys/bus/acpi/devices/808622C1:02/status 	 15
/sys/bus/acpi/devices/808622C1:03/status 	 15
/sys/bus/acpi/devices/808622C1:04/status 	 15
/sys/bus/acpi/devices/808622C1:05/status 	 15
/sys/bus/acpi/devices/808622C1:06/status 	 15
/sys/bus/acpi/devices/ACPI0003:00/status 	 15
/sys/bus/acpi/devices/ACPI0011:00/status 	 15
/sys/bus/acpi/devices/FTSC1000:00/status 	 15
/sys/bus/acpi/devices/INT33A4:00/status 	 15
/sys/bus/acpi/devices/INT33D3:01/status 	 15
/sys/bus/acpi/devices/INT33D5:00/status 	 15
/sys/bus/acpi/devices/INT33F4:00/status 	 15
/sys/bus/acpi/devices/INT33FE:01/status 	 15
/sys/bus/acpi/devices/INT33FF:00/status 	 15
/sys/bus/acpi/devices/INT33FF:01/status 	 15
/sys/bus/acpi/devices/INT33FF:02/status 	 15
/sys/bus/acpi/devices/INT33FF:03/status 	 15
/sys/bus/acpi/devices/INT33FF:04/status 	 15
/sys/bus/acpi/devices/INT3400:00/status 	 15
/sys/bus/acpi/devices/INT3403:00/status 	 15
/sys/bus/acpi/devices/INT3403:04/status 	 15
/sys/bus/acpi/devices/INT3406:00/status 	 15
/sys/bus/acpi/devices/INTL9C60:00/status 	 15
/sys/bus/acpi/devices/INTL9C60:01/status 	 15
/sys/bus/acpi/devices/LNXPOWER:01/status 	 15
/sys/bus/acpi/devices/LNXPOWER:02/status 	 15
/sys/bus/acpi/devices/LNXPOWER:08/status 	 2
/sys/bus/acpi/devices/LNXPOWER:09/status 	 2
/sys/bus/acpi/devices/LNXPOWER:0e/status 	 2
/sys/bus/acpi/devices/LNXPOWER:0f/status 	 2
/sys/bus/acpi/devices/LNXPOWER:13/status 	 2
/sys/bus/acpi/devices/LNXPOWER:14/status 	 2
/sys/bus/acpi/devices/LNXPOWER:15/status 	 2
/sys/bus/acpi/devices/LNXPOWER:16/status 	 2
/sys/bus/acpi/devices/LNXPOWER:17/status 	 2
/sys/bus/acpi/devices/MSFT0101:00/status 	 15
/sys/bus/acpi/devices/PNP0103:00/status 	 15
/sys/bus/acpi/devices/PNP0C0D:00/status 	 15
/sys/bus/acpi/devices/PNP0C0F:00/status 	 9
/sys/bus/acpi/devices/PNP0C0F:01/status 	 9
/sys/bus/acpi/devices/PNP0C0F:02/status 	 9
/sys/bus/acpi/devices/PNP0C0F:03/status 	 9
/sys/bus/acpi/devices/PNP0C0F:04/status 	 9
/sys/bus/acpi/devices/PNP0C0F:05/status 	 9
/sys/bus/acpi/devices/PNP0C0F:06/status 	 9
/sys/bus/acpi/devices/PNP0C0F:07/status 	 9
/sys/bus/acpi/devices/device:0c/status 	 15
/sys/bus/acpi/devices/device:1d/status 	 15
/sys/bus/acpi/devices/device:48/status 	 15
/sys/bus/acpi/devices/device:50/status 	 15
/sys/bus/acpi/devices/device:53/status 	 15


!!Kernel Information
!!------------------

Kernel release:    4.11.0-14-generic
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k4.11.0-14-generic
Library version:    
Utilities version:  1.1.0


!!Loaded ALSA modules
!!-------------------

snd_hdmi_lpe_audio


!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [Audio          ]: HdmiLpeAudio - Intel HDMI/DP LPE Audio
                      Intel HDMI/DP LPE Audio


!!PCI Soundcards installed in the system
!!--------------------------------------

00:03.0 Multimedia controller: Intel Corporation Device 22b8 (rev 22)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------



!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2


!!Loaded sound module options
!!---------------------------

!!Module: snd_hdmi_lpe_audio
	id : (null)
	index : -1


!!ALSA Device nodes
!!-----------------

crw-rw----+ 1 root audio 116,  2 May  5 00:11 /dev/snd/controlC0
crw-rw----+ 1 root audio 116,  3 May  5 00:13 /dev/snd/pcmC0D0p
crw-rw----+ 1 root audio 116,  1 May  5 00:11 /dev/snd/seq
crw-rw----+ 1 root audio 116, 33 May  5 00:11 /dev/snd/timer

/dev/snd/by-path:
total 0
drwxr-xr-x 2 root root  60 May  5 00:11 .
drwxr-xr-x 3 root root 140 May  5 00:11 ..
lrwxrwxrwx 1 root root  12 May  5 00:11 pci-0000:00:02.0-platform-hdmi-lpe-audio -> ../controlC0


!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

ARECORD

**** List of CAPTURE Hardware Devices ****

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [Audio]

Card hw:0 'Audio'/'Intel HDMI/DP LPE Audio'
  Mixer name	: ''
  Components	: ''
  Controls      : 5
  Simple ctrls  : 0


!!Alsactl output
!!--------------

--startcollapse--
state.Audio {
	control.1 {
		iface PCM
		name 'IEC958 Playback Mask'
		value ffffffff00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
		comment {
			access read
			type IEC958
			count 1
		}
	}
	control.2 {
		iface PCM
		name 'IEC958 Playback Default'
		value '0082000200000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
		comment {
			access 'read write'
			type IEC958
			count 1
		}
	}
	control.3 {
		iface PCM
		name ELD
		value '0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
		comment {
			access 'read volatile'
			type BYTES
			count 128
		}
	}
	control.4 {
		iface PCM
		name 'Playback Channel Map'
		value.0 0
		value.1 0
		value.2 0
		value.3 0
		value.4 0
		value.5 0
		value.6 0
		value.7 0
		comment {
			access read
			type INTEGER
			count 8
			range '0 - 36'
		}
	}
	control.5 {
		iface CARD
		name 'HDMI/DP Jack'
		value false
		comment {
			access read
			type BOOLEAN
			count 1
		}
	}
}
--endcollapse--


!!All Loaded Modules
!!------------------

Module
rfcomm
ccm
cmdlinepart
hid_multitouch
bnep
intel_spi_platform
intel_spi
spi_nor
mtd
intel_rapl
intel_powerclamp
coretemp
kvm_intel
kvm
irqbypass
punit_atom_debug
crct10dif_pclmul
crc32_pclmul
ghash_clmulni_intel
pcbc
aesni_intel
aes_x86_64
crypto_simd
glue_helper
cryptd
intel_cstate
fdp_i2c
fdp
nci
axp20x_i2c
nfc
axp20x
goodix
silead
snd_soc_rt5670
snd_soc_rt5645
snd_soc_rt5640
kxcjk_1013
industrialio_triggered_buffer
kfifo_buf
snd_soc_rl6231
industrialio
arc4
binfmt_misc
iwlmvm
mac80211
nls_iso8859_1
joydev
input_leds
iwlwifi
uvcvideo
cfg80211
videobuf2_vmalloc
videobuf2_memops
videobuf2_v4l2
videobuf2_core
videodev
media
btusb
btrtl
lpc_ich
shpchp
mei_txe
mei
snd_intel_sst_acpi
snd_intel_sst_core
snd_soc_sst_atom_hifi2_platform
processor_thermal_device
snd_hdmi_lpe_audio
intel_soc_dts_iosf
snd_soc_sst_match
snd_soc_core
snd_compress
ac97_bus
snd_pcm_dmaengine
snd_pcm
snd_seq_midi
snd_seq_midi_event
snd_rawmidi
hci_uart
snd_seq
btbcm
btqca
btintel
dw_dmac
dw_dmac_core
bluetooth
snd_seq_device
extcon_intel_int3496
intel_hid
snd_timer
sparse_keymap
rfkill_gpio
snd
i2c_designware_platform
i2c_designware_core
soundcore
spi_pxa2xx_platform
pwm_lpss_platform
8250_dw
pwm_lpss
tpm_crb
soc_button_array
int3400_thermal
acpi_thermal_rel
dptf_power
int3403_thermal
int3406_thermal
int340x_thermal_zone
acpi_pad
mac_hid
parport_pc
ppdev
lp
parport
autofs4
btrfs
xor
raid6_pq
dm_mirror
dm_region_hash
dm_log
hid_generic
usbhid
mmc_block
i915
i2c_algo_bit
drm_kms_helper
syscopyarea
sysfillrect
sysimgblt
fb_sys_fops
drm
video
i2c_hid
hid
sdhci_acpi
sdhci


!!ALSA/HDA dmesg
!!--------------

[    7.177748] input: Intel HID events as /devices/pci0000:00/INT33D5:00/input/input7
[    7.221967] input: Intel HDMI/DP LPE Audio HDMI/DP as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input8
[    7.242130] proc_thermal 0000:00:0b.0: enabling device (0000 -> 0002)
--
[    7.893754] WARNING: CPU: 1 PID: 421 at /build/linux-hwe-edge-HLHSbp/linux-hwe-edge-4.11.0/drivers/i2c/busses/i2c-designware-baytrail.c:106 baytrail_i2c_acquire+0x133/0x1e0 [i2c_designware_platform]
[    7.893756] Modules linked in: arc4 binfmt_misc iwlmvm mac80211 nls_iso8859_1 joydev input_leds iwlwifi uvcvideo cfg80211 videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core videodev media btusb btrtl lpc_ich shpchp mei_txe mei snd_intel_sst_acpi snd_intel_sst_core snd_soc_sst_atom_hifi2_platform processor_thermal_device snd_hdmi_lpe_audio intel_soc_dts_iosf snd_soc_sst_match snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_pcm snd_seq_midi snd_seq_midi_event snd_rawmidi hci_uart snd_seq btbcm btqca btintel dw_dmac dw_dmac_core bluetooth snd_seq_device extcon_intel_int3496 intel_hid snd_timer sparse_keymap rfkill_gpio snd i2c_designware_platform(+) i2c_designware_core soundcore spi_pxa2xx_platform pwm_lpss_platform 8250_dw pwm_lpss tpm_crb soc_button_array int3400_thermal acpi_thermal_rel
[    7.893835]  dptf_power int3403_thermal int3406_thermal int340x_thermal_zone acpi_pad mac_hid parport_pc ppdev lp parport autofs4 btrfs xor raid6_pq dm_mirror dm_region_hash dm_log hid_generic usbhid mmc_block i915 i2c_algo_bit drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm video i2c_hid hid sdhci_acpi sdhci


MrEen
Level 5
Level 5
Posts: 676
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound device on mint 18.3

Post by MrEen » Fri May 04, 2018 8:21 pm

Well, the first thing to check now is to see if you can do anything with Pavucontrol or is Dummy Output still the only option?

As the 4.13 kernel didn't work for you, I'd suggest trying the latest from the 4.4 series (also patched for Meltdown/Spectre.) Or, maybe try the 4.15.

The only "solution" I've found that involves your Intel Atom x5-Z83xx SoC would have us blacklist the hdmi output, but your system isn't detecting anything else as yet, so that wouldn't work.

If we can find a kernel that gives us an additional listing under !!Soundcards recognised by ALSA, then I'm pretty sure we can get your sound functional. You could just use inxi -A instead of running the script again to see if anything besides HDMI appears.

morc66
Level 1
Level 1
Posts: 6
Joined: Thu May 03, 2018 3:08 am

Re: no sound device on mint 18.3

Post by morc66 » Sat May 05, 2018 3:16 am

MrEen wrote:
Fri May 04, 2018 8:21 pm
Well, the first thing to check now is to see if you can do anything with Pavucontrol or is Dummy Output still the only option?

As the 4.13 kernel didn't work for you, I'd suggest trying the latest from the 4.4 series (also patched for Meltdown/Spectre.) Or, maybe try the 4.15.

The only "solution" I've found that involves your Intel Atom x5-Z83xx SoC would have us blacklist the hdmi output, but your system isn't detecting anything else as yet, so that wouldn't work.

If we can find a kernel that gives us an additional listing under !!Soundcards recognised by ALSA, then I'm pretty sure we can get your sound functional. You could just use instead of running the script again to see if anything besides HDMI appears.
no. at the moment it is the Intel HDMP/LDP LPE Audio analog stereo device. see inxi output:

Code: Select all

Audio:     Card Intel HDMI/DP LPE Audio driver: HdmiLpeAudio
           Sound: Advanced Linux Sound Architecture v: k4.11.0-14-generic

MrEen
Level 5
Level 5
Posts: 676
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound device on mint 18.3

Post by MrEen » Sat May 05, 2018 11:45 am

morc66 wrote:
Sat May 05, 2018 3:16 am
no. at the moment it is the Intel HDMP/LDP LPE Audio analog stereo device. see inxi output:
I'm confused. Where are you seeing analog stereo?

Post Reply

Return to “Sound, Multimedia, & Codecs”