How to enable an Audio Devices?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
microUgly
Level 1
Level 1
Posts: 15
Joined: Sun Nov 11, 2012 12:18 am

How to enable an Audio Devices?

Post by microUgly » Mon May 07, 2018 10:23 pm

I'm running Linux Mint 18.3 (64 bit) with Mate.

I would like to use my Fiio X3 2nd Gen MP3 player as a DAC. It is recognised as a device, but it is disabled.
Screenshot at 2018-05-08 12-16-19.png
What is the trick to enable it?

The following is the output from inxi. Please let me know if there's more specific information I can offer.

Code: Select all

System:    Host: HAL9000 Kernel: 4.13.0-39-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: 970A-D3P v: x.x
           Bios: American Megatrends v: FD date: 02/26/2016
CPU:       Hexa core AMD FX-6300 Six-Core (-MCP-) cache: 12288 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 42196
           clock speeds: max: 3500 MHz 1: 1401 MHz 2: 1405 MHz 3: 1514 MHz
           4: 1838 MHz 5: 1533 MHz 6: 2664 MHz
Graphics:  Card: NVIDIA GK208 [GeForce GT 730] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GT 730/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.111 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GK208 HDMI/DP Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.13.0-39-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2240.5GB (37.2% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 240.1GB
           ID-2: /dev/sdb model: ST2000DM001 size: 2000.4GB
Partition: ID-1: / size: 204G used: 55G (29%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 472M used: 192M (43%) fs: ext2 dev: /dev/sda1
           ID-3: swap-1 size: 17.14GB used: 0.88GB (5%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 38.2C mobo: N/A gpu: 0.0:50C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 410 Uptime: 8 days Memory: 14133.5/16072.4MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by microUgly on Tue May 08, 2018 3:43 am, edited 1 time in total.

User avatar
jimallyn
Level 18
Level 18
Posts: 8119
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: How to enable an Audio Devices?

Post by jimallyn » Mon May 07, 2018 11:31 pm

My guess would be that those who can help you with this will want to know what is the model number of your Fiio device?
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

microUgly
Level 1
Level 1
Posts: 15
Joined: Sun Nov 11, 2012 12:18 am

Re: How to enable an Audio Devices?

Post by microUgly » Tue May 08, 2018 3:47 am

My guess would be that those who can help you with this will want to know what is the model number of your Fiio device?
It is specifically a Fiio X3 2nd Gen device. I have updated the original post.

I suspected the specifics would not matter since the device is recognised -- it's just not enabled as the device for playback. I I have read that under Linux it requires no specific drivers to operate. But I might be naive on what it takes to get it working.

Hoser Rob
Level 11
Level 11
Posts: 3973
Joined: Sat Dec 15, 2012 8:57 am

Re: How to enable an Audio Devices?

Post by Hoser Rob » Wed May 09, 2018 9:25 am

Actually according to that screenshot ALL audio devices are disabled. Are you getting any sound out of it? You should also install pavucontrol if it's not there already ... it's been a while since I had Mate installed.

User avatar
MrEen
Level 5
Level 5
Posts: 808
Joined: Mon Jun 12, 2017 8:39 pm

Re: How to enable an Audio Devices?

Post by MrEen » Wed May 09, 2018 4:37 pm

Hoser Rob wrote:
Wed May 09, 2018 9:25 am
Actually according to that screenshot ALL audio devices are disabled. Are you getting any sound out of it? You should also install pavucontrol if it's not there already ... it's been a while since I had Mate installed.
+1

Once it's installed, type pavucontrol in the terminal. When the window opens, switch to the configuration tab at the top. Then click on the Profile down arrow beside the device you want and select whatever is appropriate in your case (can't say what options will be there, but hopefully something!)

microUgly
Level 1
Level 1
Posts: 15
Joined: Sun Nov 11, 2012 12:18 am

Re: How to enable an Audio Devices?

Post by microUgly » Wed May 09, 2018 6:39 pm

Thanks for the advise so far.

I have installed pavucontrol and ran it. I see the Fiio in the Configuration tab and it's Profile is set to Analogue Stereo Output, which I believe should be fine for this device.

However, it's not listed under the Output Devices tab. The only device here is Dummy Output, even when Show all Output Devices is chosen.
Actually according to that screenshot ALL audio devices are disabled. Are you getting any sound out of it?
You are correct that they are all disabled and I otherwise have no audio. So I guess getting anything to work would be a start :)

Let me know if there's more information I can provide.

User avatar
trytip
Level 7
Level 7
Posts: 1626
Joined: Tue Jul 05, 2016 1:20 pm

Re: How to enable an Audio Devices?

Post by trytip » Wed May 09, 2018 7:00 pm

during playback of video or audio open pavucontrol playback tab and next to your application on the right is a dropdown box menu. if device is able to play you can use this menu to select it
Image

microUgly
Level 1
Level 1
Posts: 15
Joined: Sun Nov 11, 2012 12:18 am

Re: How to enable an Audio Devices?

Post by microUgly » Wed May 09, 2018 9:03 pm

trytip wrote:
Wed May 09, 2018 7:00 pm
during playback of video or audio open pavucontrol playback tab and next to your application on the right is a dropdown box menu. if device is able to play you can use this menu to select it
There's no drop down list :(
Screenshot at 2018-05-10 11-00-20.png
I suspect this is inline with that there is also no devices listed under Output Devices except the Dummy Output devices. And I suspect no devices are listed in Output Devices because they are all disabled.

So I don't know why they are disabled or how to enable them.

User avatar
trytip
Level 7
Level 7
Posts: 1626
Joined: Tue Jul 05, 2016 1:20 pm

Re: How to enable an Audio Devices?

Post by trytip » Wed May 09, 2018 9:37 pm

you may need to install some drivers. never had a dual-gpu or dual sound so not much help there but drivers may solve something about your built-in sound. have you opened the Driver Manager to see if anything can be installed?
Image

Hoser Rob
Level 11
Level 11
Posts: 3973
Joined: Sat Dec 15, 2012 8:57 am

Re: How to enable an Audio Devices?

Post by Hoser Rob » Thu May 10, 2018 7:50 am

According to this ...

http://www.fiio.me/forum.php?mod=viewthread&tid=41872

.... fiios don't seem to work with USB3 ports in Linux, and using USB2 is suggested.

Hoser Rob
Level 11
Level 11
Posts: 3973
Joined: Sat Dec 15, 2012 8:57 am

Re: How to enable an Audio Devices?

Post by Hoser Rob » Thu May 10, 2018 10:26 am

Another thing you can do to see if a USB sound card works at ALSA (ie kernel) level when it doesn;'t seem to in pulseaudio is to just use a media player. One that has an audio module option that says "ALSA USB Audio Codec" or similar. I use SMplayer but VLC has a similar feature (I won't use a player without this option because that just seems brain dead).

This will completely bypass pulseaudio ... it's what I do normally anyway. But using an external DAC system wide as default can be more complex, even assuming it's recognized and works.

microUgly
Level 1
Level 1
Posts: 15
Joined: Sun Nov 11, 2012 12:18 am

Re: How to enable an Audio Devices?

Post by microUgly » Sun May 13, 2018 6:28 pm

Another thing you can do to see if a USB sound card works at ALSA (ie kernel) level when it doesn;'t seem to in pulseaudio is to just use a media player.
That works!

I used VLC, set the Output module to ALSA audio output, and then for the device I selected Fiio USB Audio Class 2.0 DAC, USB Audit Direct hardware device without any conversions.
But using an external DAC system wide as default can be more complex
That's ok. For starters I'm happy just to be able to hear music whilst I work :)
fiios don't seem to work with USB3 ports in Linux, and using USB2 is suggested
That indeed may be my problem for why it does not work normally. None of my USB2 ports work under Mint currently. It's something to do with my Gigabyte motherboard and I haven't got around to trying to fix it.

I will address the USB2 issues with my motherboard and then see if that gets it working with Pulseaudio.

Thanks for everyones assistance with this. Even though I don't yet have it fully working, just getting some music to play is great, and I would not have been able to figure this out.

Post Reply

Return to “Sound, Multimedia, & Codecs”