no sound from speakers in linux 18.3 fresh install

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
govind_rm
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 7:22 am

Re: no sound from speakers in linux 18.3 fresh install

Post by govind_rm » Fri Jun 01, 2018 11:04 pm

i was reading reading some older post and this seemed to have worked , but the problem is i really dont understand anything in it
[url][/viewtopic.php?t=137917#p903667]
can anyone tell me anything about this? i mean the links in this post.

User avatar
MrEen
Level 5
Level 5
Posts: 808
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound from speakers in linux 18.3 fresh install

Post by MrEen » Sat Jun 02, 2018 12:05 am

I'm assuming you meant the hda_analyzer.py is what fixed you? If so, these two lines from it might help:
223 This tool allows change the HDA codec setting using direct hardware access
224 bypassing driver's mixer layer.
I'm guessing the mixer layer is what was messing up your sound.

I'm not much of a scripter so I can't really help any more than that.

govind_rm
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 7:22 am

Re: no sound from speakers in linux 18.3 fresh install

Post by govind_rm » Sat Jun 02, 2018 6:54 am

Well I didn't try it actually. It seemed to have work for him. Rather than messing up more, I thought it would be better if I asked someone who know about this.

Thanks for your help MrEen

govind_rm
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 7:22 am

Re: no sound from speakers in linux 18.3 fresh install

Post by govind_rm » Sat Jun 30, 2018 3:17 am

guys?? anyone?? help please??

User avatar
JoeFootball
Level 6
Level 6
Posts: 1335
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: no sound from speakers in linux 18.3 fresh install

Post by JoeFootball » Sat Jun 30, 2018 12:08 pm

govind_rm wrote:guys?? anyone?? help please??
If you were to boot a live session of Linux Mint 19, do you have sound from the speakers?

You've been thorough in your troubleshooting, so I'm running out of options here. :?

Joe

User avatar
MrEen
Level 5
Level 5
Posts: 808
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound from speakers in linux 18.3 fresh install

Post by MrEen » Sat Jun 30, 2018 12:23 pm

Found another thing to try. In the terminal, type gksudo xed /etc/modprobe.d/alsa-base.conf. Scroll to the bottom of the file and add this line:

Code: Select all

options snd-hda-intel power_save=1
Save the file and reboot.

Hope that helps.

govind_rm
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 7:22 am

Re: no sound from speakers in linux 18.3 fresh install

Post by govind_rm » Sat Jun 30, 2018 12:35 pm

i had hopes for linux 19 unfortunately it also show same problem during live boot.

As far as changing value of powersaver for audio goes, i have tried that as well.it does increases time for 2 or 3 minutes..then same...

i have tried most options, other than[url][viewtopic.php?t=137917#p903667] this.
but i have no idea what it does or how to do it.

User avatar
JoeFootball
Level 6
Level 6
Posts: 1335
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: no sound from speakers in linux 18.3 fresh install

Post by JoeFootball » Sat Jun 30, 2018 1:11 pm

govind_rm wrote:it does increases time for 2 or 3 minutes..then same...
It's curious that sound works for a bit, then doesn't. Almost as if some hardware was warming up to a failure condition.

Have you confirmed that this behavior only exists in Linux Mint? What happens if you boot to a live session of Ubuntu? Or in a totally different branch of Linux? (e.g., Fedora)

Joe

User avatar
MrEen
Level 5
Level 5
Posts: 808
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound from speakers in linux 18.3 fresh install

Post by MrEen » Sat Jun 30, 2018 1:17 pm

Can I see the output of lspci -nn | grep -i audio please.

EDIT: Nevermind, I found what I needed from your list-cards output earlier. Try this: In the terminal, type gksudo xed /etc/modprobe.d/alsa-base.conf. If the last line is still still something like options snd-hda-intel ... delete it then add options snd_hda_intel vid=8086 pid=3b56 power_save=0 snoop=0
Now reboot.

mcdaniels
Level 1
Level 1
Posts: 1
Joined: Tue Jul 03, 2018 2:01 am

Re: no sound from speakers in linux 18.3 fresh install

Post by mcdaniels » Tue Jul 03, 2018 2:37 am

Hi folks,
I have the nearly the same problem on a Asus X5EA Notebook. There is no sound coming out from the speakers although the soundmixer is telling me that there should be. Sometimes it helps if I switch from HDMI Output back to the internal speakers.

For me it seems like to work, until I do a restart or a cold start. For example it worked yesterday evening after deleting the pulse audiosettings for 2-3 restarts. Today (after the notebook was shut down) no sound. What a pity, cause all other components are running very well.

It is the same with the latest Linux Mint release.

Thinking of trying Linux Mint DE.

@TO: How long does the sound work after it is disabled?

govind_rm
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 7:22 am

Re: no sound from speakers in linux 18.3 fresh install

Post by govind_rm » Tue Jul 03, 2018 3:08 am

MrEen wrote:
Sat Jun 30, 2018 1:17 pm
Can I see the output of lspci -nn | grep -i audio please.

EDIT: Nevermind, I found what I needed from your list-cards output earlier. Try this: In the terminal, type gksudo xed /etc/modprobe.d/alsa-base.conf. If the last line is still still something like options snd-hda-intel ... delete it then add options snd_hda_intel vid=8086 pid=3b56 power_save=0 snoop=0
Now reboot.
MrEen that line wasn't there. i tried adding that line,but result was same. sound still exists for few mintues only.
thanks.

User avatar
MrEen
Level 5
Level 5
Posts: 808
Joined: Mon Jun 12, 2017 8:39 pm

Re: no sound from speakers in linux 18.3 fresh install

Post by MrEen » Tue Jul 03, 2018 7:07 am

WOW. I thought for sure that would've fixed it. I'm stumped at this point. Sorry.

govind_rm
Level 1
Level 1
Posts: 24
Joined: Wed May 16, 2018 7:22 am

Re: no sound from speakers in linux 18.3 fresh install

Post by govind_rm » Wed Jul 04, 2018 3:11 am

thats ok.thanks for your time MrEen. :)

Post Reply

Return to “Sound, Multimedia, & Codecs”