Asus c202sa sound not working on mint 18.3

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
LinuxMintNewbGuy
Level 1
Level 1
Posts: 5
Joined: Sat May 19, 2018 6:56 pm

Asus c202sa sound not working on mint 18.3

Post by LinuxMintNewbGuy » Sat May 26, 2018 5:05 pm

I've just installed Linux mint on my Chromebook, and I knew going into it that the keyboard, track pad and sound might not work. I got the track pad and keyboard to work but can't find a proper solution for fixing the sound.

I see:

Code: Select all

00:1b.0 Audio device: Intel Corporation Device 2284 (rev 35)
Are there any drivers that will work on my Chromebook for this audio device? Let me know if you need more information. I'm also aware of GalliumOS but would like to avoid it if possible because I just love Mint!

MrEen
Level 5
Level 5
Posts: 668
Joined: Mon Jun 12, 2017 8:39 pm

Re: Asus c202sa sound not working on mint 18.3

Post by MrEen » Sat May 26, 2018 7:13 pm

Please post back the output from inxi -Fxz as well as aplay -l

It's possible your sound is just muted. run alsamixer in the terminal, use F6 to select your sound card, then under each column, if you see MM that device is muted. Use the arrow keys to highlight that device, then press m to unmute.

LinuxMintNewbGuy
Level 1
Level 1
Posts: 5
Joined: Sat May 19, 2018 6:56 pm

Re: Asus c202sa sound not working on mint 18.3

Post by LinuxMintNewbGuy » Sat May 26, 2018 9:12 pm

MrEen wrote:
Sat May 26, 2018 7:13 pm
Please post back the output from inxi -Fxz as well as aplay -l

It's possible your sound is just muted. run alsamixer in the terminal, use F6 to select your sound card, then under each column, if you see MM that device is muted. Use the arrow keys to highlight that device, then press m to unmute.
Hm. New issue, I can't log in. I put in the right password and it just keeps sending me back. I've read around for fixes and I'll have to look into that first. Maybe a fresh install is needed :cry:

I noticed the alsamixer instructions in a few different spots but my f6 just dims the screen. I think because I had remapped the keyboard when I installed Linux mint. The on screen keyboard and an external keyboard do the same thing. I may try a Bluetooth keyboard but I'm expecting the same results. Any idea how I could press f6 in a different way?

MrEen
Level 5
Level 5
Posts: 668
Joined: Mon Jun 12, 2017 8:39 pm

Re: Asus c202sa sound not working on mint 18.3

Post by MrEen » Sat May 26, 2018 11:20 pm

Maybe someone will know a way to select F6 alternatively, but I couldn't figure it out. If you end up reinstalling, try out sound on the Live system before you begin the install, just so we possibly know how big the issue might be. I have seen some posts about login loops but don't remember seeing a resolution.

Sorry I can't help further at this point.

Good luck.

MrEen
Level 5
Level 5
Posts: 668
Joined: Mon Jun 12, 2017 8:39 pm

Re: Asus c202sa sound not working on mint 18.3

Post by MrEen » Sun May 27, 2018 12:19 am

The login issue might be a file ownership problem (possibly playing with sudo in the wrong places.) See if this helps:

At the login screen, type Ctrl-Alt-F1 and try to login there. If success, then Ctrl-Alt-F7 (on some systems F8) should get you back to your desktop.

Assuming all that works, if find $HOME ! -user $USER returns a bunch of files, use sudo chown -R $USER:$USER /home/$USER to get ownership back.

Hopefully, that gets you back to being able to login normally. Heck, it could possibly even fix your sound issue. Let us know.

Post Reply

Return to “Sound, Multimedia, & Codecs”