[SOLVED] No audio after fresh install

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
ori0n
Level 1
Level 1
Posts: 11
Joined: Sat Jun 09, 2018 1:21 pm

[SOLVED] No audio after fresh install

Post by ori0n » Sun Jun 10, 2018 1:29 pm

No audio is coming out of my speakers or headphones.

Things I did:
  • Run alsamixer and un-mute all elements
  • Updated the kernel
  • Reboot the system
Here is my inxi -Fxz output:

Code: Select all

System:    Host: ori0n-mint Kernel: 4.13.0-43-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Alienware product: Alienware 15 R2 v: 1.4.4
           Mobo: Alienware model: 0X70NC v: A00 Bios: Alienware v: 1.4.4 date: 01/08/2018
CPU:       Quad core Intel Core i7-6820HK (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 21696
           clock speeds: max: 3600 MHz 1: 876 MHz 2: 845 MHz 3: 873 MHz 4: 875 MHz 5: 855 MHz 6: 851 MHz
           7: 878 MHz 8: 829 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA GM204M [GeForce GTX 980M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1920x1080@60.02hz
           GLX Renderer: GeForce GTX 980M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network:   Card-1: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 3b:00.0
           IF: enp59s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci bus-ID: 3c:00.0
           IF: wlp60s0 state: up mac: <filter>
           Card-3: Atheros usb-ID: 001-003
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1128.2GB (0.7% used) ID-1: /dev/sda model: TOSHIBA_THNSNK12 size: 128.0GB
           ID-2: /dev/sdb model: ST1000LM044_HN size: 1000.2GB
Partition: ID-1: / size: 19G used: 6.9G (40%) fs: ext4 dev: /dev/sdb5
           ID-2: /home size: 124G used: 471M (1%) fs: ext4 dev: /dev/sdb4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 60.5C mobo: N/A gpu: 0.0:52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 241 Uptime: 1:07 Memory: 1799.9/32034.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
The output profile set to "analog stereo input" is suspicious to me (see picture below)
Image
Last edited by ori0n on Mon Jun 11, 2018 5:03 am, edited 1 time in total.
Lorem ipsum dolor sit amet.

rado84
Level 3
Level 3
Posts: 150
Joined: Sun Aug 19, 2012 9:31 am

Re: No audio after fresh install

Post by rado84 » Sun Jun 10, 2018 8:07 pm

Did you try with other headphones?
Also, open Synaptic ahd see whether you have the selected libraries installed. By default you get only the first 2 and the rest you must install manually. I used to have all kinds of audio problems (distortions included) before I installed the rest of the selected items (blue background):

Image

User avatar
MrEen
Level 6
Level 6
Posts: 1031
Joined: Mon Jun 12, 2017 8:39 pm

Re: No audio after fresh install

Post by MrEen » Sun Jun 10, 2018 8:47 pm

Hi ori0n.

I tried to help another user with the same audio card and same busid that you have and we were never successful, but that doesn't mean you won't be.

My first suggestion would be to install pavucontrol and run it (in the terminal apt install pavucontrol followed by pavucontrol.) On the Configuration tab make sure Built-in Audio points to Analog Stereo Duplex, then go to the Output Devices tab and make sure Built-in Audio Analog Stereo points to either Speakers or Headphones (as appropriate.) Now play something with sound. Do you hear anything? If not, look at the Playback tab in pavucontrol. Does it show that something is playing?

Another option might be trying the 4.15 kernel as your computer is very new.

Good luck.

ori0n
Level 1
Level 1
Posts: 11
Joined: Sat Jun 09, 2018 1:21 pm

Re: No audio after fresh install

Post by ori0n » Mon Jun 11, 2018 5:02 am

I had those packages installed, and my pavucontrol configuration is ok. I don't know why but this morning everything works!
And I haven't changed anything since yesterday. This is strange...
Last time I installed mint on this computer audio worked with no problems, I hope it will work tomorrow.

Thanks guys!
Lorem ipsum dolor sit amet.

RO-mix
Level 1
Level 1
Posts: 8
Joined: Thu Feb 09, 2017 5:22 pm

Re: [SOLVED] No audio after fresh install

Post by RO-mix » Tue Jul 10, 2018 12:24 pm

Same problem. Repeated after 2 reinstalls. Described in another topic.

Post Reply

Return to “Sound, Multimedia, & Codecs”