No stereo output through headphones

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
SomeoneSomewhere
Level 1
Level 1
Posts: 2
Joined: Sun Jun 17, 2018 9:00 pm

No stereo output through headphones

Post by SomeoneSomewhere » Sun Jun 17, 2018 9:13 pm

Hi, I'm running Linux Mint 18.3 with Cinnamon Desktop.

I'm only getting mono output from my headphones even though the Output Profile is set to "Analog Stereo Output," which is the only option available. When I click the Test Sound button, the audio for the left speaker plays through both and likewise with the right. Any help with troubleshooting would be appreciated. Thanks.

User avatar
MrEen
Level 6
Level 6
Posts: 1329
Joined: Mon Jun 12, 2017 8:39 pm

Re: No stereo output through headphones

Post by MrEen » Sun Jun 17, 2018 9:29 pm

Hi SS, and welcome to the forum.

I don't use Cinnamon so don't have that Test button. I'd suggest you install pavucontrol (in the terminal type apt install pavucontrol) then run it (in the terminal again just type pavucontrol) then check the Configuration tab, as well as the Output Devices tab and you'll probably be able to get what you want.

User avatar
jimallyn
Level 18
Level 18
Posts: 8419
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: No stereo output through headphones

Post by jimallyn » Sun Jun 17, 2018 9:34 pm

You don't have to use the terminal to install pavucontrol, you can do it from Software Manager or Synaptic. You also don't have to start it from the terminal. It will appear in your menu as PulseAudio Volume Control. (Some prefer the terminal, some prefer the GUI. Different strokes for different folks.)
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

User avatar
MrEen
Level 6
Level 6
Posts: 1329
Joined: Mon Jun 12, 2017 8:39 pm

Re: No stereo output through headphones

Post by MrEen » Sun Jun 17, 2018 10:14 pm

jimallyn wrote:
Sun Jun 17, 2018 9:34 pm
You don't have to use the terminal to install pavucontrol, you can do it from Software Manager or Synaptic. You also don't have to start it from the terminal. It will appear in your menu as PulseAudio Volume Control. (Some prefer the terminal, some prefer the GUI. Different strokes for different folks.)
Hi jimallyn. Your point is taken. As I seem to be suggesting this same thing a lot lately, maybe I should make a copy and paste blurb with instuctions for either method.

Thanks for that.

P.S. I don't actually start it either way. I click on the speaker icon in the tray and scroll down to "Sound Settings...", but I don't think that works in every DE.

SomeoneSomewhere
Level 1
Level 1
Posts: 2
Joined: Sun Jun 17, 2018 9:00 pm

Re: No stereo output through headphones

Post by SomeoneSomewhere » Sun Jun 17, 2018 11:10 pm

Well I installed pavucontrol and messed around with the settings for a while, but to no avail. The profiles I was able to set for my headphones resulted in either mono sound or no sound at all. I did however manage to get stereo sound by plugging my headphones into the headphone jack on my monitor instead of my PC. This allowed me to use HDA NVIDIA Digital Stereo instead of Built-in Analog Stereo. Why one works properly and not the other, I don't know, but it works. Not a "solution" per se, but an acceptable workaround.

Thanks for the help.

Post Reply

Return to “Sound, Multimedia, & Codecs”