Burning ISO images blocked by Read Only /dev/sr0

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
brcre
Level 1
Level 1
Posts: 6
Joined: Wed Feb 22, 2012 12:41 pm

Burning ISO images blocked by Read Only /dev/sr0

Post by brcre » Mon Jun 18, 2018 1:49 am

I have 3 systems I'm working on.
Kubuntu and two Linux Mint 18.3 Cinnamon (A laptop and a desktop)
All of them will not burn an iso. /dev/sr* are all Read Only.
Kubuntu using K3b
Mint 18.3 laptop using Brasero and xfburn
Mint 18.3 desktop using Brasero and xfburn

All have the home directory encrypted, which appears to cause a lot of problems.

What I've learned so far:
go to Menu/Sound & Video/(iso burn application of your choice)
This will only read a disc. I cannot burn using this method.
Instead ctrl alt t
brings up a terminal.
type application of choice in, i.e. brasero or xfburn
Now the ISO can be burned
2018-06-17 23-14-04.png
2018-06-17 23-14-04.png (1.33 KiB) Viewed 126 times
*This is my main question. Answers for anything else I'll count as a great bonus
Instead of needing to remember this fix I would like to edit the Menu so it will launch correctly.
Currently the Menu launch command is: brasero %U
The Man page, The Info page, The Ubuntu Forum Page, and the Project page does not list %U as an option, or any other options I could substitute in.
Suggestions?
2018-06-17 23-11-59.png
2018-06-17 23-11-59.png (24.08 KiB) Viewed 126 times

Side topic but adding specifics to the comment I made above about encrypted home drive.
On the Kubuntu system it will lock and go into screen saver mode (screen is black), but will not exit. Sometimes if I get the light just right I can navigate to the unlock box type the password and once I'm in I can Logout and at that point the screen will be lit at the login screen. Otherwise its a alt prtscn reisub to reboot the system.
Also I made the mistake of changing my password on this system and wallet has never recovered. It does not like the new password and prompts at every login for a password.

For the LinuxMint 18.3 Laptop
Can't burn iso from the Menu

For the LinuxMint 18.3 Desktop
It has an Nvidia video card.
The system locks up from time to time and I alt prtscn reisub to reboot the system. Sometimes if I catch it in time I can ctrl alt backspace to logout and that stops it from hard locking, but sometimes I miss that window.
During boot. I will get prompted to enter my password to decrypt the hard drive. But I can't type anything in. ctrl alt del to reboot the system it will go into the Grub menu and I select the OS and I get a black screen with no prompt. Wait a bit and then type my password and it will boot on to the login screen. It was only a guess that I could enter the password on the black screen and it worked.
I can't burn a iso on this system at all. I have yet to figure out how to work around it. On top of encryption this system also has a SATA expansion card the connects to the optical drive, so that is one more layer of confusion.
Screensaver rarely comes on by itself.


Laptop Details

Code: Select all

$ inxi -dx
Drives:    HDD Total Size: 250.1GB (13.9% used) 
			ID-1: /dev/sda model: CT250BX100SSD1 size: 250.1GB
           Optical: /dev/sr0 model: hp DVD A  DS8A9SH rev: EH61 dev-links: cdrom,cdrw,dvd,dvdrw
          	Features: speed: 24x multisession: yes
           	audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
 

Code: Select all

$ cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/mint--vg-root /               ext4    errors=remount-ro 0       1

# /boot was on /dev/sda1 during installation
UUID=f23f7afb-7e3a-436a-b922-3c21d73ab9e5 /boot           ext2    defaults        0       2

#/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0
DESKTOP

Code: Select all

$ inxi -dx
Drives:    
	HDD Total Size: 19173.8GB (7.1% used) 
		ID-1: /dev/sda model: WDC_WD80EFAX size: 8001.6GB
           	ID-2: /dev/sdb model: WDC_WD80EFAX size: 8001.6GB 
           	ID-3: /dev/sdc model: WDC_WD30EZRX size: 3000.6GB
           	ID-4: /dev/sdd model: P200 size: 50.0GB 
           	ID-5: /dev/sde model: KINGSTON_SH103S3 size: 120.0GB
	Optical: /dev/sr0 model: N/A rev: N/A dev-links: cdrom,cdrw,dvd,dvdrw
		Features: speed: 48x multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: N/A

Code: Select all

$ lspci | egrep "PCI\ Express|RAID\ bus|SATA\ controller"
00:17.0 RAID bus controller: Intel Corporation SATA Controller [RAID mode]
02:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 02)
16:02.0 PCI bridge: Intel Corporation Sky Lake-E PCI Express Root Port 1C (rev 04)
17:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9235 PCIe 2.0 x2 4-port SATA 6 Gb/s Controller (rev 11)
64:00.0 PCI bridge: Intel Corporation Sky Lake-E PCI Express Root Port 1A (rev 04)

Code: Select all

$ cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
#This is the root system location
/dev/mapper/mint--vg-root /               ext4    noatime,errors=remount-ro 0       1

# /boot was on /dev/sda2 during installation
UUID=041bfcca-f468-4eec-89fe-84ba0de05fc3 /boot           ext2    defaults        0       2

# /boot/efi was on /dev/sda1 during installation
UUID=28BB-C74E  /boot/efi       vfat    umask=0077      0       1

#/dev/mapper/mint--vg-swap_1 none            swap    sw              0       0
/dev/mapper/cryptswap1 none swap sw 0 0

#/dev/sdd will be used as the temp directory
UUID=61431159-cb6a-4a69-830e-7e27a979ab3e /tmp ext4 noatime,errors=remount-ro 0       1

/dev/mapper/0 /home   ext4 rw,errors=remount-ro 0 1

Post Reply

Return to “Sound, Multimedia, & Codecs”