Loose 3d rendering in some games and 3d apps

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
mouarfff
Level 1
Level 1
Posts: 13
Joined: Sun Jun 10, 2018 7:30 am

Loose 3d rendering in some games and 3d apps

Post by mouarfff » Sat Jun 23, 2018 7:24 pm

Hello,

Often, when I play a big 3d game/app (universes sandbox2, subnautica on wine...), I switch in software rendering mode and my app do become the computer very very slow, I can press (it's long ;...) control+alt+F1 to log in a terminal and kill the app.

It's appear when the computer is hot but, in windows10, for the same, the fan become faster, it's noisy, but it's ok, i can continue to play without any problem (I have a fan dock under the laptop).

I know my laptop is "hot" when a big game is running, but, in linux, it stop hardware rendering (and fan reduce speed has if there is no game) before and the game become slow....

(sorry for my english)

Is there any way to solve this ?

Code: Select all

pegasus@andromeda ~ $ inxi -b
System:    Host: andromeda Kernel: 4.13.0-43-generic x86_64 (64 bit) Desktop: MATE 1.18.0
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: FX503VM v: 1.0 Bios: American Megatrends v: FX503VM.306 date: 01/03/2018
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) speed/max: 900/3800 MHz
Graphics:  Card: NVIDIA Device 1c20
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.01hz
           GLX Renderer: GeForce GTX 1060/PCIe/SSE2 GLX Version: 4.6.0 NVIDIA 396.24.02
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           Card-2: Intel Device 24fd driver: iwlwifi
Drives:    HDD Total Size: 1525.3GB (86.0% used)
Info:      Processes: 298 Uptime: 17:04 Memory: 5903.1/7993.4MB Client: Shell (bash) inxi: 2.2.35

Hoser Rob
Level 12
Level 12
Posts: 4325
Joined: Sat Dec 15, 2012 8:57 am

Re: Loose 3d rendering in some games and 3d apps

Post by Hoser Rob » Sat Jun 30, 2018 9:25 am

First, did you get that Nvidia driver from Driver Manager? That's the most reliable way to get drivers, and in Linux you don't just want the latest one.

I see the BIOS date is 2018. Assuming you didn't update the BIOS that's a very new machine. Go into update manager and install the newest recommended kernel.

But since that may break things (this IS Linux), if that happens, reboot and hold down the Shift key while it's starting the boot. That'll bring up the grub menu and you can select the previous kernel to boot.

mouarfff
Level 1
Level 1
Posts: 13
Joined: Sun Jun 10, 2018 7:30 am

Re: Loose 3d rendering in some games and 3d apps

Post by mouarfff » Tue Jul 03, 2018 9:09 am

Hoser Rob wrote:
Sat Jun 30, 2018 9:25 am
First, did you get that Nvidia driver from Driver Manager? That's the most reliable way to get drivers, and in Linux you don't just want the latest one.

I see the BIOS date is 2018. Assuming you didn't update the BIOS that's a very new machine. Go into update manager and install the newest recommended kernel.

But since that may break things (this IS Linux), if that happens, reboot and hold down the Shift key while it's starting the boot. That'll bring up the grub menu and you can select the previous kernel to boot.
thanks for your attention ;)

The BIOS seem ok, so in windows, asus live update force me to update without my consentement xD
(six mouth early, I had a problem with multiboot after an update, I stopped it, but I often verify and I checked yesterday ... The first bios i had when i bought it was dated to 2017 september/december2017)
In the asus page, the last bios indicated is about april 2018 with number of version 305. For my computer it's the same number, so It's not dated to april but march...

I know how to change kernel, I stayed in 4.13 because I compiled nvhda because no hdmi sound and It worked but the last kernel don't.
I waited 1 mouth to make any update prevent loosing some functionnality and I was right ;) (I loose the possibility to change brightness too ...)

I use ppa" http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main" to have last nvidia driver (i tested "normal version too) but it's the same problem...

another problem was I loose sound when i reboot from windows, and before updates, I had another problem about rebooting freeze on uefi start. Now i don't have this problem....

In feral's games, the log say there is a problem about vulkan

Post Reply

Return to “Sound, Multimedia, & Codecs”