Vestige in LMMS crashes/ Wine error?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
User avatar
MiraclesHappen
Level 1
Level 1
Posts: 34
Joined: Sat Jun 16, 2018 1:44 am
Location: Cambodia
Contact:

Vestige in LMMS crashes/ Wine error?

Post by MiraclesHappen » Tue Jun 26, 2018 10:34 pm

Hi,
My system is Linux Mint 18.3 Cinnamon 64
LMMS 1.1.3 (Linux/x86_64 Qr 4.8.6, GCC 4.8.4)

Sometimes Vestige crashes and last time I got this Wine related error.
My vsts are 32 bit

Unhandled exception: assertion failed in 32-bit code (0xf7f40dc9).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:f7f40dc9 ESP:01c9fc68 EBP:01c9fdf8 EFLAGS:00000282( - -- I S - - - )
EAX:00000000 EBX:00000b17 ECX:00000b1b EDX:00000006
ESI:7c003080 EDI:01c9fd24
Stack dump:
0x01c9fc68: 01c9fdf8 00000006 00000b1b f7b95ea9
0x01c9fc78: f7d1c000 f7b97407 00000006 01c9fca4
0x01c9fc88: 00000000 00000000 00000000 00000000
0x01c9fc98: 01c9fe30 00000001 f7c5dc19 00000020
0x01c9fca8: 00000000 00000000 00000000 00000000
0x01c9fcb8: 00000000 00000000 00000000 00000000
Backtrace:
=>0 0xf7f40dc9 __kernel_vsyscall+0x9() in [vdso].so (0x01c9fdf8)
1 0xf7b95ea9 gsignal+0x38() in libc.so.6 (0x01c9fdf8)
2 0xf7b97407 abort+0x156() in libc.so.6 (0x01c9fdf8)
3 0x7ebebd35 (0x01c9fdf8)
4 0x7ebe9833 (0x01c9fec8)
5 0x7bc7f308 call_thread_func_wrapper+0xb() in ntdll (0x01c9fedc)
6 0x7bc83169 in ntdll (+0x73168) (0x01c9ffdc)
7 0x7bc7f2fa call_thread_exit_func+0x31() in ntdll (0x01c9ffec)
0xf7f40dc9 __kernel_vsyscall+0x9 in [vdso].so: popl %ebp
Modules:
Module Address Debug info Name (94 modules)
PE 10000000-10168000 Deferred synth1 vst
ELF 7b400000-7b7ea000 Deferred kernel32<elf>
\-PE 7b410000-7b7ea000 \ kernel32
ELF 7bc00000-7bcfa000 Dwarf ntdll<elf>
\-PE 7bc10000-7bcfa000 \ ntdll
ELF 7c000000-7c004000 Deferred <wine-loader>
ELF 7d37a000-7d390000 Deferred libgpg-error.so.0
ELF 7d390000-7d405000 Deferred libpcre.so.3
ELF 7d405000-7d4b4000 Deferred libgcrypt.so.20
ELF 7d4b4000-7d4da000 Deferred liblzma.so.5
ELF 7d4da000-7d4e3000 Deferred librt.so.1
ELF 7d4e3000-7d509000 Deferred libselinux.so.1
ELF 7d509000-7d597000 Deferred libsystemd.so.0
ELF 7d597000-7d5a0000 Deferred libffi.so.6
ELF 7d5a0000-7d5b9000 Deferred libresolv.so.2
ELF 7d5b9000-7d5be000 Deferred libkeyutils.so.1
ELF 7d5be000-7d618000 Deferred libdbus-1.so.3
ELF 7d618000-7d6a4000 Deferred libgmp.so.10
ELF 7d6a4000-7d6d9000 Deferred libhogweed.so.4
ELF 7d6d9000-7d716000 Deferred libnettle.so.6
ELF 7d716000-7d72b000 Deferred libtasn1.so.6
ELF 7d72b000-7d75f000 Deferred libidn.so.11
ELF 7d75f000-7d7c0000 Deferred libp11-kit.so.0
ELF 7d7c0000-7d7f1000 Deferred libk5crypto.so.3
ELF 7d7f1000-7d8c7000 Deferred libkrb5.so.3
ELF 7d8c7000-7d8db000 Deferred libavahi-client.so.3
ELF 7d8db000-7da33000 Deferred libgnutls.so.30
ELF 7da33000-7da85000 Deferred libgssapi_krb5.so.2
ELF 7da85000-7db0c000 Deferred libcups.so.2
ELF 7db2f000-7db67000 Deferred uxtheme<elf>
\-PE 7db40000-7db67000 \ uxtheme
ELF 7db67000-7db6e000 Deferred libxfixes.so.3
ELF 7db6e000-7db7a000 Deferred libxcursor.so.1
ELF 7db7a000-7db8d000 Deferred libxi.so.6
ELF 7db8d000-7db91000 Deferred libxcomposite.so.1
ELF 7db91000-7db9e000 Deferred libxrandr.so.2
ELF 7db9e000-7dbaa000 Deferred libxrender.so.1
ELF 7dbaa000-7dbb1000 Deferred libxxf86vm.so.1
ELF 7dbb1000-7dbb5000 Deferred libxinerama.so.1
ELF 7dbb5000-7dbbc000 Deferred libxdmcp.so.6
ELF 7dbbc000-7dbc0000 Deferred libxau.so.6
ELF 7dbc0000-7dbe6000 Deferred libxcb.so.1
ELF 7dbe6000-7dd31000 Deferred libx11.so.6
ELF 7dd31000-7dd46000 Deferred libxext.so.6
ELF 7dd47000-7dd54000 Deferred libkrb5support.so.0
ELF 7dd54000-7dd59000 Deferred libcom_err.so.2
ELF 7dd59000-7dd67000 Deferred libavahi-common.so.3
ELF 7dd69000-7ddf6000 Deferred winex11<elf>
\-PE 7dd70000-7ddf6000 \ winex11
ELF 7ddf6000-7de89000 Deferred gdiplus<elf>
\-PE 7de00000-7de89000 \ gdiplus
ELF 7de89000-7df0a000 Deferred rpcrt4<elf>
\-PE 7de90000-7df0a000 \ rpcrt4
ELF 7df0a000-7e065000 Deferred ole32<elf>
\-PE 7df20000-7e065000 \ ole32
ELF 7e065000-7e0a4000 Deferred winspool<elf>
\-PE 7e070000-7e0a4000 \ winspool
ELF 7e0a4000-7e1c3000 Deferred comctl32<elf>
\-PE 7e0b0000-7e1c3000 \ comctl32
ELF 7e1c3000-7e239000 Deferred shlwapi<elf>
\-PE 7e1d0000-7e239000 \ shlwapi
ELF 7e239000-7e489000 Deferred shell32<elf>
\-PE 7e250000-7e489000 \ shell32
ELF 7e489000-7e574000 Deferred comdlg32<elf>
\-PE 7e490000-7e574000 \ comdlg32
ELF 7e575000-7e599000 Deferred imm32<elf>
\-PE 7e580000-7e599000 \ imm32
ELF 7e649000-7e673000 Deferred libexpat.so.1
ELF 7e673000-7e6bc000 Deferred libfontconfig.so.1
ELF 7e6bc000-7e6e7000 Deferred libpng12.so.0
ELF 7e6e7000-7e702000 Deferred libz.so.1
ELF 7e702000-7e7b2000 Deferred libfreetype.so.6
ELF 7e7d5000-7e9b5000 Deferred user32<elf>
\-PE 7e7f0000-7e9b5000 \ user32
ELF 7e9b5000-7ea2d000 Deferred advapi32<elf>
\-PE 7e9c0000-7ea2d000 \ advapi32
ELF 7ea2d000-7eb5c000 Deferred gdi32<elf>
\-PE 7ea40000-7eb5c000 \ gdi32
ELF 7eb5c000-7eb79000 Deferred libgcc_s.so.1
ELF 7ecf9000-7ed13000 Deferred version<elf>
\-PE 7ed00000-7ed13000 \ version
ELF 7ed13000-7ed43000 Deferred remotevstplugin<elf>
\-PE 7ed20000-7ed43000 \ remotevstplugin
ELF 7ef43000-7ef56000 Deferred libnss_files.so.2
ELF 7ef56000-7ef63000 Deferred libnss_nis.so.2
ELF 7ef63000-7ef7e000 Deferred libnsl.so.1
ELF 7ef7e000-7ef88000 Deferred libnss_compat.so.2
ELF 7ef88000-7efdd000 Deferred libm.so.6
ELF f7b65000-f7b6a000 Deferred libdl.so.2
ELF f7b6a000-f7d20000 Dwarf libc.so.6
ELF f7d20000-f7d3d000 Deferred libpthread.so.0
ELF f7d60000-f7f17000 Dwarf libwine.so.1
ELF f7f18000-f7f3d000 Deferred ld-linux.so.2
ELF f7f40000-f7f41000 Dwarf [vdso].so
Threads:
process tid prio (all id:s are in hex)
0000000e services.exe
00000022 0
0000001d 0
00000013 0
00000010 0
0000000f 0
00000011 winedevice.exe
0000001c 0
00000017 0
00000016 0
00000012 0
0000001a plugplay.exe
0000001f 0
0000001e 0
0000001b 0
00000020 winedevice.exe
00000029 0
00000024 0
00000023 0
00000021 0
00000027 explorer.exe
0000002c 0
0000002b 0
0000002a 0
00000028 0
0000002e RemoteVstPlugin.exe
00000030 0
0000002f 0
00000031 (D) E:\RemoteVstPlugin.exe
00000033 0 <==
00000032 0
00000034 RemoteVstPlugin.exe
00000036 0
00000035 0
00000037 RemoteVstPlugin.exe
00000039 0
00000038 0
System information:
Wine build: wine-3.0.1

Platform: i386 (WOW64)
Version: Windows 7
Host system: Linux
Host version: 4.13.0-45-generic

I'm not experienced enough to file a bug report with Wine, can anyone help?
Thank you!
Life is good but with Linux is even better!

deepakdeshp
Level 11
Level 11
Posts: 3774
Joined: Sun Aug 09, 2015 10:00 am

Re: Vestige in LMMS crashes/ Wine error?

Post by deepakdeshp » Tue Jun 26, 2018 11:59 pm

Pl see if your app is wine compatible
https://appdb.winehq.org
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Hoser Rob
Level 12
Level 12
Posts: 4198
Joined: Sat Dec 15, 2012 8:57 am

Re: Vestige in LMMS crashes/ Wine error?

Post by Hoser Rob » Wed Jun 27, 2018 8:21 am

Searching "linux wine Vestige" gives me nothing from the wine app database but you may want to read this:

https://lmms.io/forum/viewtopic.php?t=1662

BTW searching "linux wine <app name>" is the first thing you should do before trying anything with Wine. Wine is actually a dumb hack and it's very unreliable. Most apps fail.

User avatar
MiraclesHappen
Level 1
Level 1
Posts: 34
Joined: Sat Jun 16, 2018 1:44 am
Location: Cambodia
Contact:

Re: Vestige in LMMS crashes/ Wine error?

Post by MiraclesHappen » Thu Jun 28, 2018 6:52 am

deepakdeshp wrote:
Tue Jun 26, 2018 11:59 pm
Pl see if your app is wine compatible
https://appdb.winehq.org
That list mostly contain games.
I don't have an other OS so it's either Linux or Linux and I'm going to make it work somehow.
It's actually already working, it just crashes occasionally but I've already been able to make music with it!

Thanks anyway!
Life is good but with Linux is even better!

User avatar
MiraclesHappen
Level 1
Level 1
Posts: 34
Joined: Sat Jun 16, 2018 1:44 am
Location: Cambodia
Contact:

Re: Vestige in LMMS crashes/ Wine error?

Post by MiraclesHappen » Thu Jun 28, 2018 6:54 am

Hoser Rob wrote:
Wed Jun 27, 2018 8:21 am
Searching "linux wine Vestige" gives me nothing from the wine app database but you may want to read this:

https://lmms.io/forum/viewtopic.php?t=1662

BTW searching "linux wine <app name>" is the first thing you should do before trying anything with Wine. Wine is actually a dumb hack and it's very unreliable. Most apps fail.
I've already installed Vestige in LMMS and I'm already using my Vsts (32) bit. I've also already made music with it.
However, it does crash occasionally...

Thanks anyway!
Life is good but with Linux is even better!

Hoser Rob
Level 12
Level 12
Posts: 4198
Joined: Sat Dec 15, 2012 8:57 am

Re: Vestige in LMMS crashes/ Wine error?

Post by Hoser Rob » Thu Jun 28, 2018 7:40 am

MiraclesHappen wrote:
Thu Jun 28, 2018 6:54 am
Hoser Rob wrote:
Wed Jun 27, 2018 8:21 am
Searching "linux wine Vestige" gives me nothing from the wine app database but you may want to read this:

https://lmms.io/forum/viewtopic.php?t=1662

BTW searching "linux wine <app name>" is the first thing you should do before trying anything with Wine. Wine is actually a dumb hack and it's very unreliable. Most apps fail.
I've already installed Vestige in LMMS and I'm already using my Vsts (32) bit. I've also already made music with it.
However, it does crash occasionally...

Thanks anyway!
If it crashes occasionally, it's failing.

dagon
Level 7
Level 7
Posts: 1673
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Vestige in LMMS crashes/ Wine error?

Post by dagon » Thu Jun 28, 2018 3:40 pm

MiraclesHappen wrote:
Tue Jun 26, 2018 10:34 pm
I'm not experienced enough to file a bug report with Wine....
Hi!

I believe this is more likely an lmms issue thatn a wine issue. Especially since you're on the latest wine, 3.0.1 and on and old version of lmms, 1.1.3.
The latest and most stable lmms version of lmms is lmms-1.2.0-rc6. It contains a lot of fixes for VST support.
Download the AppImage for Linux here: https://lmms.io/download/#linux

User avatar
MiraclesHappen
Level 1
Level 1
Posts: 34
Joined: Sat Jun 16, 2018 1:44 am
Location: Cambodia
Contact:

Re: Vestige in LMMS crashes/ Wine error?

Post by MiraclesHappen » Fri Jun 29, 2018 1:24 am

dagon wrote:
Thu Jun 28, 2018 3:40 pm
MiraclesHappen wrote:
Tue Jun 26, 2018 10:34 pm
I'm not experienced enough to file a bug report with Wine....
Hi!

I believe this is more likely an lmms issue thatn a wine issue. Especially since you're on the latest wine, 3.0.1 and on and old version of lmms, 1.1.3.
The latest and most stable lmms version of lmms is lmms-1.2.0-rc6. It contains a lot of fixes for VST support.
Download the AppImage for Linux here: https://lmms.io/download/#linux
Thank you, that's good to know. However, after visiting the link you gave me I discovered that the version you mentioned is still in Beta....
I'll stick to the old one for now and if the crashes become regular or frequent, I'll definitely give the beta version a shot.
In the meantime, thanks!
Life is good but with Linux is even better!

dagon
Level 7
Level 7
Posts: 1673
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: Vestige in LMMS crashes/ Wine error?

Post by dagon » Fri Jun 29, 2018 7:18 am

It looks like I edited away half of my reply... :shock:
MiraclesHappen wrote:
Fri Jun 29, 2018 1:24 am
Thank you, that's good to know. However, after visiting the link you gave me I discovered that the version you mentioned is still in Beta....
This is correct... however, I'm part of the lmms development team and can assure you that the latest beta is more stable than 1.1.3 and all devs recommend it. The next, and probably last, beta will be out in a month or two if you're still hesitant.

User avatar
MiraclesHappen
Level 1
Level 1
Posts: 34
Joined: Sat Jun 16, 2018 1:44 am
Location: Cambodia
Contact:

Re: Vestige in LMMS crashes/ Wine error?

Post by MiraclesHappen » Fri Jun 29, 2018 8:20 pm

dagon wrote:
Fri Jun 29, 2018 7:18 am
It looks like I edited away half of my reply... :shock:
MiraclesHappen wrote:
Fri Jun 29, 2018 1:24 am
Thank you, that's good to know. However, after visiting the link you gave me I discovered that the version you mentioned is still in Beta....
This is correct... however, I'm part of the lmms development team and can assure you that the latest beta is more stable than 1.1.3 and all devs recommend it. The next, and probably last, beta will be out in a month or two if you're still hesitant.
Thanks, that's fantastic news! I'm bookmarking this page so if I experience another crash, I'll upgrade it. The reason why I'm not doing it right away is because I messed up my system twice and both times I had to make a clean install. There is a serious issue with Linux and Nvidia Ge-Force graphic cards (anyway, I fixed it with Bumblebee and Nvidia Prime). As a newbie this is kind of challenging for me so the idea of having to uninstall something AGAIN makes me a bit nervous.
These are the steps I followed to install Vestige:

[viewtopic.php?f=48&t=271193&p=1483911&h ... #p1483911l]
Scroll down at the bottom of the page.

Thank you! I'll get back here and marked it solved after having installed the version you suggested!
Life is good but with Linux is even better!

Post Reply

Return to “Sound, Multimedia, & Codecs”