No sound from built in speakers

Forum rules
Before you post please read how to get help
Post Reply
User avatar
d_chad
Level 1
Level 1
Posts: 5
Joined: Mon Jul 09, 2018 6:15 pm
Location: Canada

No sound from built in speakers

Post by d_chad »

Hello, I cannot get audio to work from the built in speakers on a Dell Latitude e6420. I was running mint 18.3 for a while and they originally worked, but I believe an update broke it. I ended up installing mint 19 from scratch but I have the same issue. The headphone jack works fine for audio. To me it seems like it thinks it's always plugged in.
Here is what I see from the command $ pacmd list-sinks :

1 sink(s) available.
* index: 4
name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE
priority: 9039
volume: front-left: 58984 / 90% / -2.74 dB, front-right: 58984 / 90% / -2.74 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max request: 0 KiB
max rewind: 0 KiB
monitor source: 5
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
Stereo
used by: 0
linked by: 0
configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
card: 0 <alsa_card.pci-0000_00_1b.0>
module: 7
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "Generic Analog"
alsa.id = "Generic Analog"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "HDA Intel PCH"
alsa.long_card_name = "HDA Intel PCH at 0xe2e60000 irq 29"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1b.0"
sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "1c20"
device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
device.form_factor = "internal"
device.string = "front:0"
device.buffering.buffer_size = "65536"
device.buffering.fragment_size = "32768"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Analog Stereo"
device.description = "Built-in Audio Analog Stereo"
alsa.mixer_name = "IDT Generic"
alsa.components = "HDA:111d76e7,10280493,00100102 HDA:80862805,80860101,00100000"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
properties:

analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-speakers"

analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
properties:
device.icon_name = "audio-headphones"
active port: <analog-output-headphones>


I tried adding a line to /etc/modprobe.d/alsa-base.conf (options snd-hda-intel model=generic) and that gave me a second option in the sound settings for HDMI/ display port built in audio, but still no built in speaker option shows. I didn't have much luck finding other models to try for snd-hda-intel. Does anyone have any other ideas?

Thanks
User avatar
trytip
Level 13
Level 13
Posts: 4977
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound from built in speakers

Post by trytip »

the most immediate fix is go into .config/pulse and delete everything in there except presets folder or default.pa if you have them, open terminal and type pulseaudio -k wait a few seconds try something with sound
Image
User avatar
MrEen
Level 23
Level 23
Posts: 18140
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound from built in speakers

Post by MrEen »

Hi d_chad, and welcome to the forum.

If you ran pacmd list-sinks with the headphones UNplugged, then I think you are correct about the system thinking they're plugged in. Here's what I would try:
1. Remove the line you added to alsa-base.conf as generic is for testing/debugging only and prevents list-sinks from showing the actual codec in use. Once we see the proper codec, we might have other options to add to alsa-base.conf down the road.
2. Power off the device.
3. Get a can of compressed air and try to give the port a couple quick blasts to hopefully dislodge any debris.
4. If it's still a problem, try the other methods here, carefully.
5. This is a last resort that I don't want you to use until all other avenues have been exhausted, but by then I'll forget, so I'm adding it to the list now. Install alsa-tools-gui so you can use hdajackretask to disable the headphone port to see if that gets the speakers working.

*****************

If this fixes your issue, great! If not, delete the files in ~/.config/pulse/ and issue pulseaudio -k in the terminal. Pulseaudio should restart then test sound. If still not working do pacmd list-sinks again, this time while something with sound is playing on the computer and copy the results.

Enclose the results in-between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.

If headphones were plugged in when you ran pacmd list-sinks then just follow the lower section with the headphones unplugged.
User avatar
d_chad
Level 1
Level 1
Posts: 5
Joined: Mon Jul 09, 2018 6:15 pm
Location: Canada

Re: No sound from built in speakers

Post by d_chad »

Thanks, I never thought of cleaning the jack. I will try that tomorrow and then try the other suggestions. I removed the line I added to the config file and rebooted. Here is the pacmd list-sinks command again while audio is playing and nothing is plugged into the jack.

Code: Select all

$ pacmd list-sinks
1 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: 
	priority: 9039
	volume: front-left: 58984 /  90% / -2.74 dB,   front-right: 58984 /  90% / -2.74 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 216.54 ms
	max request: 63 KiB
	max rewind: 64 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 371.52 ms; range is 0.50 .. 371.52 ms
	card: 0 <alsa_card.pci-0000_00_1b.0>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "92HD90BXX Analog"
		alsa.id = "92HD90BXX Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xe2e60000 irq 29"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "1c20"
		device.product.name = "6 Series/C200 Series Chipset Family High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		alsa.mixer_name = "IDT 92HD90BXX"
		alsa.components = "HDA:111d76e7,10280493,00100102 HDA:80862805,80860101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
			properties:
				
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-headphones>

User avatar
trytip
Level 13
Level 13
Posts: 4977
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound from built in speakers

Post by trytip »

@d_chad try:

Code: Select all

pacmd set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo
@RO-mix try

Code: Select all

pacmd set-card-profile alsa_output.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
Last edited by trytip on Tue Jul 10, 2018 1:19 pm, edited 1 time in total.
Image
RO-mix
Level 1
Level 1
Posts: 8
Joined: Thu Feb 09, 2017 5:22 pm

Re: No sound from built in speakers

Post by RO-mix »

pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
did not work
User avatar
trytip
Level 13
Level 13
Posts: 4977
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound from built in speakers

Post by trytip »

redo without pacmd
Image
RO-mix
Level 1
Level 1
Posts: 8
Joined: Thu Feb 09, 2017 5:22 pm

Re: No sound from built in speakers

Post by RO-mix »

di@station:~$ set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
set-card-profile: command not found
User avatar
trytip
Level 13
Level 13
Posts: 4977
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound from built in speakers

Post by trytip »

did you try creating a new user to see if sound is the same?
Image
User avatar
d_chad
Level 1
Level 1
Posts: 5
Joined: Mon Jul 09, 2018 6:15 pm
Location: Canada

Re: No sound from built in speakers

Post by d_chad »

I tried cleaning the port out but it didn't make a difference. I ran the command

Code: Select all

pacmd set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo+input:analog-stereo 
and that didn't seem to change anything. I installed alsa-tools-gui and in hdajackretask, I overrode the pin configuration "Black headphone, left side" to not connected. The "Speakers - Built in Audio" option now shows up in the Sound Settings and audio is working through the speakers. I seem to remember having both icons visible in the sound settings (headphones and speakers) when I first installed Mint 18.3.

I tried enabling the headphones and disabling again to test and it didn’t work the 2nd time. Rebooted and tried it again with hdajackretask and it does work. So not the greatest work around but at least I can force them to work now if needed.

Also tried deleting ~/.config/pulse/ and ran

Code: Select all

pulseaudio -k
. No change.

Maybe it is the headphone jack sensing is physically broken somehow? I could try another OS to test that theory I guess unless there are any other ideas?
User avatar
trytip
Level 13
Level 13
Posts: 4977
Joined: Tue Jul 05, 2016 1:20 pm

Re: No sound from built in speakers

Post by trytip »

only way to test if your hardware is OK is download a different distro run it live and see if your sound is working. ya, i know it doesn't solve issues here but at least you'll know. i suggest downloading an arch whatever run it live test your videos and audio and then come back with the info that it does/doesn't work . antergos is as good as any to test
Image
User avatar
MrEen
Level 23
Level 23
Posts: 18140
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound from built in speakers

Post by MrEen »

Hi d_chad. If you wanted to play with the alsa-base.conf file again, I found some options that might apply to your system. I say might, because my list doesn't have your 92HD90BXX listed, but it does have some slighly lower numbered options that I'll paste here. Note that you'll need to log out/in (or reboot) after each change.

Code: Select all

STAC92HD73*
===========
  ref		Reference board
  no-jd		BIOS setup but without jack-detection
  intel		Intel DG45* mobos
  dell-m6-amic	Dell desktops/laptops with analog mics
  dell-m6-dmic	Dell desktops/laptops with digital mics
  dell-m6	Dell desktops/laptops with both type of mics
  dell-eq	Dell desktops/laptops
  alienware	Alienware M17x
  auto		BIOS setup (default)

STAC92HD83*
===========
  ref		Reference board
  mic-ref	Reference board with power management for ports
  dell-s14	Dell laptop
auto BIOS setup (default)
I would try anything that has dell listed first, such as options snd-hda-intel model=dell-s14

It's totally up to you whether you want to try this. But remember that if it doesn't help, that you remove the changes you made.
User avatar
d_chad
Level 1
Level 1
Posts: 5
Joined: Mon Jul 09, 2018 6:15 pm
Location: Canada

Re: No sound from built in speakers

Post by d_chad »

Thanks, I will give those a try too.
User avatar
d_chad
Level 1
Level 1
Posts: 5
Joined: Mon Jul 09, 2018 6:15 pm
Location: Canada

Re: No sound from built in speakers

Post by d_chad »

I never could get this working right. Tried a few different live distro's and they all did the same thing. I tried all of the dell combinations in alsa-base.conf with no luck. Only way I can get sound seems to be using hdajackretask. I did find a couple other posts on the net with similar model dell laptops with the same problem so it must just be an unsupported model. Any other ideas or am I stuck using hdajackretask?
User avatar
MrEen
Level 23
Level 23
Posts: 18140
Joined: Mon Jun 12, 2017 8:39 pm

Re: No sound from built in speakers

Post by MrEen »

Now that you know how you can use hdajackretask, see if this post helps. What I'm thinking is instead of disabling a pin, use an override on an unconnected pin to see if you can get everything working.
Post Reply