No Sound Output. Sony VGN-FS990 (VAIO)

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 2
Joined: Mon Jul 16, 2018 4:58 pm

No Sound Output. Sony VGN-FS990 (VAIO)

Post by fammly420 » Mon Jul 16, 2018 5:37 pm

Hello everyone, I recently installed Linux Mint on an old Sony VAIO PCG-7M1L VGN-FS990 and the sound is not working, if it is possible for me to check if the sound card works I would really appreciate if someone could provide with the steps/ instructions to do these checks. If there is any information i must provide please let me know and i will get it back as soon as i can, Everything else seems to work fine except the sound. Under the "Output" section where it says "Device", there are no devices displayed and under "Device Settings" it says "Analog Stereo Input". When i try to test sound nothing plays. i know the speakers work because when i power it on the VAIO logo comes up and it plays a sound.

User avatar
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound Output. Sony VGN-FS990 (VAIO)

Post by MrEen » Mon Jul 16, 2018 6:19 pm

Hi fammly420, and welcome to the forum.

My first suggestion is to install PulseAudio Volume Control (pavucontrol) either through the Software Manager or Synaptic Package Manager or the terminal command apt install pavucontrol.

Once installed, run it from the menu or just pavucontrol in the terminal. On the Configuration tab, you'll probably want to select Analog Stereo Duplex. Then on the Output Devices tab, you can select Speakers, Headphones, Line Out, etc. as per your needs. This may be all you need to do.

If still no sound, play a song or video on your computer then type following terminal commands: inxi-Fxz, aplay -l and pacmd list-sinks. Copy the results of all 3 of those and paste them back here. Enclose the results in-between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.

Level 1
Level 1
Posts: 2
Joined: Mon Jul 16, 2018 4:58 pm

Re: No Sound Output. Sony VGN-FS990 (VAIO)

Post by fammly420 » Wed Jul 18, 2018 3:57 pm

Thank you so much for the quick reply, I installed Pavucontrol, I have it set to Analog Stereo Duplex under Configuration and i have the option to choose Line Out or Headphones as the Port for Built-in Audio Analog Stereo under Output Devices. I played a song on youtube and the speakers would play for few seconds, then stop, sometimes it would resume but not always and sometimes the speakers don't play at all. I decided to play the song with pavucontrol open and noticed that when the port is set to line out i get no sound from the speakers but when it is set to headphones the speakers play. So basically if i set it to headphones the speakers will play audio but after a few seconds it switches to line out which plays no audio through the speakers and it will often switch back to headphones but not always. If it is set to line out it will stay on line out playing no sound from the speakers though and no matter which port i choose the activity meter always works even when the speakers are playing.
i tried turning off "set as fallback" but it turns back on everytime.
I ran the 3 commands in terminal while playing a song on youtube.

Code: Select all

locksafevault@locksafevault-VGN-FS990:~$ inxi -Fxz
System:    Host: locksafevault-VGN-FS990 Kernel: 4.15.0-24-generic i686 bits: 32 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Sony product: VGN-FS990 v: C3LMJUNV serial: N/A
           Mobo: N/A model: N/A serial: N/A BIOS: Phoenix v: R0044J2 date: 05/19/2006
Battery    BAT0: charge: 51.6 Wh 100.0% condition: 51.6/55.0 Wh (94%) model: Sony status: Charging
CPU:       Single core Intel Pentium M (-UP-) arch: Dothan rev.8 cache: 2048 KB
           flags: (nx pae sse sse2) bmips: 3458 speed: 1733 MHz (max)
Graphics:  Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@59.55hz
           OpenGL: renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 version: 1.4 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card-1: Intel PRO/Wireless 2200BG [Calexico2] Network Connection
           driver: ipw2200 v: 1.2.2kmprq bus-ID: 06:04.0
           IF: wlp6s4 state: up mac: <filter>
           Card-2: Intel 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile
           driver: e100 v: 3.5.24-k2-NAPI port: 2000 bus-ID: 06:08.0
           IF: enp6s8 state: down mac: <filter>
Drives:    HDD Total Size: 100.0GB (21.9% used)
           ID-1: /dev/sda model: HTS541010G9AT00 size: 100.0GB
Partition: ID-1: / size: 84G used: 14G (17%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 154 Uptime: 2:42 Memory: 982.3/2003.0MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Code: Select all

locksafevault@locksafevault-VGN-FS990:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Code: Select all

locksafevault@locksafevault-VGN-FS990:~$ pacmd list-sinks
1 sink(s) available.
  * index: 2
	name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
	driver: <module-alsa-card.c>
	state: RUNNING
	suspend cause: 
	priority: 9039
	volume: front-left: 48861 /  75% / -7.65 dB,   front-right: 49420 /  75% / -7.35 dB
	        balance 0.01
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 24.61 ms
	max request: 4 KiB
	max rewind: 64 KiB
	monitor source: 5
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	used by: 1
	linked by: 3
	configured latency: 25.00 ms; range is 0.50 .. 371.52 ms
	card: 0 <alsa_card.pci-0000_00_1b.0>
	module: 7
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix" = "ALC260 Analog" = "ALC260 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel"
		alsa.long_card_name = "HDA Intel at 0xb0000000 irq 24"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci" = "8086" = "Intel Corporation" = "2668" = "82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer" = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		alsa.mixer_name = "Realtek ALC260"
		alsa.components = "HDA:10ec0260,104d0000,00100300 HDA:14f12bfa,104d0200,00090000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
		analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
				device.icon_name = "audio-headphones"
	active port: <analog-output-lineout>

User avatar
Level 12
Level 12
Posts: 4425
Joined: Mon Jun 12, 2017 8:39 pm

Re: No Sound Output. Sony VGN-FS990 (VAIO)

Post by MrEen » Wed Jul 18, 2018 4:53 pm

Hi again fammly420. You did a very good job of trying to troubleshoot and getting extra info for us to try to help solve this problem. Thanks for that.

The quickest fix that sometimes works is going into your home folder and deleting the files in /.config/pulse/ followed by pulseaudio -k in the terminal. Wait a moment, then test your sound.

I am suspecting the kernel might be your issue. Before we potentially spend a bunch of time trying various fixes, I'd like you to try booting to a previous kernel and see if that solves the issue (probably doesn't matter which one but 4.15.0-23 would be fine.) The 4.15.0-24 kernel you're using has caused various issues for many people, so it's best to eliminate that possibility.

Also, since you'll be rebooting anyway to try this, make a quick stop in your BIOS setup and see if there's anything sound related in there that is not enabled and make sure to enable anything you find.

The only issue (other than the kernel version) that I spotted in your reply, is there was no option for Speakers. That should be the name for the laptops built-in speakers I'm pretty sure. Line out is usually for speakers that are plugged in to the computer. Hopefully, that funky kernel is the cause of this and everything will work properly after the change.

If you need instructions on booting to a previous kernel just say so and I'll throw something together (or someone else will offer it.)

Good luck!

Post Reply

Return to “Sound, Multimedia, & Codecs”