Logout/login sound problem...

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
User avatar
invex
Level 2
Level 2
Posts: 78
Joined: Sun Aug 14, 2016 12:38 pm

Logout/login sound problem...

Post by invex » Tue Jul 17, 2018 1:49 am

I'm using Mint 19 Cinnamon and sound is played through HDMI.
When I log out and log back in the sound is switched to laptop internal speaker.
(On restart HDMI is automatically selected.)
It's annoying.
Any way to fix it?
TIA

User avatar
KoHoSo
Level 1
Level 1
Posts: 34
Joined: Tue Oct 19, 2010 10:38 pm
Location: Crestline, California USA
Contact:

Re: Logout/login sound problem...

Post by KoHoSo » Sat Jul 21, 2018 4:47 am

I am having the same problem with Linux Mint 19 MATE 64-bit. I have built-in analog surround sound that has had no issues since I first built the computer I am using which covers several past versions of Linux Mint including 18.3. However, in 19, when I boot up, somehow it has picked up my Blue Yeti microphone as being an output source and, worse yet, always defaults to it no matter how many times I change it back to my onboard sound.

Is there a way to lock in this setting or delete the microphone as an output? I will be glad to provide any information requested to help solve the problem.
Quando Omni Flunkus Moritati (When all else fails, play dead)

User avatar
MrEen
Level 7
Level 7
Posts: 1698
Joined: Mon Jun 12, 2017 8:39 pm

Re: Logout/login sound problem...

Post by MrEen » Sat Jul 21, 2018 3:54 pm

This site should help you set the default card.

User avatar
invex
Level 2
Level 2
Posts: 78
Joined: Sun Aug 14, 2016 12:38 pm

Re: Logout/login sound problem...

Post by invex » Sun Jul 22, 2018 12:46 pm

You can run:
pactl list short sinks
to get a list of audio devices.
In my case I added to startup:
pactl set-default-sink 'alsa_output.0.hdmi-stereo.1f.3.hdmi-stereo'
Now HDMI sound is set as default.
If your HDMI shows multiple times, add more commands to startup.
It works but when I log out/log in the internal speaker is still selected but when I reboot HDMI is always set as default.

User avatar
MrEen
Level 7
Level 7
Posts: 1698
Joined: Mon Jun 12, 2017 8:39 pm

Re: Logout/login sound problem...

Post by MrEen » Sun Jul 22, 2018 2:31 pm

See if the solution on this thread solves that for you.

User avatar
invex
Level 2
Level 2
Posts: 78
Joined: Sun Aug 14, 2016 12:38 pm

Re: Logout/login sound problem...

Post by invex » Sun Jul 22, 2018 2:56 pm

It worked.
Thank you very much.

User avatar
KoHoSo
Level 1
Level 1
Posts: 34
Joined: Tue Oct 19, 2010 10:38 pm
Location: Crestline, California USA
Contact:

Re: Logout/login sound problem...

Post by KoHoSo » Sun Jul 22, 2018 3:07 pm

MrEen wrote:
Sun Jul 22, 2018 2:31 pm
See if the solution on this thread solves that for you.
Unfortunately, that does not work for MATE. As for the previous link you posted, is there a certain header under which I should place the new text defining the profile and card I want used or something I should overwrite? I just tried that and got the same result...output defaults to my Yeti microphone instead of the analog output.
Quando Omni Flunkus Moritati (When all else fails, play dead)

User avatar
MrEen
Level 7
Level 7
Posts: 1698
Joined: Mon Jun 12, 2017 8:39 pm

Re: Logout/login sound problem...

Post by MrEen » Sun Jul 22, 2018 4:04 pm

KoHoSo wrote:
Sun Jul 22, 2018 3:07 pm
MrEen wrote:
Sun Jul 22, 2018 2:31 pm
See if the solution on this thread solves that for you.
Unfortunately, that does not work for MATE. As for the previous link you posted, is there a certain header under which I should place the new text defining the profile and card I want used or something I should overwrite? I just tried that and got the same result...output defaults to my Yeti microphone instead of the analog output.
The last section of my default.pa looks like this:
### Make some devices default
#set-default-sink output
#set-default-source input
If the card # you found from the previous steps is 1, make that section look like this:
### Make some devices default
set-default-profile 1 (whatever output/input you wanted here such as output:analog-stereo+input:analog-stereo without the parentheses)
set-default-sink 1
#set-default-source input
Don't forget you have to restart pulseaudio (or reboot) for the setting to start working. In the terminal pulseaudio -k should be enough.

User avatar
KoHoSo
Level 1
Level 1
Posts: 34
Joined: Tue Oct 19, 2010 10:38 pm
Location: Crestline, California USA
Contact:

Re: Logout/login sound problem...

Post by KoHoSo » Mon Jul 23, 2018 12:29 am

MrEen, your example at the end showed me what I was doing wrong when editing the default.pa file. I made the changes as per your example, rebooted, and the correct output now starts as it should. Thank you for taking the time to help!
Quando Omni Flunkus Moritati (When all else fails, play dead)

User avatar
MrEen
Level 7
Level 7
Posts: 1698
Joined: Mon Jun 12, 2017 8:39 pm

Re: Logout/login sound problem...

Post by MrEen » Mon Jul 23, 2018 2:02 am

You are both very welcome. :)

Post Reply

Return to “Sound, Multimedia, & Codecs”