some help would be welcome!!!

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
getaway
Level 2
Level 2
Posts: 66
Joined: Tue Jul 15, 2014 3:11 am
Location: Bretagne, France

some help would be welcome!!!

Post by getaway » Fri Jul 27, 2018 11:24 am

I've been having constant troubles with the audio system of my laptop for a few weeks now.
Troubles began when I tried to upgrade from 18.3 to 19 and at the same time tried to use a JBL extrem bluetooth speaker.
I tried a lot of things around alsa, pulseaudio, bluetooth (removing, reinstalling, restarting...), returning to 18.3 using timeshift... Everythings according to what I was understanding from my readings or was been told on this forum.
From this experience, my general feeling is that these subsystems are very unstable (at least on my computer...). Things working well for a time didn't work at all after rebooting. And then, sometimes, after a lot of new trials to fix, started to work again, more or less...

The problem is also that I'm not an expert... More of a newby... In that chase for the anomaly, I feel like a blind person at everything I try. Most of what I do, I don't understand at all.
Could anybody tell me about some links to tutos or knowledge base to better understand what is supposed to happen beetwen Alsa, Pulseaudio and Bluetooth? Where and how can I read status of things and objects?

Practically, just now I've lost the audio Icon in the status bar of the laptop (down right the screen) for 2 or 3 days and I found nothing to make it reappearing... Yesterday evening, the bluetooth speakers were working, but not the internal one. Today it's the contrary... The internal ones work with rythmbox but the sound test from the audio window doesn't work! The bluetooth speakers are connected, but don't appear in the audio window and remain silent...
Could anybody be interested in this mess???
Linuxmint Cinnamon Tara 19 64 bits
Asus X200MA and UX430U

User avatar
MrEen
Level 6
Level 6
Posts: 1330
Joined: Mon Jun 12, 2017 8:39 pm

Re: some help would be welcome!!!

Post by MrEen » Fri Jul 27, 2018 3:34 pm

Hello again, getaway. I recently lost my volume icon and apt install indicator-sound brought it back.

Here are some of my bookmarks regarding sound:

ALSA - Debian Wiki

PulseAudio - ArchWiki

SoundTroubleshooting - Community Help Wiki

Advanced Linux Sound Architecture/Troubleshooting - ArchWiki

These are the more general bookmarks I have. I have a lot more that are specific to one problem. Most were found with searches such as linux headphones not working or ubuntu speakers crunching. For us, using ubuntu in the search often means the instructions to solve the issue are exactly the same in Mint (and you'll find a lot more results for fixing Ubuntu than you will for Mint.) The only caveat can be the age of the result (i.e. solutions for Ubuntu versions older than xenial may not work or file locations may have changed.)

I have never had bluetooth on any of my computers so I don't have any bookmarks on that subject. Forum moderator JeremyB is very knowledgeable on the subject (as I'm sure many others are.) I just clicked on Advanced search (looks like a cog on the right of the search bar), typed bluetooth for keyword, and JeremyB for author and got 1312 matches here: search.php?keywords=bluetooth&terms=all ... mit=Search

Reading through a few pages of those posts might help learning a little about the subject.

Good luck. :)

getaway
Level 2
Level 2
Posts: 66
Joined: Tue Jul 15, 2014 3:11 am
Location: Bretagne, France

Re: some help would be welcome!!!

Post by getaway » Fri Jul 27, 2018 4:21 pm

I actually do thank you MrEen.
This post just witnessed a bit of determent...
I'll read through the links you gave me.
And I'll stick to linux, even if I don't very well understand why :(

As a matter of fact, the icon reappeared in my notification barr... And I'm not even sure why :cry: :cry: :cry:
Just now, sound is running ok except for the bluetooth things....

I do thank you again
Linuxmint Cinnamon Tara 19 64 bits
Asus X200MA and UX430U

Post Reply

Return to “Sound, Multimedia, & Codecs”