[SOLVED]Onbord sound card and Blue Yeti pro, loses settings after reboot

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
User avatar
MrEen
Level 6
Level 6
Posts: 1336
Joined: Mon Jun 12, 2017 8:39 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by MrEen » Sat Jul 28, 2018 2:17 pm

Try killall jackd followed by pulseaudio -D

User avatar
MrEen
Level 6
Level 6
Posts: 1336
Joined: Mon Jun 12, 2017 8:39 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by MrEen » Sat Jul 28, 2018 2:18 pm

Taxick wrote:
Sat Jul 28, 2018 2:14 pm
Should I try to uncomment

Code: Select all

### Make some devices default
set-card-profile 0  output:analog-surround-51
set-default-sink 0
#set-default-source input 1
??
Not yet.

Taxick
Level 1
Level 1
Posts: 19
Joined: Mon Jul 23, 2018 2:49 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by Taxick » Sat Jul 28, 2018 2:22 pm

Code: Select all

taxick@Taxick-Mint:~$ killall jackd
jackd: no process found
taxick@Taxick-Mint:~$ 

Code: Select all

taxick@Taxick-Mint:~$ pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed.
taxick@Taxick-Mint:~$ 
Not yet.
OK :)

User avatar
MrEen
Level 6
Level 6
Posts: 1336
Joined: Mon Jun 12, 2017 8:39 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by MrEen » Sat Jul 28, 2018 2:25 pm

Dammit. This is truly weird. Go ahead and uncomment those lines and see if that gets you back to where you started.

Taxick
Level 1
Level 1
Posts: 19
Joined: Mon Jul 23, 2018 2:49 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by Taxick » Sat Jul 28, 2018 2:29 pm

Okay...

The sound is back!
The icon right corner is back.

But it still selects the blue yeti as default.

Taxick
Level 1
Level 1
Posts: 19
Joined: Mon Jul 23, 2018 2:49 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by Taxick » Sat Jul 28, 2018 2:36 pm

If i helps, its this line that get the sound to crash

Code: Select all

set-card-profile 0  output:analog-surround-51
Both with and without

Code: Select all

output:analog-surround-51

User avatar
MrEen
Level 6
Level 6
Posts: 1336
Joined: Mon Jun 12, 2017 8:39 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by MrEen » Sat Jul 28, 2018 2:38 pm

Okay, that's good. I need to go do some yard work.

The only thing I can think of is to alter what we did in default.pa to the following:

Code: Select all

set-card-profile 0  output:analog-surround-51+input:analog-stereo
set-default-sink 1
If it doesn't work, comment it out again. Also, delete the files the ~/.config/pulse/ <---maybe try that before altering default.pa

I'll check in again in a few hours. Good luck.

User avatar
MrEen
Level 6
Level 6
Posts: 1336
Joined: Mon Jun 12, 2017 8:39 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by MrEen » Sat Jul 28, 2018 2:43 pm

Crud. Just caught my mistake, I think. see above edit (sink=1)

User avatar
phd21
Level 16
Level 16
Posts: 6744
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by phd21 » Sat Jul 28, 2018 2:51 pm

Hi Taxick,

I just read your post and the good replies to it. Here are my thoughts on this as well.

I have a similar issue with my Linux Mint KDE 18.3 system not restoring my changes to my sound configuration. Although it is not difficult to set them again each and every time I restart, there may be another option.

I always install pulse audio volume control and qasmixer. Once you have the sound settings the way you want them using Sound Settings, Pulse audio volume control, or QasMixer, while that sound application is still up and running, bring up a console terminal and issue a save command:

Code: Select all

sudo alsactl store

To restore your settings from then on, even after rebooting or logging out, just run the command below.

Code: Select all

sudo alsactl restore
This can be added to a script file and or startup script file whenever you login, only I do not yet know how to do that using "sudo" for the required root user permission.


FYI: If you have made a lot of changes to pulse audio which most users do not have to do, you might be better off deleting that hidden user "./config/pulse" folder and rebooting before trying the above commands. Or re-installing pulse audio packages again.
=============================================================================
Qasmixer and alsamixer not saving user changes:
Save settings Alsamixer CloudReady
https://neverware.zendesk.com/hc/en-us/ ... -Alsamixer

alsa - Howto save AlsaMixer settings? - Ask Ubuntu
https://askubuntu.com/questions/50067/h ... r-settings

alsa - Howto save AlsaMixer settings? - Ask Ubuntu
https://askubuntu.com/questions/50067/h ... r-settings
------------------------------------------------------------------------------------------------------------------------------
Yes I launched alsamixer as Sudo and saved it as Sudo.

I've seen ubuntu support where it states to save the settings it is necessary to open a second terminal and input the store command when alsamixer (or QasMixer and or Pulse audio Volume Control) is still running in the first terminal.

You can easily make the settings stay after reboot!

just use this command: sudo alsactl store

AFTER you applied the settings ;-

This should store all the settings in the configuration file, and make sure it works on boot ;-
==============================================================================
Firstly type in terminal "alsamixer" to enter the alsamixer UI. Then make the configurations you neede.g increase speakers/headphones level or unmute something pressing "m" on keyboard. Now the most important part. Before you exit alsamixer, open a new terminal and do : "sudo su" to get high privileges Be very careful with commands you use in "sudo su" mode because you may destroy your system and then do "alsactl store" to save alsa settings. Then close both terminals and restart your computer. This will do the job.

==============================================================================

FYI: Install "pulse audio volume control" from the "Synaptic Package Manager SPM". There are some really nice graphical GUI programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager SPM that you can install and use. Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" and make it fullscreen, on the right side you will have mixer devices where you can control your system sound. If you do not see the mixer devices, hit "F6". The mixer item "sysdefault" will show all installed sound card devices, and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. There are also various other check boxes below that you can use, and depending upon your sound cards that sometimes includes headphone checkboxes and or sliders as well, like "Headphone Jack Sense".

QasTools: Applications
http://xwmw.org/qastools/applications.html

The applications included are:
- qasconfig - browser for the alsa configuration tree
- qashctl - mixer for alsa's high level control interface
- qasmixer - desktop mixer with features similar to alsamixer

Qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a sytem tray icon with basic mixer functionality.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Taxick
Level 1
Level 1
Posts: 19
Joined: Mon Jul 23, 2018 2:49 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by Taxick » Sat Jul 28, 2018 3:23 pm

MrEen wrote:
Sat Jul 28, 2018 2:43 pm
Crud. Just caught my mistake, I think. see above edit (sink=1)
Hi.

I'm sorry, but no sound again, and no icon in the corner.

My edit:

Code: Select all

set-card-profile 0  output:analog-surround-51+input:analog-stereo
set-default-sink 1
#set-default-source input 1
I have removed the settings, and sound is back!

I have also deleted ~/.config/pulse/

phd21 wrote:
Sat Jul 28, 2018 2:51 pm
Hi Taxick,

I just read your post and the good replies to it. Here are my thoughts on this as well.

I have a similar issue with my Linux Mint KDE 18.3 system not restoring my changes to my sound configuration. Although it is not difficult to set them again each and every time I restart, there may be another option.

I always install pulse audio volume control and qasmixer. Once you have the sound settings the way you want them using Sound Settings, Pulse audio volume control, or QasMixer, while that sound application is still up and running, bring up a console terminal and issue a save command:

Code: Select all

sudo alsactl store

To restore your settings from then on, even after rebooting or logging out, just run the command below.

Code: Select all

sudo alsactl restore
This can be added to a script file and or startup script file whenever you login, only I do not yet know how to do that using "sudo" for the required root user permission.


AFTER you applied the settings ;-

This should store all the settings in the configuration file, and make sure it works on boot ;-
==============================================================================
Firstly type in terminal "alsamixer" to enter the alsamixer UI. Then make the configurations you neede.g increase speakers/headphones level or unmute something pressing "m" on keyboard. Now the most important part. Before you exit alsamixer, open a new terminal and do : "sudo su" to get high privileges Be very careful with commands you use in "sudo su" mode because you may destroy your system and then do "alsactl store" to save alsa settings. Then close both terminals and restart your computer. This will do the job.

==============================================================================
Hi, Thanks for also trying to help me out...

I can fine use:

Code: Select all

sudo alsactl store
But when i try to load it agian after reboot, i get this error:

Code: Select all

taxick@Taxick-Mint:~$ sudo alsactl restore
[sudo] password for taxick: 
alsactl: set_control:1461: Cannot write control '2:0:0:BLUE Internal Clock Validity:0' : Operation not permitted
taxick@Taxick-Mint:~$ 

User avatar
MrEen
Level 6
Level 6
Posts: 1336
Joined: Mon Jun 12, 2017 8:39 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by MrEen » Sat Jul 28, 2018 3:35 pm

I'm an idiot. Your very first post shows the problem on the Configuration tab of pavucontrol. Change the Blue USB profile to something that only has input (duplex is input and output.)

Taxick
Level 1
Level 1
Posts: 19
Joined: Mon Jul 23, 2018 2:49 pm

Re: Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by Taxick » Sat Jul 28, 2018 4:02 pm

No - I'm an idiot! You're my survivor! Thanks a lot for all your time you spent on me... Its really appreciated

It all WORKS now!

Sorry for being such a NOOB - IM Really a NOOB!

Have a great evening here from Denmark!

Also thanks to @phd21 witch some with a useful post as well.

Again THANKS!

User avatar
MrEen
Level 6
Level 6
Posts: 1336
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED]Onbord sound card and Blue Yeti pro, loses settings after reboot

Post by MrEen » Sat Jul 28, 2018 4:05 pm

You're very welcome from all of us. :D

Post Reply

Return to “Sound, Multimedia, & Codecs”