Mint 19 Fresh install no sound.

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 3:03 pm

TIA I went from Win 10 to Mint 19 on an HP tower, Win 10 was too slow, but the sound worked. The install seemed OK, but now I have no sound. Hopefully I put this in the right forum.

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 4:50 pm

Hi ADee, and welcome to the forum.

Please open a terminal and paste these in one at a time, then use your mouse to copy what the terminal returns and paste it back here.

inxi -Fxz

aplay -l

When pasting what the terminal returned please enclose the results in-between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 5:08 pm

I hope I got the format correct.

Code: Select all

frank@frank-HP-ProDesk-405-G1-MT:~$ inxi -Fxz
System:    Host: frank-HP-ProDesk-405-G1-MT Kernel: 4.18.5-041805-generic x86_64
           bits: 64 gcc: 8.2.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Hewlett-Packard product: HP ProDesk 405 G1 MT serial: N/A
           Mobo: Hewlett-Packard model: 2171 v: NULL serial: N/A
           BIOS: AMI v: 80.04 date: 12/25/2013
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Mouse status: Discharging
           hidpp__1: charge: N/A condition: NA/NA Wh
           model: Logitech K520 status: Discharging
CPU:       Dual core AMD E1-2500 APU with Radeon HD Graphics (-MCP-) 
           arch: Jaguar rev.1 cache: 1024 KB
           
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 5590
           clock speeds: max: 1400 MHz 1: 865 MHz 2: 985 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 210] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce 210/PCIe/SSE2
           version: 3.3.0 NVIDIA 340.106 Direct Render: Yes
Audio:     Card-1 NVIDIA High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series]
           driver: snd_hda_intel bus-ID: 02:00.0
           Sound: Advanced Linux Sound Architecture v: k4.18.5-041805-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 4500.9GB (19.8% used)
           ID-1: /dev/sda model: ST1500DM003 size: 1500.3GB
           ID-2: /dev/sdb model: TOSHIBA_DT01ACA3 size: 3000.6GB
Partition: ID-1: / size: 1.4T used: 15G (2%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 8.53GB used: 0.00GB (0%)
           fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 70.2C mobo: N/A gpu: 0.0:53C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 152 Uptime: 6 min Memory: 762.2/7919.1MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
frank@frank-HP-ProDesk-405-G1-MT:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Creative [HDA Creative], device 0: ALC898 Analog [ALC898 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
frank@frank-HP-ProDesk-405-G1-MT:~$ 

Code: Select all

frank@frank-HP-ProDesk-405-G1-MT:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Creative [HDA Creative], device 0: ALC898 Analog [ALC898 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
frank@frank-HP-ProDesk-405-G1-MT:~$ 

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 6:47 pm

Everything's looking promising so far.

I suggest install and run PulseAudio Volume Control (pavucontrol) and go to the Configuration tab (farthest on the right.)

You'll probably have two sections there, one for HDMI and one for regular sound. If the regular sound is what you're after, make it's setting Analog Stereo Duplex, and then go to the Output Devices tab and select as appropriate there (speakers, headphones, line, etc.)

HDMI is slightly trickier as you'll have a plethora of options.

If that doesn't get the sound going, start a song or video and issue pacmd list-sinks in the terminal and paste the results back here.

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 8:50 pm

PulseAudio Volume Control was the firs thing I tried before posting here. Here are the terminal results with an .wav file playing. MP3 files make no sound either.
Thanks!

Code: Select all

frank@frank-HP-ProDesk-405-G1-MT:~$ pacmd list-sinks
1 sink(s) available.
  * index: 1
	name: <alsa_output.pci-0000_02_00.0.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: 
	priority: 9039
	volume: front-left: 52428 /  80% / -5.81 dB,   front-right: 52428 /  80% / -5.81 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 83.08 ms
	max request: 15 KiB
	max rewind: 64 KiB
	monitor source: 1
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 90.00 ms; range is 0.50 .. 371.52 ms
	card: 1 <alsa_card.pci-0000_02_00.0>
	module: 8
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC898 Analog"
		alsa.id = "ALC898 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HDA Creative"
		alsa.long_card_name = "HDA Creative at 0xfe204000 irq 36"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:02:00.0"
		sysfs.path = "/devices/pci0000:00/0000:00:02.3/0000:02:00.0/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1102"
		device.vendor.name = "Creative Labs"
		device.product.id = "0012"
		device.product.name = "Sound Core3D [Sound Blaster Recon3D / Z-Series] (SB1570 SB Audigy Fx)"
		device.string = "front:1"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Sound Core3D [Sound Blaster Recon3D / Z-Series] (SB1570 SB Audigy Fx) Analog Stereo"
		alsa.mixer_name = "Realtek ALC898"
		alsa.components = "HDA:10ec0899,11020041,00100003"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: yes)
			properties:
				
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-lineout>
frank@frank-HP-ProDesk-405-G1-MT:~$ 

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 9:11 pm

It shows as playing to Line out. Do you have speakers plugged in and are they turned on?

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 9:20 pm

Yes, and I tried another set of speakers from another PC, same brand and model speakers. They didn't work on this PC. The speakers are on and worked on the other computer.
Last edited by ADee on Tue Sep 04, 2018 9:22 pm, edited 1 time in total.

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 9:22 pm

Okay. Give me a few moments and I'll have something to test.

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 9:25 pm

No problem, I appreciate the help.

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 9:33 pm

Damn. I was hoping the ALC898 codec would have something we could try but it's pretty much all for acers. We'll try the default though and see if that kickstarts sound.

In the terminal type xed admin:///etc/modprobe.d/alsa-base.conf and scroll to the bottom of the file and add this new line:

Code: Select all

options snd_hda_intel model=auto
Save the file and reboot and test sound.

If that doesn't work, I've got something a little trickier to try.

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 9:42 pm

I added it, saved the file, rebooted and still no sound.

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 9:54 pm

Okay. In the terminal type apt install alsa-tools-gui and when it's installed, run hdajackreatsk in the terminal.

When that opens, click the box like thing up top and choose the ALC898 codec. Under Green Line Out check the box for Override then click Apply now and test your sound.

I'm not very familiar with hdajackretask but this post from this afternoon was solved this way (different issue.) You might have to fool a bit with those settings, clicking Apply now and testing with each change. If something then works, you can click on Install boot override to make it permanentish.

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 9:57 pm

Also, if you haven't fully shut down the computer since installing, that's certainly worth a shot.

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 10:01 pm

Not sure what to do with this message: I'm a Win 10 convert, and learning.

Code: Select all

frank@frank-HP-ProDesk-405-G1-MT:~$ hdajackreatsk

Command 'hdajackreatsk' not found, did you mean:

  command 'hdajackretask' from deb alsa-tools-gui

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 10:05 pm

Yup, you mispelled it because I mispelled it ... hdajackretask <-- much better! :oops:

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Tue Sep 04, 2018 10:06 pm

I'm about to hit the sack for the night. One other thing worth trying is delete the files in ~/.config/pulse/ then issue pulseaudio -k in the terminal, wait 10 seconds then test sound.

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Tue Sep 04, 2018 10:08 pm

While I was waiting, I took your advice and turned the machine off, and on again. I have sound! THANKS!!!!!!!

Should I reverse the first step I did in this process? If so how?

Good night and thanks! I'll check back in the morning.....

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 19 Fresh install no sound.

Post by MrEen » Wed Sep 05, 2018 7:11 am

It's probably a good idea. Use xed admin:///etc/modprobe.d/alsa-base.conf again and delete the line you added. It won't apply until your next reboot, but I don't think there is any urgency for that.

Glad you're fixed. :)

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound. SOLVED

Post by ADee » Wed Sep 05, 2018 8:19 am

Will do! Thanks for the help.

ADee
Level 2
Level 2
Posts: 56
Joined: Tue Sep 04, 2018 2:58 pm

Re: Mint 19 Fresh install no sound.

Post by ADee » Wed Sep 05, 2018 8:42 am

Last question I hope.

Since I never completed this phase, should I do anything to remove alsa-tools-gui?

Okay. In the terminal type apt install alsa-tools-gui and when it's installed, run hdajackreatsk in the terminal.

When that opens, click the box like thing up top and choose the ALC898 codec. Under Green Line Out check the box for Override then click Apply now and test your sound.

I'm not very familiar with hdajackretask but this post from this afternoon was solved this way (different issue.) You might have to fool a bit with those settings, clicking Apply now and testing with each change. If something then works, you can click on Install boot override to make it permanentish.

Post Reply

Return to “Sound, Multimedia, & Codecs”