[SOLVED]There is no input sound from microphone

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

[SOLVED]There is no input sound from microphone

Post by Domin_PL » Fri Sep 14, 2018 5:26 pm

Hello everybody,
I have been surfing through internet for over 3 days and I did not success in finding the solution for my problem.

Well, to introduce, I'd love to record voice from the microphone, but I have no input (blank record).
The microphone I use is not native, it is built-in with bluetooth headphones (JBL T450BT), iPhone headphones with microphone also don't work and from built-in pc there is lots of noise that makes the voice unhearable.

To make it more clear, I'm running Linux Mint 19 Tara 64 bit on Lenovo T430s, i5-3320M, 8GB ram, SSD (anyway that doesn't matter I think) with dualboot Windows 10. On Windows I have no issues with my headphones so they are OK (and new btw).

Playing with sound settings didn't give me any effect. In "alsamixer" heaphones are not muted, I set values for them to be max.
My codecs:
:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC269VC
Codec: Intel PantherPoint HDMI

I have no issuess with connecting to headphones, using them to listen to music etc, the only thing that stucks is microphone.

Do you guys have any ideas what can I do?

Bests
Last edited by Domin_PL on Fri Sep 21, 2018 7:30 am, edited 1 time in total.

JeremyB
Level 19
Level 19
Posts: 9166
Joined: Fri Feb 21, 2014 8:17 am

Re: There is no input sound from microphone

Post by JeremyB » Fri Sep 14, 2018 5:32 pm

You will likely need to go into sound settings and change the headphones to HSP/HFP audio profile for the microphone to work, then check input devices in sound settings

Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

Re: There is no input sound from microphone

Post by Domin_PL » Sat Sep 15, 2018 6:16 am

@Jeremy I've currently changed to HSP/HFP but when using the microphone from headphones every app crashes when starting to record. I tried several apps, I tried sound recorders from store and a web one. Each of them doesn't start recording/crashes

User avatar
phd21
Level 16
Level 16
Posts: 6984
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: There is no input sound from microphone

Post by phd21 » Sat Sep 15, 2018 10:48 am

HI Domin_PL,

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.


FYI: Install "pulse audio volume control" from the "Synaptic Package Manager (SPM)" if it is not already installed. There are some really nice graphical (GUI) programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager (SPM) that you can install and use. Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" and make it fullscreen, on the right side you will have mixer devices where you can control your system sound. If you do not see the mixer devices, hit "F6". The mixer item "sysdefault" will show all installed sound card devices, and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. There is a microphone button in the lower right that may need to be enabled (on). There are also various other checkboxes below that you can use, and depending upon your sound card(s) that sometimes includes headphone checkboxes and or sliders as well, like "Headphone Jack Sense".

QasTools: Applications
http://xwmw.org/qastools/applications.html

The applications included are:
- qasconfig - browser for the alsa configuration tree
- qashctl - mixer for alsa's high level control interface
- qasmixer - desktop mixer with features similar to alsamixer

Qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a system tray icon with basic mixer functionality.

And, you may have to go into the System Settings Sound preferences, or "pulse audio volume control", to set the default configuration to "duplex", and the default input to the microphone you want to use if there is more than one microphone.


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

Re: There is no input sound from microphone

Post by Domin_PL » Sat Sep 15, 2018 2:32 pm

Okay, thank you, here is output from inxi -Fxzd:
domin@Domin:~$ inxi -Fxzd
System: Host: Domin Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: LENOVO product: 2356GH3 v: ThinkPad T430s serial: N/A
Mobo: LENOVO model: 2356GH3 serial: N/A
UEFI: LENOVO v: G7ET95WW (2.55 ) date: 07/10/2013
Battery BAT0: charge: 23.7 Wh 98.0% condition: 24.2/44.0 Wh (55%)
model: SANYO 45N1037 status: N/A
CPU: Dual core Intel Core i5-3320M (-MT-MCP-)
arch: Ivy Bridge rev.9 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376
clock speeds: max: 3300 MHz 1: 1197 MHz 2: 1201 MHz 3: 1230 MHz
4: 1197 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller
bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 ) driver: intel
Resolution: 1600x900@60.00hz, 1280x1024@60.02hz
OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
version: 4.2 Mesa 18.0.5 Direct Render: Yes
Audio: Card Intel 7 Series/C216 Family High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network: Card-1: Intel 82579LM Gigabit Network Connection
driver: e1000e v: 3.2.6-k port: 5080 bus-ID: 00:19.0
IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
driver: iwlwifi bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Drives: HDD Total Size: 128.0GB (31.3% used)
ID-1: /dev/sda model: TOSHIBA_THNSNF12 size: 128.0GB
Optical-1: /dev/sr0 model: HL-DT-ST DVDRAM GU70N
rev: LT21 dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 24x multisession: yes
audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 89G used: 38G (45%) fs: ext4 dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 40.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 344 Uptime: 21:51 Memory: 1926.8/7795.6MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

lsusb:

domin@Domin:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 04f2:b2da Chicony Electronics Co., Ltd thinkpad t430s camera
Bus 001 Device 008: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]
Bus 001 Device 004: ID 147e:2020 Upek TouchChip Fingerprint Coprocessor (WBF advanced mode)
Bus 001 Device 003: ID 25a7:2410
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


I've downloaded QasMixer, seems like my headphones' mic is working but still I have no sound. I can record only on A2DP because as I said before on HSP/HFP neither I can record (application freezes) and listen to music (it doesn't even start, stuck at 0:00, same everywhere, YouTube etc).

Any suggestions?

User avatar
phd21
Level 16
Level 16
Posts: 6984
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: There is no input sound from microphone

Post by phd21 » Sat Sep 15, 2018 2:48 pm

Hi Domin_PL,

Okay, you are using Linux Mint 19 Mate edition and version (64-bit).

Because you are using a Bluetooth Headset, if you want to use its microphone you must usually use the "HSP/HFP" option not the "a2dp" Bluetooth option in the sound settings. On my ancient Bluetooth headset the "a2dp" has better sound, but no microphone whereas the "HSP/HFP" option I get both sound and mic, but the sound is not as good. I read that newer Bluetooth headsets have great sound using either option now. You may also have to tell the applications in the sound settings or pulse audio volume control to use the Bluetooth and "HSP/HFP".

I do not see anything wrong with the results of the "inxi -Fxzd" console terminal command, so that is a good thing.

I do not know why your system would be crashing when you use the "HSP/HFP" option?

You can try deleting the user hidden pulse audio configuration folder, rebooting, and retrying that? Your system will recreate the pulse audio configuration folder.

Code: Select all

rm -r ~/.config/pulse/

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

Re: There is no input sound from microphone

Post by Domin_PL » Sat Sep 15, 2018 3:00 pm

Unfortunately still no effect, sound recorders still crash while trying to record in HSP mode.

Just tried this solution:
viewtopic.php?t=260636
Still no effect.

User avatar
phd21
Level 16
Level 16
Posts: 6984
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: There is no input sound from microphone

Post by phd21 » Sat Sep 15, 2018 4:06 pm

Hi Domin_PL,

Can you tell us what applications you are trying to use for recording and or for listening to music with? What are you trying to record, video and audio or just audio, and with what application(s)?
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

Re: There is no input sound from microphone

Post by Domin_PL » Sat Sep 15, 2018 4:17 pm

Okay, firstly I tried to record sound using sound recorder from Software Store.
When this started crashing I started using on-line microphone testers such as:
https://webcammictest.com/check-microphone.html
and the other ones. After selecting my headphones as input device and clicking start to record website used to stop responding, just lagged. There is no problem without headphones. Tested both on Opera and Chrome.

To listen to music I used YouTube, Spotify, none of them did work on HFP/HSP mode. On A2DP there was no problem with headphones.

User avatar
trytip
Level 8
Level 8
Posts: 2140
Joined: Tue Jul 05, 2016 1:20 pm

Re: There is no input sound from microphone

Post by trytip » Sat Sep 15, 2018 4:21 pm

does it work with just a regular microphone that plugs into your laptop?
Image

Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

Re: There is no input sound from microphone

Post by Domin_PL » Sat Sep 15, 2018 4:23 pm

I haven't tested with a regular one - I don't have anyone.
I can buy one but I thought it's unecessary because I have built-in with headphones.

User avatar
phd21
Level 16
Level 16
Posts: 6984
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: There is no input sound from microphone

Post by phd21 » Sat Sep 15, 2018 6:22 pm

Hi Domin_PL,

Maybe updating the Linux Kernel might help.

1.) "Audio-Recorder" is the best audio recorder that I know of, SimpleScreenRecord (ssr) is the best desktop recorder for video and audio or either one.

How To Record Streaming Audio in Ubuntu Linux | It's FOSS
https://itsfoss.com/record-streaming-audio/

- To install "Audio-Recorder" using the PPA method, open a console terminal, type in, or copy & paste, each line below one by one: Click "Select All" above command, right-click the highlighted command, select Copy (or Ctrl+Insert), click in the console terminal window, and right click paste (or "Shift+Insert" or "Ctrl+Shift+v"), repeat for each command.

Code: Select all

sudo add-apt-repository ppa:audio-recorder/ppa

Code: Select all

sudo apt-get -y update

Code: Select all

sudo apt-get install --reinstall audio-recorder
- SimpleScreenRecorder is in the Software Manager or Synaptic Package Manager (SPM) of Linux Mint 19, requires a PPA for earlier Linux Mint versions.

SimpleScreenRecorder - Maarten Baert's website
http://www.maartenbaert.be/simplescreenrecorder/


2.) Youtube and Spotify are through your browser unless you have installed a desktop application. Can you play and hear music through a music app on your desktop? I like Audacious music application among others which is in the "Synaptic Package Manager (SPM)".


3.) What Bluetooth manager are you using in Linux Mint Mate 19? You can search the "Synaptic Package Manager (SPM)" for "bluetooth" and tell us what related packages are installed. You can switch Bluetooth managers if need be.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

Re: There is no input sound from microphone

Post by Domin_PL » Thu Sep 20, 2018 12:02 pm

I'd like to say thank you guys for all tries in helping - after all experimenting with Linux kernels, configurations etc I decided to buy an analog microphone and now it works perfect (with noise in the background, but I will solve it I hope). So, to sum up, I don't know what is/was the problem that other devices don't work on Linux but work on Windows, maybe just lack of compatibility or something.

User avatar
phd21
Level 16
Level 16
Posts: 6984
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: There is no input sound from microphone

Post by phd21 » Thu Sep 20, 2018 12:24 pm

Hi Domin_PL,

You are welcome from all of us that replied...

I am glad you found something that is working for you. It may just be your particular Bluetooth headset and its microphone and or the Bluetooth transceiver adapter that is a problem because other Bluetooth headsets do work, so you might try another one. USB Bluetooth adapters v4.x + are low-cost. Amazon.com and maybe even local business supply stores or other local stores which have good return policies that would allow you try other Bluetooth headsets and or USB bluetooth adapters.

Most Bluetooth headsets do not have very long battery life, so it is a good idea to have another option like a corded headset with microphone or a stand-alone microphone.
Last edited by phd21 on Fri Sep 21, 2018 10:48 am, edited 1 time in total.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

JeremyB
Level 19
Level 19
Posts: 9166
Joined: Fri Feb 21, 2014 8:17 am

Re: There is no input sound from microphone

Post by JeremyB » Thu Sep 20, 2018 4:57 pm

Ok a Broadcom bluetooth, see https://askubuntu.com/a/632348/300665 follow the instructions but search the windows inf file for 21e6 rather than 21d7 that is shown in the answer

Domin_PL
Level 1
Level 1
Posts: 8
Joined: Fri Sep 14, 2018 3:53 pm

Re: There is no input sound from microphone

Post by Domin_PL » Fri Sep 21, 2018 7:29 am

@JeremyB thank you, this helped me. Now headphones can work in HSP/HFP mode!

Thank you all guys for the help.

User avatar
trytip
Level 8
Level 8
Posts: 2140
Joined: Tue Jul 05, 2016 1:20 pm

Re: [SOLVED]There is no input sound from microphone

Post by trytip » Fri Sep 21, 2018 9:55 am

get rid of echo and some noise cancellation
sudo gedit /etc/pulse/default.pa or xed which ever text editor you use and paste this at the bottom of the file: save and reboot.

Code: Select all

load-module module-echo-cancel source_name=noechosource sink_name=noechosink
set-default-source noechosource
set-default-sink noechosink
you will have a new sink named noechosink which you can list with

Code: Select all

pacmd list-sinks | sed -n "/^.*name:/s/.*<\(.*\)>.*/\1/p"
Image

Post Reply

Return to “Sound, Multimedia, & Codecs”