No system (events) sounds in Linux Mint XFCE 18 and 19

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Tomsat50
Level 1
Level 1
Posts: 8
Joined: Mon Apr 15, 2013 7:29 am

No system (events) sounds in Linux Mint XFCE 18 and 19

Post by Tomsat50 » Mon Oct 15, 2018 7:58 am

I have just installed LM 18.3 Xfce on my old Acer Aspire 5310 laptop which has become unuseable with Windows 10: all major (forced) updates result in crashes.
All works fine now with Linux Mint, the laptop is MUCH quicker, and has started with it's second life... :D :D
The only issue is that I cannot activate the system sounds (startup sound, annuciations, etc)! :( :(
I can play audio files and audio streams without any problem, using the internal speakers as well as on the headphones.
I have read several threads regarding this issue, and could not find any solution.
So I hope that someone can help me out.
UPDATE: I have installed a newer version (Tara) which does not fix it, unfortunately..... :(

a60man
Level 1
Level 1
Posts: 25
Joined: Mon Oct 15, 2018 5:43 am

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by a60man » Mon Oct 15, 2018 8:48 am

I recently installed 64 Bit Mint Cinnamon and Mate on two hard drives, one of them gave the startup sound, not sure which, but subsequent boots, no startup sound. Sound working well otherwise.

User avatar
MrEen
Level 8
Level 8
Posts: 2011
Joined: Mon Jun 12, 2017 8:39 pm

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by MrEen » Mon Oct 15, 2018 5:03 pm

Hi Tomsat50.

For starters, are the 2 Event sounds boxes checked in Menu > Settings > Appearance > Settings tab?

This topic may help as well.

Tomsat50
Level 1
Level 1
Posts: 8
Joined: Mon Apr 15, 2013 7:29 am

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by Tomsat50 » Tue Oct 16, 2018 8:15 am

Hi MisterEen,

Thanks for your reply.
I try to create the SoundThemeName setting, but I do not know how to create it.
After pressing "New" a popup appears named "New Property", see screenshot.
Can you tell me what I should enter??
Schermafdruk_2018-10-16_14-13-21.png
Schermafdruk_2018-10-16_14-13-21.png (9.32 KiB) Viewed 326 times

User avatar
MrEen
Level 8
Level 8
Posts: 2011
Joined: Mon Jun 12, 2017 8:39 pm

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by MrEen » Tue Oct 16, 2018 8:38 pm

For Property:

Code: Select all

/Net/SoundThemeName
For Type:

Code: Select all

String
Then a new choice, Value, will open where you enter a folder name that exists in /usr/share/sounds such as

Code: Select all

freedesktop
or

Code: Select all

LinuxMint

Tomsat50
Level 1
Level 1
Posts: 8
Joined: Mon Apr 15, 2013 7:29 am

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by Tomsat50 » Wed Oct 17, 2018 6:00 am

Thanks, I have created the SoundThemeName in the NET xsettings.
In addition I have modified the index.theme in the /usr/shared/sounds/freedesktop folder: Name=freedesktop instead of Name=Default.
I have also verified that both event soundboxes are checked in Menu>Settings>Appearance>Settings.
I have also created the 2 missing files in /etc/X11/Xsession.d (libcanberra etc.)
Still, no sounds after a reboot.....

User avatar
MrEen
Level 8
Level 8
Posts: 2011
Joined: Mon Jun 12, 2017 8:39 pm

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by MrEen » Wed Oct 17, 2018 6:45 pm

What's the output of running sudo fuser -v /dev/snd/* in the terminal?

Tomsat50
Level 1
Level 1
Posts: 8
Joined: Mon Apr 15, 2013 7:29 am

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by Tomsat50 » Thu Oct 18, 2018 5:58 am

This is what I see:
Schermafdruk van 2018-10-18 11-54-53.png

User avatar
MrEen
Level 8
Level 8
Posts: 2011
Joined: Mon Jun 12, 2017 8:39 pm

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by MrEen » Thu Oct 18, 2018 7:08 am

Okay, it's normal.

Maybe try a different sound theme in case there is some problem with your copy of freedesktop. That other thread I linked to has links to a couple of others that I preferred over the default anyway.

Tomsat50
Level 1
Level 1
Posts: 8
Joined: Mon Apr 15, 2013 7:29 am

Re: No system (events) sounds in Linux Mint XFCE 18 and 19

Post by Tomsat50 » Fri Oct 19, 2018 1:16 pm

Thanks, I will try it out.
In the mean time I have the freedesktop sound theme replaced with LinuxMint, and I have some 'popping' sounds when opening windows....
So I am making some progresss.... I will try to install the Borealis sound theme, see what's happening.
UPDATE: I have the start-up sound with some work-around: http://pclosmag.com/html/Issues/201305/page09.html
I only had to install sox to make it working.
Learning every day... :D

Post Reply

Return to “Sound, Multimedia, & Codecs”