Creative Sound Blaster 5.1 VX Microphones aren't working

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
terrestrian
Level 1
Level 1
Posts: 8
Joined: Wed Oct 24, 2018 10:27 am

Creative Sound Blaster 5.1 VX Microphones aren't working

Post by terrestrian » Wed Oct 24, 2018 10:53 am

As topic indicates, I have SB 5.1 VX Sound Card. For some reason my microphones aren't working. I have 3 different mics and they all work when I plugged them to the motherboards jaks but they don't work with my sound card. I am pretty sure my mics have nothing wrong with them. By the way, before I switched to Linux I was using Windows 7 and my mics were working perfect with my sound card.

And here is my system info:
OS: Linux Mint 19 Tara x86_64
Kernel: 4.15.0-38-generic
Shell: bash 4.4.19
DE: Cinnamon 3.8.9
CPU: Intel Core 2 Quad Q8400 (4) @ 2.664
GPU: AMD Radeon HD 4850

User avatar
MrEen
Level 7
Level 7
Posts: 1961
Joined: Mon Jun 12, 2017 8:39 pm

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by MrEen » Wed Oct 24, 2018 3:17 pm

Hi terrestrian, and welcome to the forum.

Just a guess at this point, but use either alsamixer or pavucontrol (pavucontrol is not installed by default) and check that the mics are not muted. Also, if they have stereo settings try dropping one side (I think it's the right) all the way to 0.

If no success, paste back the output of running arecord -l and inxi -Fxz in the terminal please.

P.S. In alsamixer the q key and the e key increase volumes, the z key and c key decrease volumes for individual sides as opposed to using the up and down arrows to move both sides at once. Also, the m key toggles mute (you'll see MM at the bottom if it's muted.)

Good luck.

User avatar
phd21
Level 17
Level 17
Posts: 7465
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by phd21 » Wed Oct 24, 2018 3:47 pm

Hi terrestrian,

Welcome to the wonderful world of Linux Mint and its excellent forum!

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

FYI: Install "pulse audio volume control" from the "Synaptic Package Manager (SPM)". There are some really nice graphical (GUI) programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager (SPM) that you can install and use. Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" and make it fullscreen, on the right side you will have mixer devices where you can control your system sound and at the bottom right is a button for Microphone, make sure it is enabled and that all mic and capture sliders are enabled (solid dot) and at least half-way up. If you do not see the mixer devices, hit "F6". The mixer item "sysdefault" will show all installed sound card devices, and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. There are also various other check boxes below that you can use, and depending upon your sound card(s) that sometimes includes headphone checkboxes and or sliders as well, like "Headphone Jack Sense".

QasTools: Applications
http://xwmw.org/qastools/applications.html

The applications included are:
- qasconfig - browser for the alsa configuration tree
- qashctl - mixer for alsa's high level control interface
- qasmixer - desktop mixer with features similar to alsamixer

Qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a system tray icon with basic mixer functionality.

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

terrestrian
Level 1
Level 1
Posts: 8
Joined: Wed Oct 24, 2018 10:27 am

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by terrestrian » Wed Oct 24, 2018 4:28 pm

MrEen wrote:
Wed Oct 24, 2018 3:17 pm
Hi terrestrian, and welcome to the forum.

Just a guess at this point, but use either alsamixer or pavucontrol (pavucontrol is not installed by default) and check that the mics are not muted. Also, if they have stereo settings try dropping one side (I think it's the right) all the way to 0.

If no success, paste back the output of running arecord -l and inxi -Fxz in the terminal please.

P.S. In alsamixer the q key and the e key increase volumes, the z key and c key decrease volumes for individual sides as opposed to using the up and down arrows to move both sides at once. Also, the m key toggles mute (you'll see MM at the bottom if it's muted.)

Good luck.
Thanks for your answer. I am not used to terminal but I opened alsamixer and looked around. I think it is not muted. Here is the outputs of what you asked.
~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: VT1708S Analog [VT1708S Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 0: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 1: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 2: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: CA0106 [CA0106], device 3: ca0106 [CA0106]
Subdevices: 1/1
Subdevice #0: subdevice #0

~$ inxi -Fxz
System: Host: CEARTH Kernel: 4.15.0-38-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine: Device: desktop Mobo: ASUSTeK model: P5KPL-AM EPU v: x.0x serial: N/A
BIOS: American Megatrends v: 0501 date: 08/20/2010
CPU: Quad core Intel Core2 Quad Q8400 (-MCP-) arch: Penryn rev.10 cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 21332
clock speeds: max: 2664 MHz 1: 1999 MHz 2: 1999 MHz 3: 1999 MHz 4: 2032 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RV770 [Radeon HD 4850] bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 ) drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
Resolution: 1280x1024@60.02hz
OpenGL: renderer: AMD RV770 (DRM 2.50.0 / 4.15.0-38-generic, LLVM 7.0.0)
version: 3.3 Mesa 18.2.3 - padoka PPA Direct Render: Yes
Audio: Card-1 Creative Labs CA0106/CA0111 [SB Live!/Audigy/X-Fi Series]
driver: snd_ca0106 port: ec00 bus-ID: 04:01.0
Card-2 Advanced Micro Devices [AMD/ATI] RV770 HDMI Audio [Radeon HD 4850/4870]
driver: snd_hda_intel bus-ID: 01:00.1
Card-3 Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network: Card: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
driver: ATL1E port: dc00 bus-ID: 02:00.0
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 378.1GB (7.1% used)
ID-1: /dev/sda model: SAMSUNG_HD250HJ size: 250.1GB
ID-2: /dev/sdb model: Corsair_Force_LE size: 120.0GB
ID-3: USB /dev/sdc model: TransMemory size: 8.0GB
Partition: ID-1: / size: 110G used: 20G (19%) fs: ext4 dev: /dev/sdb1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 36.0C mobo: 33.0C gpu: 53.5
Fan Speeds (in rpm): cpu: 1004 psu: 0 sys-1: 1584
Info: Processes: 204 Uptime: 7:14 Memory: 2466.9/3944.7MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56
Attachments
pic2.png
Last edited by terrestrian on Wed Oct 24, 2018 5:25 pm, edited 1 time in total.

terrestrian
Level 1
Level 1
Posts: 8
Joined: Wed Oct 24, 2018 10:27 am

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by terrestrian » Wed Oct 24, 2018 5:05 pm

phd21 wrote:
Wed Oct 24, 2018 3:47 pm
Hi terrestrian,

Welcome to the wonderful world of Linux Mint and its excellent forum!

I just read your post and the good replies to it. Here are my thoughts on this as well.

It would help to know more about your system setup. If you run "inxi -Fxzd" and "lsusb" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

FYI: Install "pulse audio volume control" from the "Synaptic Package Manager (SPM)". There are some really nice graphical (GUI) programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager (SPM) that you can install and use. Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" and make it fullscreen, on the right side you will have mixer devices where you can control your system sound and at the bottom right is a button for Microphone, make sure it is enabled and that all mic and capture sliders are enabled (solid dot) and at least half-way up. If you do not see the mixer devices, hit "F6". The mixer item "sysdefault" will show all installed sound card devices, and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. There are also various other check boxes below that you can use, and depending upon your sound card(s) that sometimes includes headphone checkboxes and or sliders as well, like "Headphone Jack Sense".

QasTools: Applications
http://xwmw.org/qastools/applications.html

The applications included are:
- qasconfig - browser for the alsa configuration tree
- qashctl - mixer for alsa's high level control interface
- qasmixer - desktop mixer with features similar to alsamixer

Qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a system tray icon with basic mixer functionality.

Hope this helps ...
I installed QasMixer and got to this page.

And here the output you asked:
~$ lsusb
Bus 001 Device 002: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102/2.0 / HEMA Flash Drive 2 GB / PNY Attache 4GB Stick
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Edit: Couldn't upload pic so I attached.
Attachments
pulse.png

User avatar
phd21
Level 17
Level 17
Posts: 7465
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by phd21 » Wed Oct 24, 2018 5:17 pm

Hi terrestrian,

Please provide screenshot(s) of QasMixer on the "sysdefault" mixer option.

And, the one capture feedback slider is at its lowest setting, move to middle (half-way). It looks like your microphone is enabled and should be working, is it? How many microphones do you have? Have you told your system in the Sound Settings or Pulse Audio volume control to use the microphone (input tab)?
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

terrestrian
Level 1
Level 1
Posts: 8
Joined: Wed Oct 24, 2018 10:27 am

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by terrestrian » Wed Oct 24, 2018 5:33 pm

phd21 wrote:
Wed Oct 24, 2018 5:17 pm
Hi terrestrian,

Please provide screenshot(s) of QasMixer on the "sysdefault" mixer option.

And, the one capture feedback slider is at its lowest setting, move to middle (half-way). It looks like your microphone is enabled and should be working, is it? How many microphones do you have? Have you told your system in the Sound Settings or Pulse Audio volume control to use the microphone (input tab)?
I slided that half-way up. Nothing changed. Right know, I have 2 mics plugged to my pc. One is plugged to my sound card and the other plugged to my motherboard. And here is the screenshots of sysdefault mixer option. I dont know about what you said last. :(
Attachments
pic3.png

User avatar
phd21
Level 17
Level 17
Posts: 7465
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by phd21 » Wed Oct 24, 2018 5:52 pm

Hi terrestrian,

Okay, that's a better screenshot of qasmixer.

Did you check the iec958 in qasmixer or was that already checked? You can try with this setting enabled or disabled, if disabled and the options change, please provide another screenshot.

You have also checked options for using the "rear" microphone. You can try either the front and the rear options. I do not know if you can have both enabled at the same time.

On my Dell Optiplex 780, the rear combination jack for Line-in/mic has never worked for me, only the front mic jack works for me.

Please provide screenshots of Pulse Audio Volume Control's Configuration tab, Input tab, Output devices tab, resize the window if necessary to show all options.

I noticed you also have HDMI capabilities do you have anything connected with HDMI?

If the microphones have their own volume control check to make sure they are not too low.

Hope this helps ...
.
pulse_audio_volume_control.jpg
Pulse Audio Volume Control
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

terrestrian
Level 1
Level 1
Posts: 8
Joined: Wed Oct 24, 2018 10:27 am

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by terrestrian » Thu Oct 25, 2018 3:37 am

phd21 wrote:
Wed Oct 24, 2018 5:52 pm
Hi terrestrian,

Okay, that's a better screenshot of qasmixer.

Did you check the iec958 in qasmixer or was that already checked? You can try with this setting enabled or disabled, if disabled and the options change, please provide another screenshot.

You have also checked options for using the "rear" microphone. You can try either the front and the rear options. I do not know if you can have both enabled at the same time.

On my Dell Optiplex 780, the rear combination jack for Line-in/mic has never worked for me, only the front mic jack works for me.

Please provide screenshots of Pulse Audio Volume Control's Configuration tab, Input tab, Output devices tab, resize the window if necessary to show all options.

I noticed you also have HDMI capabilities do you have anything connected with HDMI?

If the microphones have their own volume control check to make sure they are not too low.

Hope this helps ...
.
pulse_audio_volume_control.jpg
Firstly, I removed other mics to my pc in order to remove misunderstandings. I checked iec958 in qasmixer, tried with different options but nothing changed. I only noticed that when I enabled iec958 with i2s in option, the volume bar in the Linux Mint's Sound Settings page had a little red on it. I also provided screenshot for that. I haven't anything connected with HDMI.
Attachments
inputdevices.png
configuration.png
alsamixer.png
Look at this. I can not volume up and down "Analog Source Mic" or mute or unmute.
Last edited by terrestrian on Thu Oct 25, 2018 3:54 am, edited 2 times in total.

terrestrian
Level 1
Level 1
Posts: 8
Joined: Wed Oct 24, 2018 10:27 am

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by terrestrian » Thu Oct 25, 2018 3:44 am

I couldn't upload 2 other pic in same post. Sorry for inconvenient. Here is the other 2.
Attachments
myoutputc.png
sound.png

User avatar
phd21
Level 17
Level 17
Posts: 7465
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by phd21 » Thu Oct 25, 2018 12:09 pm

Hi terrestrian,

I would uncheck iec958 option.

Make sure the volume control is not muted. Are you able to listen to music and or videos normally? You should be able to hear yourself talking into the mic through your speakers or headset. Are you trying to use analog and digital s/pdif audio connections? Are the mics analog or digital, mono or stereo, and have you ever used them before with this computer using any operating system successfully? If mono, do not use stereo settings for mic.

Also, smart to remove other mics and use only one until you get the mic situation resolved. Some computers automatically turn off other audio jacks when something else is plugged into a jack. For instance, if I have my headset plugged into my front audio jacks (mic and headset speaker jacks), my system automatically disables the speaker (line-out) jack in the back. Yet, my system has no problem with my USB webcam mic and my onboard system mic connected at the same time.

FYI: Re: Screenshots and this forum. Everyone is limited to directly attaching or uploading anything to the posts and or replies to something less 200kb which is much smaller than a typical screenshot and you can only add 3 attachments per post or reply. So, you either have to take a portion of the screen, crop the image, and or resize (rescale, shrink) and or use a compressed image format like ".jpg" or ".jpeg" versus ".png", or use an image hosting website like "imgur.com" or "postimages.org" get and copy a shared direct link url address to that image and post that into your posts and or replies using the "rimg" button in the toolbar. If you do not want to do any image editing, or want to post more than 3 images into one post/reply, then use remote images from an image hosting website.

I use an excellent screenshot application called "Ksnip", which can also open existing images, because I can crop and or resize (scale) an image, and use various painter annotation functions, or upload directly to my "imgur" image hosting account, save into another image format, all within one application.

Uploading a screenshot, image, or images to this forum - Linux Mint Forums
viewtopic.php?f=42&t=232332&hilit=screenshot+forum


Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

terrestrian
Level 1
Level 1
Posts: 8
Joined: Wed Oct 24, 2018 10:27 am

Re: Creative Sound Blaster 5.1 VX Microphones aren't working

Post by terrestrian » Thu Oct 25, 2018 5:00 pm

phd21 wrote:
Thu Oct 25, 2018 12:09 pm
Hi terrestrian,

I would uncheck iec958 option.

Make sure the volume control is not muted. Are you able to listen to music and or videos normally? You should be able to hear yourself talking into the mic through your speakers or headset. Are you trying to use analog and digital s/pdif audio connections? Are the mics analog or digital, mono or stereo, and have you ever used them before with this computer using any operating system successfully? If mono, do not use stereo settings for mic.

Also, smart to remove other mics and use only one until you get the mic situation resolved. Some computers automatically turn off other audio jacks when something else is plugged into a jack. For instance, if I have my headset plugged into my front audio jacks (mic and headset speaker jacks), my system automatically disables the speaker (line-out) jack in the back. Yet, my system has no problem with my USB webcam mic and my onboard system mic connected at the same time.

FYI: Re: Screenshots and this forum. Everyone is limited to directly attaching or uploading anything to the posts and or replies to something less 200kb which is much smaller than a typical screenshot and you can only add 3 attachments per post or reply. So, you either have to take a portion of the screen, crop the image, and or resize (rescale, shrink) and or use a compressed image format like ".jpg" or ".jpeg" versus ".png", or use an image hosting website like "imgur.com" or "postimages.org" get and copy a shared direct link url address to that image and post that into your posts and or replies using the "rimg" button in the toolbar. If you do not want to do any image editing, or want to post more than 3 images into one post/reply, then use remote images from an image hosting website.

I use an excellent screenshot application called "Ksnip", which can also open existing images, because I can crop and or resize (scale) an image, and use various painter annotation functions, or upload directly to my "imgur" image hosting account, save into another image format, all within one application.

Uploading a screenshot, image, or images to this forum - Linux Mint Forums
viewtopic.php?f=42&t=232332&hilit=screenshot+forum


Hope this helps ...
I unchecked iec958 option.

I am able to listen to music and watch videos normally.

I am not hearing myself.

I am trying to use analog connection.

My mics are stereo.

I was able to use them perfectly on Windows 7.

I think there is nothing to do about it. I gave up. Thanks for your time and thanks for your help anyway.

Post Reply

Return to “Sound, Multimedia, & Codecs”