Pulseaudio does not work

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Yanderella
Level 1
Level 1
Posts: 4
Joined: Sat Oct 27, 2018 7:57 am

Pulseaudio does not work

Post by Yanderella » Sat Oct 27, 2018 8:16 am

I tried all the solutions I found, but not even one worked! I am currently running 64bit Linux mint 19 xfce, I have to precise That I am a new on linux....
My computer is a Z83 made by intel (I guess), and this pc works perfectly, excluding the audio.

Code: Select all

$ pulseaudio
E: [pulseaudio] module.c: Failed to load module "module-alsa-source" (argument: "device=hw:1,0"): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

Code: Select all

$ pulseaudio --start
E: [pulseaudio] main.c: Daemon startup failed.

Code: Select all

$ pulseaudio -v
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 11.1
I: [pulseaudio] main.c: Page size is 4096 bytes
I: [pulseaudio] main.c: Machine ID is 0be4b885ddb347e5bc70559303dca99f.
I: [pulseaudio] main.c: Session ID is c2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/yanderella/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-11.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
I: [pulseaudio] main.c: System supports high resolution timers
I: [pulseaudio] cpu-x86.c: CPU flags: CMOV MMX SSE SSE2 SSE3 SSSE3 SSE4_1 SSE4_2 
I: [pulseaudio] svolume_mmx.c: Initialising MMX optimized volume functions.
I: [pulseaudio] remap_mmx.c: Initialising MMX optimized remappers.
I: [pulseaudio] svolume_sse.c: Initialising SSE2 optimized volume functions.
I: [pulseaudio] remap_sse.c: Initialising SSE2 optimized remappers.
I: [pulseaudio] sconv_sse.c: Initialising SSE2 optimized conversions.
I: [pulseaudio] svolume_orc.c: Initialising ORC optimized volume functions.
I: [pulseaudio] module-device-restore.c: Successfully opened database file '/home/yanderella/.config/pulse/0be4b885ddb347e5bc70559303dca99f-device-volumes'.
I: [pulseaudio] module.c: Loaded "module-device-restore" (index: #0; argument: "").
I: [pulseaudio] module-stream-restore.c: Successfully opened database file '/home/yanderella/.config/pulse/0be4b885ddb347e5bc70559303dca99f-stream-volumes'.
I: [pulseaudio] module.c: Loaded "module-stream-restore" (index: #1; argument: "").
I: [pulseaudio] module-card-restore.c: Successfully opened database file '/home/yanderella/.config/pulse/0be4b885ddb347e5bc70559303dca99f-card-database'.
I: [pulseaudio] module.c: Loaded "module-card-restore" (index: #2; argument: "").
I: [pulseaudio] module.c: Loaded "module-augment-properties" (index: #3; argument: "").
I: [pulseaudio] module.c: Loaded "module-switch-on-port-available" (index: #4; argument: "").
I: [pulseaudio] module.c: Loaded "module-switch-on-connect" (index: #5; argument: "").
I: [pulseaudio] alsa-util.c: Trying to disable ALSA period wakeups, using timers only
I: [pulseaudio] alsa-util.c: snd_pcm_hw_params_set_buffer_size_near() failed: Invalid argument
I: [pulseaudio] alsa-util.c: ALSA period wakeups disabled
I: [pulseaudio] alsa-sink.c: Successfully opened device default.
I: [pulseaudio] alsa-sink.c: Successfully enabled mmap() mode.
I: [pulseaudio] alsa-sink.c: Successfully enabled timer-based scheduling mode.
I: [pulseaudio] sink.c: Created sink 0 "alsa_output.default" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: [pulseaudio] sink.c:     alsa.resolution_bits = "16"
I: [pulseaudio] sink.c:     device.api = "alsa"
I: [pulseaudio] sink.c:     device.class = "sound"
I: [pulseaudio] sink.c:     alsa.class = "generic"
I: [pulseaudio] sink.c:     alsa.subclass = "generic-mix"
I: [pulseaudio] sink.c:     alsa.name = "Intel HDMI/DP LPE Audio"
I: [pulseaudio] sink.c:     alsa.id = "HdmiLpeAudio"
I: [pulseaudio] sink.c:     alsa.subdevice = "0"
I: [pulseaudio] sink.c:     alsa.subdevice_name = "subdevice #0"
I: [pulseaudio] sink.c:     alsa.device = "0"
I: [pulseaudio] sink.c:     alsa.card = "0"
I: [pulseaudio] sink.c:     alsa.card_name = "Intel HDMI/DP LPE Audio"
I: [pulseaudio] sink.c:     alsa.long_card_name = "Intel HDMI/DP LPE Audio"
I: [pulseaudio] sink.c:     alsa.driver_name = "snd_hdmi_lpe_audio"
I: [pulseaudio] sink.c:     device.bus_path = "pci-0000:00:02.0-platform-hdmi-lpe-audio"
I: [pulseaudio] sink.c:     sysfs.path = "/devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0"
I: [pulseaudio] sink.c:     device.bus = "pci"
I: [pulseaudio] sink.c:     device.vendor.id = "8086"
I: [pulseaudio] sink.c:     device.vendor.name = "Intel Corporation"
I: [pulseaudio] sink.c:     device.product.id = "22b0"
I: [pulseaudio] sink.c:     device.product.name = "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers"
I: [pulseaudio] sink.c:     device.string = "default"
I: [pulseaudio] sink.c:     device.buffering.buffer_size = "352832"
I: [pulseaudio] sink.c:     device.buffering.fragment_size = "352832"
I: [pulseaudio] sink.c:     device.access_mode = "mmap+timer"
I: [pulseaudio] sink.c:     device.description = "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers"
I: [pulseaudio] sink.c:     device.icon_name = "audio-card-pci"
I: [pulseaudio] source.c: Created source 0 "alsa_output.default.monitor" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: [pulseaudio] source.c:     device.description = "Monitor of Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers"
I: [pulseaudio] source.c:     device.class = "monitor"
I: [pulseaudio] source.c:     device.icon_name = "audio-input-microphone"
I: [pulseaudio] alsa-sink.c: Using 1,0 fragments of size 352832 bytes (2000,18ms), buffer size is 352832 bytes (2000,18ms)
I: [pulseaudio] alsa-sink.c: Time scheduling watermark is 20,00ms
I: [alsa-sink-HdmiLpeAudio] core-util.c: Successfully enabled SCHED_RR scheduling for thread, with priority 5.
I: [alsa-sink-HdmiLpeAudio] alsa-sink.c: Starting playback.
I: [alsa-sink-HdmiLpeAudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_HWSYNC failed (-32)
I: [pulseaudio] core.c: default_source: (unset) -> alsa_output.default.monitor
I: [pulseaudio] core.c: default_sink: (unset) -> alsa_output.default
I: [pulseaudio] module.c: Loaded "module-alsa-sink" (index: #6; argument: "").
I: [alsa-sink-HdmiLpeAudio] alsa-sink.c: Starting playback.
I: [alsa-sink-HdmiLpeAudio] alsa-sink.c: Starting playback.
I: [pulseaudio] alsa-util.c: Cannot disable ALSA period wakeups
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] alsa-util.c: snd_pcm_hw_params failed: Invalid argument
I: [pulseaudio] alsa-util.c: Cannot disable ALSA period wakeups
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] (alsa-lib)pcm_hw.c: SNDRV_PCM_IOCTL_PREPARE failed (-22)
I: [pulseaudio] alsa-util.c: snd_pcm_hw_params failed: Invalid argument
I: [pulseaudio] (alsa-lib)conf.c: Unknown parameter 1
I: [pulseaudio] (alsa-lib)conf.c: Parse arguments error: No such file or directory
I: [pulseaudio] (alsa-lib)pcm.c: Unknown PCM plug:hw:1,0
I: [pulseaudio] alsa-util.c: Error opening PCM device plug:hw:1,0: No such file or directory
E: [pulseaudio] module.c: Failed to load module "module-alsa-source" (argument: "device=hw:1,0"): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.
I: [pulseaudio] module.c: Unloading "module-alsa-sink" (index: #6).
I: [pulseaudio] core.c: default_sink: alsa_output.default -> (unset)
I: [alsa-sink-HdmiLpeAudio] alsa-sink.c: Starting playback.
I: [pulseaudio] core.c: default_source: alsa_output.default.monitor -> (unset)
I: [pulseaudio] sink.c: Freeing sink 0 "alsa_output.default"
I: [pulseaudio] source.c: Freeing source 0 "alsa_output.default.monitor"
I: [pulseaudio] module.c: Unloaded "module-alsa-sink" (index: #6).
I: [pulseaudio] module.c: Unloading "module-switch-on-connect" (index: #5).
I: [pulseaudio] module.c: Unloaded "module-switch-on-connect" (index: #5).
I: [pulseaudio] module.c: Unloading "module-switch-on-port-available" (index: #4).
I: [pulseaudio] module.c: Unloaded "module-switch-on-port-available" (index: #4).
I: [pulseaudio] module.c: Unloading "module-augment-properties" (index: #3).
I: [pulseaudio] module.c: Unloaded "module-augment-properties" (index: #3).
I: [pulseaudio] module.c: Unloading "module-card-restore" (index: #2).
I: [pulseaudio] module.c: Unloaded "module-card-restore" (index: #2).
I: [pulseaudio] module.c: Unloading "module-stream-restore" (index: #1).
I: [pulseaudio] module.c: Unloaded "module-stream-restore" (index: #1).
I: [pulseaudio] module.c: Unloading "module-device-restore" (index: #0).
I: [pulseaudio] module.c: Unloaded "module-device-restore" (index: #0).
I: [pulseaudio] main.c: Daemon terminated.

Code: Select all

$ pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such process

Code: Select all

$ sudo pulseaudio -v
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 11.1
I: [pulseaudio] main.c: Page size is 4096 bytes
I: [pulseaudio] main.c: Machine ID is 0be4b885ddb347e5bc70559303dca99f.
E: [pulseaudio] core-util.c: Home directory not accessible: Permission denied

Code: Select all

$ start-pulseaudio-x11
Connection failure: Connection refused
pa_context_connect() failed: Connection refused

Code: Select all

$ inxi
CPU~Quad core Intel Atom x5-Z8350 (-MCP-) speed/max~963/1920 MHz Kernel~4.15.0-20-generic x86_64 Up~1:05 Mem~1203.4/1923.1MB HDD~NA(-) Procs~218 Client~Shell inxi~2.3.56  
When I try to open the audio mixer I get this message:

Code: Select all

Connection to Pulseaudio failed. Automatic retry in 5s

In this case is likely because PULSE_SERVER in the Environment/X11 Root Window Properties or default-server in client.conf is misconfigured. The situation can also arise when PulseAudio crashed and left stale details in the X11 Root Window. if this case, then PulseAudio should autospawn again, or if this is not configured you should run start-pulseaudio-x11 manually.

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Pulseaudio does not work

Post by MrEen » Sat Oct 27, 2018 10:03 am

Hi Yanderella, and welcome to the forum.

The first thing to try is to delete all the files in ~/.config/pulse then in the terminal run pulseaudio --start then test your sound.

If that doesn't work, paste back the results of inxi -Fxz as well as aplay -l please.

Good luck.

User avatar
Yanderella
Level 1
Level 1
Posts: 4
Joined: Sat Oct 27, 2018 7:57 am

Re: Pulseaudio does not work

Post by Yanderella » Sun Oct 28, 2018 5:25 am

MrEen wrote:
Sat Oct 27, 2018 10:03 am
Hi Yanderella, and welcome to the forum.

The first thing to try is to delete all the files in ~/.config/pulse then in the terminal run pulseaudio --start then test your sound.

If that doesn't work, paste back the results of inxi -Fxz as well as aplay -l please.

Good luck.
I still get:

Code: Select all

E: [pulseaudio] main.c: Daemon startup failed.
infos:

Code: Select all

$ inxi -Fxz
System:    Host: yanderella-pc Kernel: 4.15.0-20-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: AZW product: Z83-V serial: N/A
           Mobo: AMI model: Cherry Trail CR serial: N/A
           UEFI: American Megatrends v: YB1007 date: 07/07/2017
CPU:       Quad core Intel Atom x5-Z8350 (-MCP-) 
           arch: Airmont rev.4 cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11520
           clock speeds: max: 1920 MHz 1: 762 MHz 2: 1112 MHz 3: 932 MHz
           4: 780 MHz
Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1200@59.95hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics (Cherrytrail)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Intel HDMI/DP LPE Audio driver: HdmiLpeAudio
           Card-2 bytcr-rt5651 driver: bytcr-rt5651
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/mmcblk0 model: N/A size: 31.0GB
           ID-2: /dev/mmcblk2 model: N/A size: 125.7GB
Partition: ID-1: / size: 28G used: 13G (47%) fs: ext4 dev: /dev/mmcblk0p2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 64.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 216 Uptime: 2:38 Memory: 1284.9/1923.1MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Code: Select all

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: bytcrrt5651 [bytcr-rt5651], device 0: Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: bytcrrt5651 [bytcr-rt5651], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

User avatar
thx-1138
Level 6
Level 6
Posts: 1290
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Pulseaudio does not work

Post by thx-1138 » Sun Oct 28, 2018 11:00 am

Yanderella wrote:
Sun Oct 28, 2018 5:25 am
....................................
...try the following commands:

Code: Select all

git clone https://github.com/plbossart/UCM.git
sudo cp -rf ~/UCM/bytcr-rt5651 /usr/share/alsa/ucm
sudo cp ~/UCM/bytcr-rt5651/asound.state /var/lib/alsa
echo "blacklist snd_hdmi_lpe_audio" | sudo tee /etc/modprobe.d/blacklist_snd_hdmi_lpe_audio.conf

User avatar
Yanderella
Level 1
Level 1
Posts: 4
Joined: Sat Oct 27, 2018 7:57 am

Re: Pulseaudio does not work

Post by Yanderella » Sat Nov 03, 2018 7:48 am

thx-1138 wrote:
Sun Oct 28, 2018 11:00 am
Yanderella wrote:
Sun Oct 28, 2018 5:25 am
....................................
...try the following commands:

Code: Select all

git clone https://github.com/plbossart/UCM.git
sudo cp -rf ~/UCM/bytcr-rt5651 /usr/share/alsa/ucm
sudo cp ~/UCM/bytcr-rt5651/asound.state /var/lib/alsa
echo "blacklist snd_hdmi_lpe_audio" | sudo tee /etc/modprobe.d/blacklist_snd_hdmi_lpe_audio.conf
I tried that and from the last command I got this:

Code: Select all

$ echo "blacklist snd_hdmi_lpe_audio" | sudo tee /etc/modprobe.d/blacklist_snd_hdmi_lpe_audio.conf
blacklist snd_hdmi_lpe_audio

User avatar
thx-1138
Level 6
Level 6
Posts: 1290
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Pulseaudio does not work

Post by thx-1138 » Sat Nov 03, 2018 12:38 pm

...if the above commands don't do the trick after rebooting, then i'm afraid i'm out of ideas personally.
See here & here as well...

User avatar
Yanderella
Level 1
Level 1
Posts: 4
Joined: Sat Oct 27, 2018 7:57 am

Re: Pulseaudio does not work

Post by Yanderella » Sat Nov 17, 2018 4:18 am

Ok I made it work, the way to do that was Installing the driver from the git, then running

Code: Select all

sudo -i
and then

Code: Select all

pulseaudio --start
!
Thanks for helping^^
only problem is that I need to do that everytime I turn on the pc, but for my usage of this pc is absolutely ok

User avatar
MrEen
Level 8
Level 8
Posts: 2014
Joined: Mon Jun 12, 2017 8:39 pm

Re: Pulseaudio does not work

Post by MrEen » Sat Nov 17, 2018 11:46 am

That indicates to me that you had permission issues. It is working when you start pulseaudio as root, but not as your normal user.

A better fix would be to repair the permissions in your home directory.

You can see the files with issues with find $HOME ! -user $USER

A fix for this is sudo chown -R $USER:$USER /home/$USER

Good luck.

User avatar
thx-1138
Level 6
Level 6
Posts: 1290
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Pulseaudio does not work

Post by thx-1138 » Sat Nov 17, 2018 12:14 pm

In addition to what MrEen suggested in regards to permissions
(i'm also rather surprised to see sudo -i being being 'needed' before reloading PA),
you could simply add a small script under Startup Applications to do so automatically:

Code: Select all

#!/bin/sh
sleep 10; pulseaudio --start
Or alternatively, depending on how the PA daemon (mis)behaves, the slightly more 'involved':

Code: Select all

#!/bin/sh
sleep 10; pulseaudio -k && pulseaudio --start

Post Reply

Return to “Sound, Multimedia, & Codecs”