Mint 17.3+Skype- no sound

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Mint 17.3+Skype- no sound

Post by Patyk » Sun Nov 18, 2018 4:12 pm

Please, I need help with sound on Mint 17.3.
HW:Notebook Acer 5635Z.

The problem:
After new instal.of Mint 17.3, there is no problem with the sound through the system. For example sound in a movie on YT is ok. But when I instal Skype, and when I log in to the Skype, the notebook is very soon without sound. Nothing help.
I have tried uninstal Pulseaudio and instal it again- no works. I have to reinstal Mint 17.3. and then is sound ok.
I have tried many attemptes of advices which I have find on the Internet. But everything is abou "No sound in Mint 17.3", but no one is joined with the skype.

Is there known any good solution for this?

After last instalation of Mint 17.3, the sound was ok. After inst.of Skype- the sound was ok. After of using of Skype - the sound was ok. But after disable the skype in " Apps launched after log in" (in Menu of Linux) (I do not know exact English name of this- I use different lang.version.) the sound is dead again. Off course, I have tried the skype allow to launch again in the Apps launched... but without success.

In preview instal.of the Mint I did not watch the causality yet. So I do not know what happened before the sound collapsed.

Thank you
Patyk

SolidState
Level 1
Level 1
Posts: 6
Joined: Wed Nov 14, 2018 9:06 pm

Re: Mint 17.3+Skype- no sound

Post by SolidState » Sun Nov 18, 2018 9:46 pm

I have seen this issue on my desktop machine install of mint 17.3, If you open the sound properties/preferences applet and see what sound device is the default. test the speakers and microphone. Do you use another device for skype, other than the native sound hardware of the laptop? perhaps a USB headset? You can see what is active and muted or turned off/disabled. Have a look at the sound preferences by right clicking on the speaker icon in the panel.

If you have done this with the sound preferences, and are using a USB headset and still have no sound, you might want to try the following:

Disable the native sound system in the laptop itself through the sound perferences.
If using a USB headset, and try doing a cold boot of the machine with the headset pluged in.

There are a few settings in skype to set but I cannot recall them now because I am now on Mint 19 without skype. Sound was a bit of a bother for me on 17.x thats for sure. :wink:

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Mon Nov 19, 2018 3:15 am

Thank you for quick answer.

I do not use any peripheries on the Notebook. Only native HW.

Actually i am not on the notebook. At evening I will check the properties of the sound again. And then I will post here what there is set.

Thank you

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Mon Nov 19, 2018 3:17 pm

I have checked the preferences of the sound. On the list Hardware there is only possibility "Analog duplex stereo". And on the list Output there is again only possibility "Inner sound system analog stereo".
The test of the sound: Completely silent/ no sound.

Thank you for your help

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Sun Nov 25, 2018 4:00 pm

any idea?

I have set the volume on max. And there is very thin sound from the played stream. But only from left speaker. There is strange thing. When I plug in headsphones, no sound comes from hp, but still from the speaker

Thank you

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 17.3+Skype- no sound

Post by MrEen » Sun Nov 25, 2018 4:05 pm

Hi Patyk.

Try deleting the files in ~/.config/pulse then run pulseaudio -k in the terminal. If you're testing with your browser, restart that as well afterwards. Does this get sound working again?

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Sun Nov 25, 2018 4:59 pm

Thank you
Before I will try your advice, I have to tell here one more thing. I tried live DVD Mint 17.3 and there is no sound too.

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 17.3+Skype- no sound

Post by MrEen » Sun Nov 25, 2018 5:04 pm

Assuming the sound card isn't dead, run alsamixer in the terminal and check for mutes. Columns with MM at the bottom are muted. Use left/right arrows to change columns, up/down arrows to change levels, and the m key to toggle mute/unmute.

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Mon Nov 26, 2018 11:01 am

New information

From live DVD the sound works. I do know why, but actually from the DVD works. I have installed new installation and the sound is now working.

I have tested wire connection of the speakers to MB and it is OK(I had the NB disassembled).


Is there any way, how to find out a setting now, when it works?

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 17.3+Skype- no sound

Post by MrEen » Mon Nov 26, 2018 4:46 pm

Now that it's working, you can type alsactl store in the terminal.

That will save the configuration of all sound cards to /etc/asound.state

If, in the future, your sound gets messed up, alsactl restore should revert back to the saved settings. You should probably delete the files in ~/.config/pulse first before ever trying the restore command. I have never used that command so I cannot comment on its effectiveness.

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Mon Nov 26, 2018 6:18 pm

Thank you

The terminal gave me this messages
alsactl: state_lock:121: file /var/lib/alsa/asound.state lock error: File exists

alsactl: state_lock:121: file /var/lib/alsa/asound.state unlock error: File exists

Is it correct?

thank you

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 17.3+Skype- no sound

Post by MrEen » Mon Nov 26, 2018 6:33 pm

Okay, maybe the instructions I read are out of date. Seems /var/lib/alsa/asound.state is now the location, and it would seem you need to use sudo on the command.

Try sudo alsactl store instead.

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Tue Nov 27, 2018 5:14 am

yes. with the sudo it works. Thank you.

Actually I test the NB without instal. the Skype. Later I will report here the result.

Thank you for your help and time

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Mon Dec 03, 2018 5:08 pm

Hello here.
I have new info.

Mint worked for a week without Skype. I used only FF and some videos through FF like on YT.

Yesterday at evening, I turned off the NB. Today at morning I turned on the NB and the sound is dead again.
I have try the command "sudo alsactl restore" but it does not work. I tried it even without the "sudo", but it does not work too.

I have checked setting of the sound (properties on the panel- icon of the speaker) and is completely same as the setting after new installation.

Is there any idea what to do?

Thank you

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 17.3+Skype- no sound

Post by MrEen » Mon Dec 03, 2018 5:13 pm

Start something that has sound, then in the terminal type pacmd list-sinks and paste the output back here.

There's a very decent chance I'll be able to figure out what's wrong from that output.

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Tue Dec 04, 2018 3:03 am

Thank you, here it is.

Welcome to PulseAudio! Use "help" for usage information.
>>> 1 sink(s) available.
* index: 0
name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: RUNNING
suspend cause:
priority: 9959
volume: 0: 100% 1: 100%
0: 0,00 dB 1: 0,00 dB
balance 0,00
base volume: 100%
0,00 dB
volume steps: 65537
muted: no
current latency: 22,30 ms
max request: 4 KiB
max rewind: 64 KiB
monitor source: 0
sample spec: s16le 2ch 48000Hz
channel map: front-left,front-right
Stereo
used by: 1
linked by: 1
configured latency: 25,00 ms; range is 1,00 .. 341,33 ms
card: 0 <alsa_card.pci-0000_00_1b.0>
module: 4
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "CX20561 Analog"
alsa.id = "CX20561 Analog"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "HDA Intel"
alsa.long_card_name = "HDA Intel at 0xf0700000 irq 29"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1b.0"
sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "293e"
device.product.name = "82801I (ICH9 Family) HD Audio Controller"
device.form_factor = "internal"
device.string = "front:0"
device.buffering.buffer_size = "65536"
device.buffering.fragment_size = "32768"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Analogové stereo"
device.description = "Vnitřní zvukový systém Analogové stereo"
alsa.mixer_name = "Conexant CX20561 (Hermosa)"
alsa.components = "HDA:14f15051,10250253,00100000"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
analog-output-speaker: Analogové stereo (priority 10000, latency offset 0 usec, available: unknown)
properties:
device.icon_name = "audio-speakers"
analog-output-headphones: Analogová sluchátka (priority 9000, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-headphones"
active port: <analog-output-speaker>

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Tue Dec 04, 2018 3:42 pm

I am testing live Fedora 29. The sound is dead. It is same as before Mint 17.3 live.

pacmd list-sinks

1 sink(s) available.
* index: 0
name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
driver: <module-alsa-card.c>
flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: SUSPENDED
suspend cause: IDLE
priority: 9039
volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 0.00 ms
max request: 0 KiB
max rewind: 0 KiB
monitor source: 0
sample spec: s16le 2ch 48000Hz
channel map: front-left,front-right
Stereo
used by: 0
linked by: 1
configured latency: 0.00 ms; range is 0.50 .. 1837.50 ms
card: 0 <alsa_card.pci-0000_00_1b.0>
module: 6
properties:
alsa.resolution_bits = "16"
device.api = "alsa"
device.class = "sound"
alsa.class = "generic"
alsa.subclass = "generic-mix"
alsa.name = "CX20561 Analog"
alsa.id = "CX20561 Analog"
alsa.subdevice = "0"
alsa.subdevice_name = "subdevice #0"
alsa.device = "0"
alsa.card = "0"
alsa.card_name = "HDA Intel"
alsa.long_card_name = "HDA Intel at 0xf0700000 irq 25"
alsa.driver_name = "snd_hda_intel"
device.bus_path = "pci-0000:00:1b.0"
sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
device.bus = "pci"
device.vendor.id = "8086"
device.vendor.name = "Intel Corporation"
device.product.id = "293e"
device.product.name = "82801I (ICH9 Family) HD Audio Controller"
device.form_factor = "internal"
device.string = "front:0"
device.buffering.buffer_size = "352800"
device.buffering.fragment_size = "176400"
device.access_mode = "mmap+timer"
device.profile.name = "analog-stereo"
device.profile.description = "Analog Stereo"
device.description = "Built-in Audio Analog Stereo"
alsa.mixer_name = "Conexant CX20561 (Hermosa)"
alsa.components = "HDA:14f15051,10250253,00100000"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card-pci"
ports:
analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
properties:
device.icon_name = "audio-speakers"
analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
properties:
device.icon_name = "audio-headphones"
active port: <analog-output-speaker>

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 17.3+Skype- no sound

Post by MrEen » Tue Dec 04, 2018 4:31 pm

I'm sorry Patyk. Your output looks good other than speakers being unavailable.

Delete the files ~/.config/pulse then run pulseaudio -k in the terminal. Then restart whatever you're playing sound on and test.

After that, all I can suggest at this time is to try a complete shutdown, wait a full minute, than power back up and test.

Good luck.

Patyk
Level 1
Level 1
Posts: 14
Joined: Sun Nov 18, 2018 3:26 pm

Re: Mint 17.3+Skype- no sound

Post by Patyk » Tue Dec 04, 2018 5:10 pm

Thank you very much Mr.Een.

Pulseaudio -k works for me. Even I did not need to restart NB.

Is there any chance to find out why the pulseaudio(or NB?) do this? What goes wrong? Is it the soundcard almost dead? Why was sound unavailable even under live USB distro(Fedora 28/29)? Even with installation of Win7? No sound under these distros/installation. And then after the Pulseaudio -k sound works well

Thank you again

User avatar
MrEen
Level 7
Level 7
Posts: 1964
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint 17.3+Skype- no sound

Post by MrEen » Tue Dec 04, 2018 5:36 pm

I can't answer about Fedora as I have no experience with it. Maybe pulseaudio needed to be started manually first?

Deleting the files in ~/.config/pulse makes pulseaudio generate a fresh set of configuration files. It's impossible to say how they got corrupted, but it happens. Running pulseaudio -k afterwards makes pulseaudio restart after the fresh configuration files have loaded. More accurately, it kills the running daemon, which then automatically respawns.

Keep that instruction handy. It appears you may need to use it every once in a while.

Good luck.

Post Reply

Return to “Sound, Multimedia, & Codecs”