Cant Use External mic, using hw mic jack

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Cant Use External mic, using hw mic jack

Post by eMINT » Sat Jan 05, 2019 11:30 pm

hi!, nor headphones or external mic where detected when plugged in.

i force the headphones with this cmmd

Code: Select all

#Send Audio to Headphones
sudo hda-verb /dev/snd/hwC0D0 0x0f SET_PIN_WIDGET_CONTROL 0xc0

#Mute Audio of Headphones
sudo hda-verb /dev/snd/hwC0D0 0x0f SET_PIN_WIDGET_CONTROL 0x0

#Send Audio to Speakers
sudo hda-verb /dev/snd/hwC0D0 0x0b SET_PIN_WIDGET_CONTROL 0xc0

#Mute Audio of Speakers
sudo hda-verb /dev/snd/hwC0D0 0x0b SET_PIN_WIDGET_CONTROL 0x0
but can figure out how to do the same to record from external mic, built in mic is working


inxi -Fxz

Code: Select all

System:    Host: blablabla Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.4.4 (Gtk 2.24.30) Distro: Linux Mint 18 Sarah
Machine:   System: Alienware product: Alienware 15 R2 v: 1.2.14
           Mobo: Alienware model: Alienware 15 R2 v: A00 Bios: Alienware v: 1.2.14 date: 06/02/2016
CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20737
           clock speeds: max: 3500 MHz 1: 899 MHz 2: 880 MHz 3: 899 MHz 4: 899 MHz 5: 857 MHz 6: 899 MHz
           7: 849 MHz 8: 838 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA GM204M [GeForce GTX 970M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card-1: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx port: d000 bus-ID: 3b:00.0
           IF: enp59s0 state: down mac: <filter>
           Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 3c:00.0
           IF: wlp60s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (21.9% used) ID-1: /dev/nvme1n1 model: N/A size: 256.1GB
           ID-2: /dev/nvme0n1 model: N/A size: 256.1GB ID-3: /dev/sda model: ST1000LM044_HN size: 1000.2GB
Partition: ID-1: / size: 172G used: 143G (88%) fs: ext4 dev: /dev/nvme0n1p3
           ID-2: swap-1 size: 68.72GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 310 Uptime: 15 min Memory: 3616.6/32042.9MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
aplay -l

Code: Select all

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

arecord -l

Code: Select all

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: CA0132 Analog Mic-In2 [CA0132 Analog Mic-In2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 4: CA0132 What U Hear [CA0132 What U Hear]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
amixer -c0 controls | grep -i mic

Code: Select all

numid=27,iface=CARD,name='Mic Phantom Jack'
numid=22,iface=MIXER,name='Mic SVM Capture Switch'
numid=9,iface=MIXER,name='Mic1-Boost (30dB) Capture Switch'
numid=13,iface=MIXER,name='AMic1/DMic Auto Detect Capture Switch'
numid=11,iface=MIXER,name='AMic1/DMic Capture Switch'
numid=6,iface=MIXER,name='Analog-Mic2 Capture Switch'
numid=5,iface=MIXER,name='Analog-Mic2 Capture Volume'


cat /proc/asound/card*/codec\#*

Code: Select all

Codec: Creative CA0132
Address: 0
AFG Function Id: 0x1 (unsol 1)
Vendor Id: 0x11020011
Subsystem Id: 0x10280708
Revision Id: 0x100918
No Modem Function Group found
Default PCM:
    rates [0x0]:
    bits [0x0]:
    formats [0x0]:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
State of AFG node 0x01:
  Power states:  D0 D3 D3cold S3D3cold CLKSTOP EPSS
  Power: setting=D0, actual=D0
GPIO: io=0, o=0, i=0, unsolicited=1, wake=1
Node 0x02 [Audio Output] wcaps 0x49d: Stereo Amp-Out
  Device: name="CA0132 Analog", type="Audio", device=0
  Amp-Out caps: ofs=0x5a, nsteps=0x63, stepsize=0x03, mute=1
  Amp-Out vals:  [0x4f 0x4f]
  Converter: stream=0, channel=0
  PCM:
    rates [0x5e4]: 16000 44100 48000 88200 96000 192000
    bits [0x1f]: 8 16 20 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x03 [Audio Output] wcaps 0x49d: Stereo Amp-Out
  Amp-Out caps: ofs=0x5a, nsteps=0x63, stepsize=0x03, mute=1
  Amp-Out vals:  [0x5a 0x5a]
  Converter: stream=0, channel=0
  PCM:
    rates [0x5e4]: 16000 44100 48000 88200 96000 192000
    bits [0x1f]: 8 16 20 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x04 [Audio Output] wcaps 0x49d: Stereo Amp-Out
  Amp-Out caps: ofs=0x5a, nsteps=0x63, stepsize=0x03, mute=1
  Amp-Out vals:  [0x5a 0x5a]
  Converter: stream=0, channel=0
  PCM:
    rates [0x5e4]: 16000 44100 48000 88200 96000 192000
    bits [0x1f]: 8 16 20 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x05 [Audio Output] wcaps 0x691: Stereo Digital
  Control: name="IEC958 Playback Con Mask", index=16, device=0
  Control: name="IEC958 Playback Pro Mask", index=16, device=0
  Control: name="IEC958 Playback Default", index=16, device=0
  Control: name="IEC958 Playback Switch", index=16, device=0
  Control: name="IEC958 Default PCM Playback Switch", index=0, device=0
  Device: name="CA0132 Digital", type="SPDIF", device=1
  Converter: stream=0, channel=0
  Digital: Enabled
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x5e0]: 44100 48000 88200 96000 192000
    bits [0x1e]: 16 20 24 32
    formats [0x5]: PCM AC3
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x06 [Audio Output] wcaps 0x691: Stereo Digital
  Converter: stream=0, channel=0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x5e0]: 44100 48000 88200 96000 192000
    bits [0x1e]: 16 20 24 32
    formats [0x5]: PCM AC3
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x07 [Audio Input] wcaps 0x100591: Stereo
  Device: name="CA0132 Analog", type="Audio", device=0
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x1e4]: 16000 44100 48000 88200 96000
    bits [0x1f]: 8 16 20 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x12
Node 0x08 [Audio Input] wcaps 0x10059b: Stereo Amp-In
  Control: name="Analog-Mic2 Capture Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="Analog-Mic2 Capture Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Device: name="CA0132 Analog Mic-In2", type="Audio", device=2
  Amp-In caps: ofs=0x5a, nsteps=0x63, stepsize=0x03, mute=1
  Amp-In vals:  [0x5a 0x5a]
  Converter: stream=0, channel=0
  SDI-Select: 0
  PCM:
    rates [0x1e4]: 16000 44100 48000 88200 96000
    bits [0x1f]: 8 16 20 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x11
Node 0x09 [Audio Input] wcaps 0x100791: Stereo Digital
  Control: name="IEC958 Capture Switch", index=0, device=0
  Control: name="IEC958 Capture Default", index=0, device=0
  Device: name="CA0132 Digital", type="SPDIF", device=1
  Converter: stream=0, channel=0
  SDI-Select: 0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x1f0]: 32000 44100 48000 88200 96000
    bits [0x1a]: 16 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x0e
Node 0x0a [Audio Input] wcaps 0x10079b: Stereo Digital Amp-In
  Control: name="What U Hear Capture Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Control: name="What U Hear Capture Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Device: name="CA0132 What U Hear", type="Audio", device=4
  Amp-In caps: ofs=0x5a, nsteps=0x63, stepsize=0x03, mute=1
  Amp-In vals:  [0x5a 0x5a]
  Converter: stream=0, channel=0
  SDI-Select: 0
  Digital:
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x1ec]: 16000 22050 44100 48000 88200 96000
    bits [0x1b]: 8 16 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x13
Node 0x0b [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x00010014: OUT EAPD Detect
  EAPD 0x2: EAPD
  Pin Default 0x01014010: [Jack] Line Out at Ext Rear
    Conn = 1/8, Color = Green
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x40: OUT
  Unsolicited: tag=05, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x02
Node 0x0c [Pin Complex] wcaps 0x400701: Stereo Digital
  Pincap 0x00000010: OUT
  Pin Default 0x014580f0: [Jack] SPDIF Out at Ext Rear
    Conn = Optical, Color = Purple
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x00:
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x05
Node 0x0d [Pin Complex] wcaps 0x400701: Stereo Digital
  Pincap 0x00000010: OUT
  Pin Default 0x014570f0: [Jack] SPDIF Out at Ext Rear
    Conn = Optical, Color = Yellow
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x00:
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x06
Node 0x0e [Pin Complex] wcaps 0x400681: Stereo Digital
  Pincap 0x00000020: IN
  Pin Default 0x01c530f0: [Jack] SPDIF In at Ext Rear
    Conn = Optical, Color = Blue
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x0f [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0000001c: OUT HP Detect
  Pin Default 0x0221401f: [Jack] HP Out at Ext Front
    Conn = 1/8, Color = Green
    DefAssociation = 0x1, Sequence = 0xf
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x02
Node 0x10 [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x0000001c: OUT HP Detect
  Pin Default 0x02216011: [Jack] HP Out at Ext Front
    Conn = 1/8, Color = Orange
    DefAssociation = 0x1, Sequence = 0x1
  Pin-ctls: 0x00:
  Unsolicited: tag=01, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x03
Node 0x11 [Pin Complex] wcaps 0x40058b: Stereo Amp-In
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00]
  Pincap 0x00000134: IN OUT Detect
    Vref caps: HIZ
  Pin Default 0x02012014: [Jack] Line Out at Ext Front
    Conn = 1/8, Color = Grey
    DefAssociation = 0x1, Sequence = 0x4
  Pin-ctls: 0x20: IN VREF_HIZ
  Unsolicited: tag=04, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x04
Node 0x12 [Pin Complex] wcaps 0x400481: Stereo
  Control: name="Mic1-Boost (30dB) Capture Switch", index=0, device=0
    ControlAmp: chs=1, dir=In, idx=0, ofs=0
  Pincap 0x00003724: IN Detect
    Vref caps: HIZ 50 GRD 80 100
  Pin Default 0x37a791f0: [Jack] Mic at Oth Mobile-In
    Conn = Analog, Color = Pink
    DefAssociation = 0xf, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=02, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x13 [Pin Complex] wcaps 0x400681: Stereo Digital
  Pincap 0x00000020: IN
  Pin Default 0x908700f0: [Fixed] Line In at Int N/A
    Conn = Analog, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x20: IN
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x14 [Beep Generator Widget] wcaps 0x70040c: Mono Amp-Out
  Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=1
  Amp-Out vals:  [0x1c]
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x15 [Vendor Defined Widget] wcaps 0xf00600: Mono Digital
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x16 [Vendor Defined Widget] wcaps 0xf00680: Mono Digital
  Unsolicited: tag=03, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x17 [Audio Output] wcaps 0x49d: Stereo Amp-Out
  Amp-Out caps: ofs=0x5a, nsteps=0x63, stepsize=0x03, mute=1
  Amp-Out vals:  [0x5a 0x5a]
  Converter: stream=0, channel=0
  PCM:
    rates [0x5ec]: 16000 22050 44100 48000 88200 96000 192000
    bits [0x1f]: 8 16 20 24 32
    formats [0x1]: PCM
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x18 [Pin Complex] wcaps 0x400581: Stereo
  Pincap 0x00000010: OUT
  Pin Default 0x500000f0: [N/A] Line Out at Int N/A
    Conn = Unknown, Color = Unknown
    DefAssociation = 0xf, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 1
     0x17
Codec: Intel Skylake HDMI
Address: 2
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x80862809
Subsystem Id: 0x80860101
Revision Id: 0x100000
No Modem Function Group found
Default PCM:
    rates [0x0]:
    bits [0x0]:
    formats [0x0]:
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
State of AFG node 0x01:
  Power states:  D0 D3 CLKSTOP EPSS
  Power: setting=D0, actual=D0, Clock-stop-OK
GPIO: io=0, o=0, i=0, unsolicited=0, wake=0
Node 0x02 [Audio Output] wcaps 0x6611: 8-Channels Digital
  Converter: stream=0, channel=0
  Digital: KAE
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0x1a]: 16 24 32
    formats [0x5]: PCM AC3
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x03 [Audio Output] wcaps 0x6611: 8-Channels Digital
  Converter: stream=0, channel=0
  Digital: Enabled KAE
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0x1a]: 16 24 32
    formats [0x5]: PCM AC3
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x04 [Audio Output] wcaps 0x6611: 8-Channels Digital
  Converter: stream=0, channel=0
  Digital: Enabled KAE
  Digital category: 0x0
  IEC Coding Type: 0x0
  PCM:
    rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
    bits [0x1a]: 16 24 32
    formats [0x5]: PCM AC3
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
Node 0x05 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
  Control: name="IEC958 Playback Con Mask", index=0, device=0
  Control: name="IEC958 Playback Pro Mask", index=0, device=0
  Control: name="IEC958 Playback Default", index=0, device=0
  Control: name="IEC958 Playback Switch", index=0, device=0
  Control: name="ELD", index=0, device=3
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x0b000094: OUT Detect HBR HDMI DP
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=01, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Devices: 0
  Connection: 0
  In-driver Connection: 3
     0x02 0x03 0x04
Node 0x06 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
  Control: name="IEC958 Playback Con Mask", index=1, device=0
  Control: name="IEC958 Playback Pro Mask", index=1, device=0
  Control: name="IEC958 Playback Default", index=1, device=0
  Control: name="IEC958 Playback Switch", index=1, device=0
  Control: name="ELD", index=0, device=7
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x0b000094: OUT Detect HBR HDMI DP
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=02, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Devices: 0
  Connection: 0
  In-driver Connection: 3
     0x02 0x03 0x04
Node 0x07 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
  Control: name="IEC958 Playback Con Mask", index=2, device=0
  Control: name="IEC958 Playback Pro Mask", index=2, device=0
  Control: name="IEC958 Playback Default", index=2, device=0
  Control: name="IEC958 Playback Switch", index=2, device=0
  Control: name="ELD", index=0, device=8
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals:  [0x00 0x00]
  Pincap 0x0b000094: OUT Detect HBR HDMI DP
  Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
    Conn = Digital, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
  Pin-ctls: 0x00:
  Unsolicited: tag=03, enabled=1
  Power states:  D0 D3 EPSS
  Power: setting=D0, actual=D0
  Devices: 0
  Connection: 0
  In-driver Connection: 3
     0x02 0x03 0x04
Node 0x08 [Vendor Defined Widget] wcaps 0xf00000: Mono

Can someone help me? it doesnt matter if i had to doit in the commd line, just need that working for video calls, builtin mic is getting room noise, and toher people arround me thx.

PD. i cant update the OS. its a LTS version and i cant touch untill its ended (work machine) thx

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: Cant Use External mic, using hw mic jack

Post by MrEen » Sun Jan 06, 2019 12:07 am

Hi eMINT.
PD. i cant update the OS. its a LTS version and i cant touch untill its ended (work machine) thx
Does this mean you can't even apply updates? I think that's the original kernel from the install that has since has dozens of security updates!

Are you allowed to install software for the Software Manager? PulseAudio Volume Control will probably help get the external mic working. Also, running alsamixer in the terminal may help as I saw this: CA0132 Analog Mic-In2 ... mute=1

When alsamixer opens, press F6 to select the CA0132 Analog option, then use the arrow keys to get to the mic column that has MM at the bottom and press the m key to unmute it. You can also use the up/down arrow to change levels if you wish.

Hope that helps.

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sun Jan 06, 2019 10:11 pm

MrEen wrote:
Sun Jan 06, 2019 12:07 am
Hi eMINT.
PD. i cant update the OS. its a LTS version and i cant touch untill its ended (work machine) thx
Does this mean you can't even apply updates? I think that's the original kernel from the install that has since has dozens of security updates!

Are you allowed to install software for the Software Manager?
yes i can ask for permission and do that, the kernel is updated i think. i mean that i cant do a fresh install of last version of Linux Mint

Code: Select all

uname -a
Linux machinename 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
i will try your option and come back with feedback

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: Cant Use External mic, using hw mic jack

Post by MrEen » Sun Jan 06, 2019 10:23 pm

The latest 4.4 kernel is 4.4.0-141. I just counted and there have been 60 versions from yours to the latest. Just letting you know. You might want to let the bosses know. That kernel has not been patched for Spectre and Meltdown vulnerabilities for example.

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sun Jan 06, 2019 10:32 pm

Selection_061.png
Selection_060.png

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sun Jan 06, 2019 10:33 pm

ALSA hda-verb.txt
(1.5 KiB) Downloaded 33 times
Selection_063.png
Selection_064.png

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sun Jan 06, 2019 10:40 pm

Selection_066.png

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sun Jan 06, 2019 10:43 pm

MrEen wrote:
Sun Jan 06, 2019 12:07 am
When alsamixer opens, press F6 to select the CA0132 Analog option, then use the arrow keys to get to the mic column that has MM at the bottom and press the m key to unmute it. You can also use the up/down arrow to change levels if you wish.

Hope that helps.
F6 does nothing. i dont find where to quit that mute, do you know how to doit by cmmd line?

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: Cant Use External mic, using hw mic jack

Post by MrEen » Sun Jan 06, 2019 11:00 pm

eMINT wrote:
Sun Jan 06, 2019 10:43 pm
MrEen wrote:
Sun Jan 06, 2019 12:07 am
When alsamixer opens, press F6 to select the CA0132 Analog option, then use the arrow keys to get to the mic column that has MM at the bottom and press the m key to unmute it. You can also use the up/down arrow to change levels if you wish.

Hope that helps.
F6 does nothing. i dont find where to quit that mute, do you know how to doit by cmmd line?
In the terminal just type alsamixer not gnome-alsamixer, although your pavucontrol screenshot makes me think the mic isn't muted after all. What Profile is selected on the Configuration tab of pavucontrol?

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: Cant Use External mic, using hw mic jack

Post by MrEen » Sun Jan 06, 2019 11:07 pm

I have to go for several hours. I'm hoping your Profile is set as Digital instead of Analog Stereo Duplex. If so, change it to Analog Stereo Duplex and the mic might start working.

Good luck.

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sun Jan 06, 2019 11:39 pm

that one is selected
Selection_060.png

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: Cant Use External mic, using hw mic jack

Post by MrEen » Mon Jan 07, 2019 8:22 am

Have you tested the mic recently? In your first post you said the mic wasn't being detected when plugged in, but it appears to be detected now.

If it's not working, what program are you trying to use the mic with?

Also, while trying to use the mic in that program, what does the Recording tab of pavucontrol show? Does the bar under the volume slider show movement when you're talking into the mic?

It is possible the program is trying to use alsa directly. If you can change it to using pulse (or pulseaudio) that may get it working.

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Mon Jan 07, 2019 9:23 am

MrEen wrote:
Mon Jan 07, 2019 8:22 am
Have you tested the mic recently? In your first post you said the mic wasn't being detected when plugged in, but it appears to be detected now.

If it's not working, what program are you trying to use the mic with?

Also, while trying to use the mic in that program, what does the Recording tab of pavucontrol show? Does the bar under the volume slider show movement when you're talking into the mic?

It is possible the program is trying to use alsa directly. If you can change it to using pulse (or pulseaudio) that may get it working.
yes tested the mic after every change. recording audio with Audacity, only gets audio from bultin mic, not external

pavucontrol shows audacity recording. but it dont get audio from external mic. the mute is always in 1, in the cat /proc/asound/card*/codec\#*

Audacity only option available is ALSA
Selection_061.png
Selection_060.png

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: Cant Use External mic, using hw mic jack

Post by MrEen » Mon Jan 07, 2019 3:26 pm

I am going to take a few stabs in the dark here:

1. In the terminal, type arecord -d 10 /tmp/test-mic.wav and speak into the mic for 10 seconds. When it's done, type aplay /tmp/test-mic.wav and see if that works properly.

2. In your opening post, you mentioned headphones and mic not being detected when plugged in. Is there any possibility you have each plugged in to the others port? I'm not trying to treat you like an idiot, we've all done silly things like that.

3. My Audacity preferences show just default for Recording Device, while yours has default: Neutral:0 so I wonder if that is causing the issue. Is there an option for just default?

4. If all of that was no help, try deleting the files in /home/YourUserName/.config/pulse then run pulseaudio -k in the terminal. That will delete pulseaudio's configuration files and generate a fresh set. Wait a few seconds then test again.

Hopefully one of those gets you working as I'm running out of ideas.

User avatar
MrEen
Level 13
Level 13
Posts: 4521
Joined: Mon Jun 12, 2017 8:39 pm

Re: Cant Use External mic, using hw mic jack

Post by MrEen » Wed Jan 09, 2019 10:52 pm

One more idea. On the Recording tab of pavucontrol, click on the Lock icon. Now you'll see two channels. Lower one side all the way and test the mic. If that doesn't work, raise the one you lowered and lower the other one all the way and test again.

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Thu Jan 10, 2019 7:25 pm

been really busy need to test

you have each plugged in to the others port?

thats not the case

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sat Jan 12, 2019 8:16 am

Code: Select all

1. In the terminal, type arecord -d 10 /tmp/test-mic.wav and speak into the mic for 10 seconds. When it's done, type aplay /tmp/test-mic.wav and see if that works properly.
that records, but from the internal mic, next to the webcam, itrs not recording from the plugged mic in the jack

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sat Jan 12, 2019 8:18 am

Code: Select all

3. My Audacity preferences show just default for Recording Device, while yours has default: Neutral:0 so I wonder if that is causing the issue. Is there an option for just default?
put to default, problem continues

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sat Jan 12, 2019 8:20 am

MrEen wrote:
Wed Jan 09, 2019 10:52 pm
One more idea. On the Recording tab of pavucontrol, click on the Lock icon. Now you'll see two channels. Lower one side all the way and test the mic. If that doesn't work, raise the one you lowered and lower the other one all the way and test again.
nothing

User avatar
eMINT
Level 2
Level 2
Posts: 90
Joined: Sat Feb 27, 2010 1:06 am

Re: Cant Use External mic, using hw mic jack

Post by eMINT » Sat Jan 12, 2019 8:22 am

Code: Select all

4. If all of that was no help, try deleting the files in /home/YourUserName/.config/pulse then run pulseaudio -k in the terminal. That will delete pulseaudio's configuration files and generate a fresh set. Wait a few seconds then test again.
problem persists

Post Reply

Return to “Sound, Multimedia, & Codecs”