Page 1 of 1

[SOLVED] CD burning software?

Posted: Fri May 17, 2019 9:10 pm
by Fredashay
I've been unable to burn an audio CD on Linux.

Mint came with K3b, but it requires me to first convert my MP3 music to wave format. Okay, I converted my MP3s to WAV with Audacity. But when I try to load my WAV files into K3b, it still complains that it's not in wave format.

I then installed Brasero. I can burn one or two MP3 files to a CD just fine and they play back on my stereo just fine. Brasero will even burn a MIDI, or OGG, or WAV file directly to a CD with nor problems. That's awesome! But if I try to burn more than about 5 songs to a single CD, Brasero crashes halfway through the burn. I've tried changing up the options, burn the image directly vs. not, using burnproof vs. not using burnproof, etc.

Does anyone have any suggestions? Are there any CD burners out there that actually work?

Here's my system specs:

Host: oof-X10DAi Kernel: 4.15.0-50-generic x86_64 bits: 64
compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.10
Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic
Type: Desktop Mobo: Supermicro model: X10DAi v: 123456789 serial: <filter>
UEFI [Legacy]: American Megatrends v: 1.0a date: 09/24/2014
Topology: 2x Quad Core model: Intel Xeon E5-2623 v3 bits: 64
type: MT MCP SMP arch: Haswell rev: 2 L2 cache: 20.0 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 96023
Speed: 1200 MHz min/max: 1200/3500 MHz Core speeds (MHz): 1: 1200 2: 1200
3: 1203 4: 1201 5: 1201 6: 1203 7: 1201 8: 1203 9: 1200 10: 1201 11: 1201
12: 1200 13: 1200 14: 1201 15: 1200 16: 1202
Device-1: NVIDIA GM107GL [Quadro K620] driver: nvidia v: 390.116
bus ID: 81:00.0
Display: x11 server: X.Org 1.19.6 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 3440x1440~60Hz
OpenGL: renderer: Quadro K620/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116
direct render: Yes
Device-1: Intel C610/X99 series HD Audio vendor: Super Micro
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: NVIDIA driver: snd_hda_intel v: kernel bus ID: 81:00.1
Sound Server: ALSA v: k4.15.0-50-generic
Device-1: Intel I210 Gigabit Network vendor: Super Micro driver: igb
v: 5.4.0-k port: 6000 bus ID: 05:00.0
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel I210 Gigabit Network vendor: Super Micro driver: igb
v: 5.4.0-k port: 5000 bus ID: 06:00.0
IF: enp6s0 state: down mac: <filter>
Local Storage: total: 17.29 TiB used: 9.63 TiB (55.7%)
ID-1: /dev/sda vendor: Western Digital model: WD6003FFBX-68MU3N0
size: 5.46 TiB
ID-2: /dev/sdb vendor: Western Digital model: WD6003FFBX-68MU3N0
size: 5.46 TiB
ID-3: /dev/sdc vendor: Western Digital model: WD1000DHTZ-04N21V0
size: 931.51 GiB
ID-4: /dev/sdd type: USB model: Kindle Internal Storage size: 6.24 GiB
ID-5: /dev/sdf type: USB vendor: Western Digital model: WD60EZRZ-00RWYB1
size: 5.46 TiB
Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSC0 rev: LK00
dev-links: cdrom,cdrw,dvd,dvdrw
Features: speed: 12 multisession: yes audio: yes dvd: yes
rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
ID-1: / size: 916.39 GiB used: 54.31 GiB (5.9%) fs: ext4 dev: /dev/sdc1
System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 41 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 34%
Processes: 345 Uptime: 2h 24m Memory: 125.79 GiB used: 7.72 GiB (6.1%)
Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19
inxi: 3.0.27

Re: CD burning software?

Posted: Sat May 18, 2019 12:37 am
by DAMIEN1307
ive never experienced any problem using xfburn, many people have reported problems with brasero...DAMIEN

Install xfburn

Code: Select all

sudo apt install xfburn

Re: [SOLVED] CD burning software?

Posted: Sat May 18, 2019 10:52 am
by Fredashay
Thank you! Xfburn worked. It even recognized multiple audio formats like MID and OGG. And the CD played back just fine on my stereo. :-)

However, it did have a few problems of its own.

First: There is one MP3 song that it can't see for some reason. It shows up when I click on ADD to add the songs in the folder to Xfburn, but that one song always gets an error message "Resource not found" and doesn't copy it into Xfburn. It's a song I edited with Audacity, so maybe it was stored using a codec not available to Xfburn. But there were several other songs I edited with Audacity that it burned just fine.

Second: If I add songs to the folder I'm working in with File Manager while Xfburn is running, Xfburn doesn't see the new files in the folder when I go to ADD them. It's like Xfburn looks in the folder once when Xfburn stars and doesn't check again as I add and remove songs from the folder. Maybe this is because Xfburn was written for Xfce while I'm using Cinnamon?

I can get around these bugs, but I just thought I'd point them out...

Re: [SOLVED] CD burning software?

Posted: Sat May 18, 2019 11:41 am
by phd21
Hi Fredashay,

I just read your post and the good replies to it. Here are my thoughts on this as well.

+1 for "xfburn"

"K3b" will work very well if it is installed correctly with its supporting packages. I can burn music CD's using many different audio file formats with K3b without having to convert them to .wav files first.

Previous post:
cd burner for mint 19 - Linux Mint Forums

Hope this helps ...

Re: [SOLVED] CD burning software?

Posted: Sat May 18, 2019 3:37 pm
by Fredashay
Follow up about Xfburn. The reason it couldn't find that one MP3 file that I clicked on was because I had a special character in the file name to force it to be the first audio file to play on the CD. When I renamed the song from # First Song.mp3 to Aaa First Song.mp3, it was able to load and burn the song.

phd21 wrote:
Sat May 18, 2019 11:41 am
"K3b" will work very well if it is installed correctly with its supporting packages.
Thanks! I'll keep that in mind if I have problems in the future. But I did have everything K3b-related installed from the primary repository by Software Manager...

Re: [SOLVED] CD burning software?

Posted: Sat May 18, 2019 4:19 pm
by phd21
Hi Fredashay,

Filenames can certainly impact how certain applications work.

"K3b" in Linux Mint 19.x requires some extra considerations explained in the link I provided for it to work well.